phpmyAdmin

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

phpmyAdmin

Postby Nentwig » 21. June 2016 10:41

Hallo Miteinander.
OpenSuse 13.2 Xampp 5.6.21-0
Ich folgendes Problem.
Mit der Konsole kann ich Mysql ( MariaDB) bearbeiten. /opt/lampp/xampp start gibt mir folgende Message aus

Starting XAMPP for Linux 5.6.21-0...
XAMPP: Starting Apache...ok.
XAMPP: Starting MySQL...ok.
XAMPP: Starting ProFTPD...redirecting to systemctl start .service
ok.

Aber der m[b]anager-linux-x64.run kann Mysql nicht starten. phpMyAdmin wird gestartet, kann aber keine Datenbank finden Fehler
#2002 - Datei oder Verzeichnis nicht gefunden — Der Server antwortet nicht (evtl. ist der Socket des lokalen MySQL-Servers nicht korrekt konfiguriert).
im /etc/my.cnf ist mysqlsock als Kommentar.

Jetzt die Frage:
wer Kann mir helfen und wo muss ich überall Aendern ??
Danke für Eure Bemühungen
Nentwig
 
Posts: 2
Joined: 20. June 2016 15:57
XAMPP version: linux-x64-5.6.21-0
Operating System: Opensuse 13.2

Re: phpmyAdmin

Postby Nobbie » 22. June 2016 11:09

Nentwig wrote:/opt/lampp/xampp start gibt mir folgende Message aus

Starting XAMPP for Linux 5.6.21-0...
XAMPP: Starting Apache...ok.
XAMPP: Starting MySQL...ok.
XAMPP: Starting ProFTPD...redirecting to systemctl start .service


Dann ist doch gut, damit ist doch alles gestartet. Die grafische Oberfläche ist nur Schickimicki (und auch nur als Alternative gedacht), da kann ich auch nicht reinschauen, wenn da etwas schief geht und man kann sie auch nicht benutzen, um Xampp automatisch beim Booten zu starten.

MIr fallen sehr wohl zwei Dinge auf:

a) normalerweise muss das Kommando mit root-Rechten, also via "sudo" gestartet werden (so ist es auch dokumentiert)

b) eigentlich soll man das Script /opt/lampp/lampp benutzen, das ist zwar "nur" ein Link auf "xampp", aber auch das ist so dokumentiert und es wäre durchaus denkbar, dass "xampp" irgendwann nicht mehr ausgeliefert wird oder sich anders verhält.

Also insgesamt bitte "sudo /opt/lampp/lampp start" eingeben und danach sollte auch phpmyadmin problemlos laufen.
Nobbie
 
Posts: 8761
Joined: 09. March 2008 13:04

Re: phpmyAdmin

Postby Nentwig » 25. June 2016 10:29

Salue Miteinander.
Ich habe mit viel Mühe phpMyAdmin unter xampp zum laufen gebracht, mit Datenbanken.
Sogar adminer ist gelaufen. Aber Gambas3 fand keine Datenbanken.
Nun habe ich den PC neu aufsetzt wieder mit OpenSuse 13.2.
Wie immer habe ich im Yast2/Dienste den Apache2-Service + Mysql-Service aktiviert.
Kein Problem.
Dabei habe ich festgestellt, das Apache2 Rel. 2.4.10 problemlos läuft während
Rel. 2.4.16 beim aktivieren eine Fehlerlist ausgibt.
Im OpenSuse Leap42.1 wird Rel 2.4.16 installiert!!
Danke für Deine Bemühungen
Nentwig
 
Posts: 2
Joined: 20. June 2016 15:57
XAMPP version: linux-x64-5.6.21-0
Operating System: Opensuse 13.2

Re: phpmyAdmin

Postby Nobbie » 25. June 2016 14:13

Mit dieser Frage sind wir hier leider überfordert, hier wird das Xampp Produkt unterstützt, aber das setzt Du nicht (mehr) ein sondern stattdessen die Tools von OpenSuSE. Das müßtest Du dann auch bei OpenSuSE anfragen.
Nobbie
 
Posts: 8761
Joined: 09. March 2008 13:04


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 6 guests