MYSQL Fails to start and ultimately XAMPP Control crashes

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

MYSQL Fails to start and ultimately XAMPP Control crashes

Postby kimmik » 24. October 2014 12:35

New here so please accept apology for naivety.

On Windows 7 Home Premium, previously had Apache 2.2, PHP 5.3 and MySQL 5.5 running for years without any problem.

Needed to upgrade PHP! So decided to download XAMPP to upgrade all together.

First step was to uninstall previous versions - All OK.

Installed XAMPP package using system admin authority and disabled Firewall (Norton). - All OK

Rebooted PC and ran the XAMPP Control Panel.
"Started" each module in turn
"Apache" - OK
"MYSQL" - Windows opened a "Do you want to allow this program...." "Program Name: Net Command" window - Answered "Yes"
Why didn't this happen when Apache was started?
The Control Panel shows the following message:
[mysql] Attempting to start MySQL service...
and nothing else happens.

Starting other modules FileZilla, Mercury and TomCat proceed without a problem
Another attempt at starting MYSQL results in the same "Permission request" and no start.

going to http://localhost/xampp/index.php shows everything active EXCEPT MYSQL marked as deactivated and no hints

After several minutes Microsoft just shuts down the Control Panel

Thanks in advance for any help with getting MYSQL up and running.
kimmik
 
Posts: 20
Joined: 24. October 2014 12:08
Operating System: Windows 7 Home Premium

Re: MYSQL Fails to start and ultimately XAMPP Control crashe

Postby Altrea » 24. October 2014 12:38

mysql_error.log contents?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: MYSQL Fails to start and ultimately XAMPP Control crashe

Postby kimmik » 24. October 2014 14:30

The mysql_error.log was empty!

I tried to run c:\XAMPP\mysql_start.bat in an admin enabled command window. This appeared to run ok.

Shutdown again and restart the XAMPP Control Panel and everything seemed to start ok.

It has now been running for about an hour - Now to see if the MySQL tools still work and to put some data into it.

Thanks for your help - though I guess it will be one of those life's unsolved mysteries.
kimmik
 
Posts: 20
Joined: 24. October 2014 12:08
Operating System: Windows 7 Home Premium


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 2 guests