Probleme beim Anlegen von InnoDB

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

Probleme beim Anlegen von InnoDB

Postby ositron » 11. August 2004 21:41

Hallo, ich habe eine neue Datenbank über die mysql Konsole angelegt und als 'TYPE=InnoDB' angegeben.

MySQL macht daraus aber immer Tabellen vom Typ MyISAM, zumindest wird das als Tabellentyp angezeigt, wenn ich einen Dump ziehe. Auch die referenzielle Integrität ist nicht gewährleistet.

Hat jemand eine Ahnung, warum der Tabellentyp InnoDB von MySQL anscheinend ignoriert wird?
ositron
 
Posts: 5
Joined: 06. August 2004 23:17

Postby Wiedmann » 11. August 2004 22:55

evtl. mußt du InnoDB erst in der my.ini/my.cnf aktivieren.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby ositron » 12. August 2004 16:37

Hallo danke erstmal für den Hinweis. Habe auch versucht im Manual etwas dazu zu finden, aber als Anfänger hat mir das dann doch nicht weitergeholfen.

Falls mir jemand erklären kann, wie ich unter Windows nach der XAMPP-Installation (neueste Distribution) die InnoDB aktivieren kann, wäre das toll. Danke!
ositron
 
Posts: 5
Joined: 06. August 2004 23:17

Postby jsb » 26. August 2004 20:23

ositron wrote:Hallo danke erstmal für den Hinweis. Habe auch versucht im Manual etwas dazu zu finden, aber als Anfänger hat mir das dann doch nicht weitergeholfen.

Falls mir jemand erklären kann, wie ich unter Windows nach der XAMPP-Installation (neueste Distribution) die InnoDB aktivieren kann, wäre das toll. Danke!

suche auf deinem Rechner eine der folgenden Dateien my.ini oder my.cnf
in dieser datei findest du einen Abschnitt:

skip-innodb
# Uncomment the following if you are using InnoDB tables
#innodb_data_home_dir = /xampp/mysql/
#innodb_data_file_path = ibdata1:10M:autoextend
#innodb_log_group_home_dir = /xampp/mysql/
#innodb_log_arch_dir = /xampp/mysql/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
#set-variable = innodb_buffer_pool_size=16M
#set-variable = innodb_additional_mem_pool_size=2M
# Set .._log_file_size to 25 % of buffer pool size
#set-variable = innodb_log_file_size=5M
#set-variable = innodb_log_buffer_size=8M
#innodb_flush_log_at_trx_commit=1
#set-variable = innodb_lock_wait_timeout=50

Bei diesen Zeilen mußt du wie es oben steht das '#' Zeichen am Anfang entfernen
Danach sollte es so aussehen
# skip-innodb
# Uncomment the following if you are using InnoDB tables
nnodb_data_home_dir = /xampp/mysql/
nnodb_data_file_path = ibdata1:10M:autoextend
nnodb_log_group_home_dir = /xampp/mysql/
nnodb_log_arch_dir = /xampp/mysql/
You can set .._buffer_pool_size up to 50 - 80 %
of RAM but beware of setting memory usage too high
set-variable = innodb_buffer_pool_size=16M
set-variable = innodb_additional_mem_pool_size=2M
Set .._log_file_size to 25 % of buffer pool size
set-variable = innodb_log_file_size=5M
set-variable = innodb_log_buffer_size=8M
innodb_flush_log_at_trx_commit=1
set-variable = innodb_lock_wait_timeout=50

Wenn du dann das nächste mal mySQL startest sollte innodb klappen
User avatar
jsb
 
Posts: 38
Joined: 26. March 2004 13:50
Location: Berlin

Postby ositron » 27. August 2004 22:02

Hallo jsb,

erstmal danke für den Hinweis. Ich habe die Änderungen in der my.ini durchgeführt. Allerdings habe ich dann durch die Abfrage "mysql> show variables like "have_%";" geprüft, welche Tabellentypen unterstützt werden. Und dann kam die Anzeige:

have_innodb: disabled

Es muss also noch irgendwo weitere Optionen geben, die nicht aktiviert sind. Kann es sein, dass dies mit der Standarddistribution von XAMPP zusammenhängt?
ositron
 
Posts: 5
Joined: 06. August 2004 23:17

Postby Wiedmann » 28. August 2004 08:49

Hi ositron,

1. solltest du sicher sein, dass du die Änderungen in der my.ini/my.cnf durchführst, die auch benutzt wird.

2. in der Vorhandenen steht zwar viel drin.., aber folgende my.ini langt für das funktinieren von MySQL:
Code: Select all
[mysqld]
basedir=C:\xampp\mysql
datadir=C:\xampp\mysql\data
enable-named-pipe

Die Pfade mußt du halt auf dein System anpassen.
Den 3. Punkt nur, wenn du Windows NT/XP benutzt.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jsb » 28. August 2004 12:44

ositron wrote:Hallo jsb,

erstmal danke für den Hinweis. Ich habe die Änderungen in der my.ini durchgeführt. Allerdings habe ich dann durch die Abfrage "mysql> show variables like "have_%";" geprüft, welche Tabellentypen unterstützt werden. Und dann kam die Anzeige:

have_innodb: disabled

Es muss also noch irgendwo weitere Optionen geben, die nicht aktiviert sind. Kann es sein, dass dies mit der Standarddistribution von XAMPP zusammenhängt?


Achte darauf das du die Änderungen in der my.ini/my.cnf macht die im Windowsverzeichnis abgelegt ist. denn das ist die die benuzt wird.
User avatar
jsb
 
Posts: 38
Joined: 26. March 2004 13:50
Location: Berlin


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 2 guests