mySQL startet nicht

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

mySQL startet nicht

Postby JoachimF » 20. November 2013 18:18

Hallo alle zusammen,

ich bin neu hier und versuche in Joomla eine Homepage zu generieren. Dazu habe ich mir vorgestern das Programm XAMPP 1.8.3 heruntergeladen. Alles lief perfekt. Gestern nach dem Anschalten des Computers - leider nicht mehr möglich mySQL zu starten. So schnell lasse ich mich nicht entmutigen: Programm neu installiert, alles perfekt.
Heute Computer neu gestartet - das gleiche Problem:

Initialisere Control Panel
18:13:33 [main] Windows Version: Windows 7 Professional SP1 64-bit
18:13:33 [main] XAMPP Version: 1.8.3
18:13:33 [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
18:13:33 [main] Dein Benutzerprofil besitzt keine Administratorenrechte! Das reicht aus für die meisten
18:13:33 [main] Anwendungsfunktionen, aber wann immer du etwas mit Windows-Diensten tun möchtest,
18:13:33 [main] wird eine Sicherheitsabfrage erscheinen oder etwas wird garnicht erst funktionieren!
18:13:33 [main] Also denke daran diese Anwendung mit Administratorrechten zu starten!
18:13:33 [main] XAMPP Installationsverzeichnis: "c:\xampp\"
18:13:33 [main] Voraussetzungen werden geprüft
18:13:33 [main] Alle Voraussetzungen sind erfüllt
18:13:33 [main] Initialisiere Module
18:13:33 [Apache] Initialisiere Modul...
18:13:33 [Apache] Prüfe ob Modul existiert...
18:13:33 [Apache] Prüfe benötigte Tools...
18:13:33 [Apache] Überprüfe Dienst (name="Apache2.4"): Dienst nicht installiert
18:13:33 [Apache] Dienst-Pfad: Dienst nicht installiert
18:13:33 [Apache] Überprüfe Standardports...
18:13:33 [Apache] Port-blockierende Anwendung gefunden: httpd.exe
18:13:33 [Apache] Prüfe Anwendung: c:\xampp\apache\bin\httpd.exe
18:13:33 [Apache] Pfad der Port-blockierenden Anwendung: c:\xampp\apache\bin\httpd.exe
18:13:33 [Apache] Pfad des Port-blockierenden Dienstes:
18:13:33 [Apache] XAMPP Apache ist bereits gestartet auf Port 80
18:13:33 [Apache] Port-blockierende Anwendung gefunden: httpd.exe
18:13:33 [Apache] Prüfe Anwendung: c:\xampp\apache\bin\httpd.exe
18:13:33 [Apache] Pfad der Port-blockierenden Anwendung: c:\xampp\apache\bin\httpd.exe
18:13:33 [Apache] Pfad des Port-blockierenden Dienstes:
18:13:33 [Apache] XAMPP Apache ist bereits gestartet auf Port 443
18:13:33 [mysql] Initialisiere Modul...
18:13:33 [mysql] Prüfe ob Modul existiert...
18:13:33 [mysql] Prüfe benötigte Tools...
18:13:33 [mysql] Überprüfe Dienst (name="mysql"): Dienst nicht installiert
18:13:33 [mysql] Dienst-Pfad: Dienst nicht installiert
18:13:33 [mysql] Überprüfe Standardports...
18:13:33 [main] Das FileZilla Modul ist deaktiviert
18:13:33 [main] Das Mercury Modul ist deaktiviert
18:13:33 [main] Das Tomcat Modul ist deaktiviert
18:13:33 [main] Aktiviere Autostart für Modul "Apache"
18:13:33 [main] Aktiviere Autostart für Modul "MySQL"
18:13:33 [main] Starte Check-Timer
18:13:33 [main] Control Panel bereit
18:13:34 [Apache] Autostart abgebrochen: Apache ist bereits gestartet
18:13:34 [mysql] Autostart aktiv: Starte...
18:13:34 [mysql] Überprüfe Standardports...
18:13:34 [mysql] Versuche MySQL zu starten...
18:13:34 [mysql] Führe aus: ""c:\xampp\mysql\bin\mysqld.exe" --defaults-file="c:\xampp\mysql\bin\my.ini" --standalone"
18:13:34 [mysql] Rückgabecode: 0
18:13:38 [mysql] Überprüfe Standardports...
18:13:38 [mysql] Versuche MySQL zu starten...
18:13:38 [mysql] Führe aus: ""c:\xampp\mysql\bin\mysqld.exe" --defaults-file="c:\xampp\mysql\bin\my.ini" --standalone"
18:13:38 [mysql] Rückgabecode: 0
18:13:51 [mysql] Überprüfe Standardports...
18:13:51 [mysql] Versuche MySQL zu starten...
18:13:51 [mysql] Führe aus: ""c:\xampp\mysql\bin\mysqld.exe" --defaults-file="c:\xampp\mysql\bin\my.ini" --standalone"
18:13:51 [mysql] Rückgabecode: 0

Ich wäre sehr dankbar, wenn mir jemand einen Lösungsvorschlag präsentieren könnte. Das Betriebssystem ist Windows 7.

Vielen Dank schon jetzt für Eure Mühen

Joachim (blutiger Anfänger :oops: )
JoachimF
 
Posts: 2
Joined: 20. November 2013 15:18
Operating System: Windows7

Re: mySQL startet nicht

Postby Altrea » 20. November 2013 19:18

Hallo Joachim,

versuche es mal mit XAMPP 1.8.2-2, denn ich vermute du bist wiederholt diesem Bug zum Opfer gefallen:
viewtopic.php?f=16&t=66746#p230644

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: mySQL startet nicht

Postby JoachimF » 21. November 2013 15:15

Hallo,

vielen, vielen Dank ..... Super; jetzt funktioniert das Programm tadellos.

Nochmals vielen Dank :D

Herzlicher Gruß

Joachim
JoachimF
 
Posts: 2
Joined: 20. November 2013 15:18
Operating System: Windows7

Re: mySQL startet nicht

Postby ThomasCrook » 29. November 2013 10:22

Is there any other alternatives of it? I am just looking for some prior solutions which also works for two factor authentication in Google apps..Find more on http://www.googleappsecurity.com/two-factor-authentication
ThomasCrook
 
Posts: 1
Joined: 29. November 2013 08:57
Operating System: Windows

Re: mySQL startet nicht

Postby h20_master » 04. March 2014 09:39

Hallo, auch ich bin blutiger Neueinsteiger bei xampp und mySQL. Ich habe genau das gleiche Problem wie Joachim. Ist es wirklich damit getan, auf eine ältere Version von xampp auszuweichen, oder haben sich da schon andere Lösungsansätze gefunden? Ich habe gerade xampp wieder deinstalliert. Was soll ich tun?
h20_master
 
Posts: 2
Joined: 04. March 2014 09:34
Operating System: Windows 7

Re: mySQL startet nicht

Postby Altrea » 04. March 2014 13:22

Hallo h20_master,

h20_master wrote:Ist es wirklich damit getan, auf eine ältere Version von xampp auszuweichen, oder haben sich da schon andere Lösungsansätze gefunden?

Die Alternative zu einer älteren XAMPP Version wäre eine neuere, also XAMPP 1.8.3-3

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: mySQL startet nicht

Postby h20_master » 05. March 2014 08:11

Danke, Danke...
aber genau da ist das Problem. Ich hatte am 3.3.14 diese Version installiert, Wordpress zum laufen bekommen und schon damit gearbeitet. Leider liess sich am nächsten Tag nach Neustart nur noch Apache starten, aber leider nicht mySQL. So....nun bin ich etwas ratlos.
Mit freundlichen Grüßen
h20_master
h20_master
 
Posts: 2
Joined: 04. March 2014 09:34
Operating System: Windows 7

Re: mySQL startet nicht

Postby Altrea » 05. March 2014 08:24

Bist du denn sicher, dass du exakt dasselbe Problem wie der Threadersteller hast? (Du hast uns ja ziemlich wenig eigene Informationen zukommen lassen, daher kann das keiner von uns hier beurteilen).
Dass MySQL nicht startet kann unterschiedlichste Ursachen haben und der beschriebene Bug sollte in der aktuell in XAMPP befindlichen MySQL-Version gefixt sein.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 3 guests