Driver not found 3,51

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

Driver not found 3,51

Postby foki » 11. March 2004 13:33

Salute @ all,

folgendes Problem:

Xampp läuft auf Windows XP Prof., nach dem letzten Update leuchtet das MySQL-Lämpchen rot.

In dem ODBC-Fenster erscheint nur:
Driver 3,51 not found

Zunächst gegooglet:
gleiches Problem siehe ---> http://www.phpforum.de/archiv_7922_mysq ... eigen.html

Ich hab das wie dort beschrieben dann auch gemacht. Aber Pustekuchen lief nix. Die Ampel blieb auf rot.

Und nu ???

MfG

foki
foki
 
Posts: 8
Joined: 11. March 2004 13:20

Postby Wiedmann » 11. March 2004 14:08

Naja, das eine hat mit dem anderen nicht direkt was zu tun.

Der ODBC-Treiber wird ja standardmäßig nicht installiert. Und wird auch grad im Zusammenhang mit Apache nicht benötigt. Das ist einfach eine Info für dich.

Die rote Ampel sagt allerdings. daß der MySQL nicht läuft. Scheint also was beim Update schiefgelaufen zu sein. ODer der WinMySQLadmin überwacht einen falschen Service. Stimmen die Einträge in der "my.ini" noch?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby foki » 11. March 2004 14:50

Ich hab nochmal Xampp deinstalliert und neu aufgesetzt gehabt trotzdem bleibt die Ampel auf Rot
foki
 
Posts: 8
Joined: 11. March 2004 13:20

Postby Wiedmann » 11. March 2004 15:27

Und läuft der MySQL-Server oder ist "nur" die Ampel rot? Damit das Tool funktioniert, den MySQL nach Anleitung als Dienst installieren. Pfade anpassen nicht vergessen (in my.cnf). Vor dem Neustart von MySql oder dem Tool die Datei "my.ini" im Windows-Verzeichnis löschen.

Ach so... wegen dem ODBC:
Bei mir sagt der auch ODBC nicht gefunden (obwohl installiert). Zeigt aber drunter wenigstens die gefunden ODBC-DLL's an. Zugriff über ODBC funktioniert aber trozdem :-)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby foki » 25. March 2004 13:51

jungens help me!!!

hab erst heut wieder Zeit gefunden ins Forum zu gucken!!!

Image

Who can help me ???

greetz

foki

------
http://whit.team-bangarang.de <-- Design Meinung gefragt!!!
foki
 
Posts: 8
Joined: 11. March 2004 13:20

Postby foki » 25. March 2004 13:53

foki wrote:jungens help me!!!

hab erst heut wieder Zeit gefunden ins Forum zu gucken!!!

Image

Who can help me ???

greetz

foki

My.ini is vorhanden


------
http://whit.team-bangarang.de <-- Design Meinung gefragt!!!
foki
 
Posts: 8
Joined: 11. March 2004 13:20

Postby Wiedmann » 25. March 2004 14:23

Jetzt mal unabhängig von diesem Tool:

Was passiert denn, wenn du in der Eingabeaufforderung
"net start MySQL"
eingibst?

(Was steht denn im Reiter "Start Check"?)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby foki » 25. March 2004 14:44

my.ini is vorhanden und OK
foki
 
Posts: 8
Joined: 11. March 2004 13:20

Postby Heini_net » 25. March 2004 16:49

moin..

bei mir ist der Datenbanktreiber 3.51 auch nicht installiert und mysql funzt trotzdem.. es muss also was anderes sein warum mysql nicht startet.

Mfg. Heini
User avatar
Heini_net
 
Posts: 520
Joined: 25. July 2003 15:43
Location: hier

Postby Kristian Marcroft » 25. March 2004 17:15

Hi,

und wenn ich mich nicht irre, sollte der ODBC Treiber im aktuellem MDAC enthalten sein.

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby Heini_net » 25. March 2004 17:19

jo.. gehe ich auch von aus der der Treiber bereits installiert ist nur mit dem fehler meinte ich den sql admin tool das anmotzt das der Treiber nicht installiert ist..

Mfg. Heini
User avatar
Heini_net
 
Posts: 520
Joined: 25. July 2003 15:43
Location: hier

Postby foki » 16. April 2004 08:08

HI

muss ich die alten dll-Dateien aus dem Windows/System32 löschen,

wenn ich XAmpp nochmal neu aufsetze ??
foki
 
Posts: 8
Joined: 11. March 2004 13:20

Postby Kristian Marcroft » 16. April 2004 08:19

Hi,

nein du musst nichts löschen, da XAMPP nichts in Systemverzeichnise installiert.

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 4 guests