ERROR 1045

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

ERROR 1045

Postby p3st0lino » 01. March 2004 19:08

Hallo erst mal.

So wo soll ich anfangen naja ok von Anfang an is wohl das beste.

Also ich hab seit einer Woche ca. die neuste Version von XAMPP auf meinem Rechner. OS ist Windows XP. Nun ja ich hab mich dann auch schön an die Anleitung gehalten, wie man den ganzen kram drauf macht, habe installation ohne Perl gewählt und nun funktioniert auch so weit alles außer mysql. Ich habe zwar schon über WinMyAdmin ein password gesetzt und auch einen username nur kann ich mit diesem nicht zu mysql connecten. Egal ob ich es über phpMyAdmin oder über den DOS cmd-promt versuche ich bekomme immer die gleiche Meldung.

ERROR 1045: Access denied for user myusername@localhost <Password: YES>

Seit einer woche probiere ich nun diese Problem zu lösen, doch finde keine möglichkeit. Google spuckt zwar eine Menge ähnliche Fragen aus, doch hat bisher keine der angebotenen Problemlösungen geholfen.

Ich hoffe, dass ihr mir weiterhelfen könnt, den so langsam ist der Frustfaktor bei mir im 90% Bereich.
Wenn ihr irgendwo ein Tutorial habt in dem exakt beschrieben steht, welche Punkte alles gecheckt sein müssen, um Zugang zu mysql zu bekommen wäre ich auch sehr froh, denn die meisten Tutorials lasen da scheinbar immer die hälfte weg und ich muss mir alles klein klein zusammenbastelln was oft daran scheitert, dass die Autoren mit unterschiedlichen Versionen arbeiten.
p3st0lino
 
Posts: 3
Joined: 01. March 2004 18:27

Postby p3st0lino » 02. March 2004 18:58

Ok ich hab herausgefunden woran es lag. Anscheinend kann ich bei mir mysql nicht als service insatllieren, denn der fehler ist weg, sobald ich mysql mauel starte und es nicht als service insatlliert habe. Leider weiß ich absolut nicht wieso ich es nicht als service installieren kann. Wenn noch jemand eine Idee hat, woran das liegen kann dann hälft mir bitte ansonsten werd ich es wohl irgendwann herausfinden so wie alles bisher.

Cya.
p3st0lino
 
Posts: 3
Joined: 01. March 2004 18:27

Error

Postby highsource.de » 04. March 2004 22:04

Hallo!
Hast du in der config.inc.php ein Passwort für MySql vergeben was ich annehme!

Also wenn du diese mit einem Passwort versehen hast dann musst du das Xampp auch klar machen!
Das machst du indem du under DeineHD:xampp\mysql\bin und da das winmysqladmin.exe Programm ausführen und das selbe Passwort vergeben mit dem dazugehörigem USER!
Unter der Reiterkarte my.ini Setup siehst du die Konfigurationsdatei dort siehst du auch das Passwort und den User! Kannst du immer wieder ändern aber nicht vergessen auch die config Datei!
Das müsste es gewesen sein!

Nun nochmal mit der CMD probieren!

Grüße highsource.de
Lieber Gott gib mir den Quellcode zu meinem Leben ich muss ihn ändern!
$meinalter=25;
while(1) {
$meinalter=25;
};
User avatar
highsource.de
 
Posts: 24
Joined: 04. March 2004 19:57
Location: bei Berlin

Postby p3st0lino » 05. March 2004 10:12

Hallo Highsource.

Danke für den Tip, ich werd das gelich mal ausprobieren. Ich hatte bisher immer das Passwort bei WinMySqlAdmin gesetzt und aus irgendwelchen gründen gedacht, dass dies auch das passwort für mysql selber setzt.
Ich haoffe mal es geht jetzt.

Grüß, p3st0lino.
p3st0lino
 
Posts: 3
Joined: 01. March 2004 18:27


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 2 guests