Access denied for user #@'localhost' (using password: YES)

Alles, was MySQL betrifft, kann hier besprochen werden.

Access denied for user #@'localhost' (using password: YES)

Postby Top Gun » 12. March 2011 20:13

Hallo,

nachdem ich gestern Probleme hatte mit Xampp 1.7.4, habe ich es heute wieder komplett runter geschmissen und die 1.7.3 installiert. Die Installation war problemlos.

Nachdem ich für den MySQL-Admin und phpMyAdmin-root ein Passwort vergeben habe, habe ich einen neuen User angelegt (web0) und als Host localhost (ich hatte es sogar mit allen Hosts [%] probiert) ausgewählt. Für diesen User habe ich eine neue DB angelegt und auch volle Rechte gewährt. Ich kann mich mit diesem User im phpMyAdmin anmelden, sehe die Datenbank und kann auch Tabellen bearbeiten.
Wenn ich jetzt aber einen Connect zur DB von meinem PHP-Script probiere, bekomme ich die Fehlermeldung:
Access denied for user 'web0'@'localhost' (using password: YES)

Verwende ich in dem PHP-Script den Benutzer root mit entsprechendem Passwort ist der Connect erfolgreich.

Wo könnte jetzt mein Problem sein? Was habe ich falsch gemacht?

Gruß
Top Gun
Top Gun
 
Posts: 3
Joined: 24. February 2009 15:18

Re: Access denied for user #@'localhost' (using password: YE

Postby WilliL » 12. March 2011 22:17

diese Zeile nach einem mysql-Befehl bewirkt in php-scripts Wunder bei debugging:
Code: Select all
echo "<br> erg - ".mysql_errno(). ": " . mysql_error()."<br>";

vermutlich steht auch noch eine Info im xampp/apache/logs/apache error.log oder im xampp/mysql/data/mysql_error.log
Willi
WilliL
 
Posts: 624
Joined: 08. January 2010 10:54
XAMPP Version: 5.5.19
Operating System: Win7Home Prem 64 SP1

Re: Access denied for user #@'localhost' (using password: YE

Postby Top Gun » 12. March 2011 23:31

Danke für den Hilfeversuch, allerdings steht in den Logs nichts drin, nur das Starten und Stoppen der Dienste.

Die Debug-Zeile bringt folgendes an den Tag: erg - 1045: Access denied for user 'web0'@'localhost' (using password: YES)
Das ist der Fehler wie oben schon benannt.

Wie gesagt es funktioniert mit dem root-Account und dessem Passwort, daher gehe ich davon aus, dass ich bei der Einrichtung des Benutzers oder der Vergabe der Rechte irgendwo einen Fehler gemacht habe. Allerdings ist das nicht das erste Mal das ich mit xampp, MySQL und oder phpMyAdmin arbeite und ich habe es heute nicht anders gemacht als sonst... Wo könnte also mein Fehler liegen?

EDIT: Ich habe meinem User web0 nun sogar globale Rechte gegeben - Access denied
Danach habe ich in der mysql-DB in der Tabelle user die Rechte überprüft - sind mit denen von root identisch

Wo um alles in der Welt ist der Fehler?
Top Gun
 
Posts: 3
Joined: 24. February 2009 15:18

Re: Access denied for user #@'localhost' (using password: YE

Postby Altrea » 13. March 2011 10:15

Du schreibst, dass der Login mit dem User über phpmyadmin funktioniert, aber über dein Script nicht.
Besitzt das Passwort vielleicht Umlaute oder Sonderzeichen, die dein Script in der falschen Zeichenkodierung überträgt?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6671
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Access denied for user #@'localhost' (using password: YE

Postby Top Gun » 13. March 2011 10:20

Ah ich Idiot... du hast vollkommen Recht das Passwort enthielt ein ß. Da ich das PW nur einmal blind in ein Textfile geschrieben habe und dann immer per Copy & Paste gearbeitet habe, ist mir das gar nicht weiter aufgefallen. Und dadran habe ich mich nen ganzen Abend aufgehalten... :roll:

Vielen Dank für deinen Einfall

Gruß
Top Gun
Top Gun
 
Posts: 3
Joined: 24. February 2009 15:18


Return to MySQL

Who is online

Users browsing this forum: No registered users and 4 guests