My SQL startet nicht!

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

My SQL startet nicht!

Postby Rick » 13. February 2004 19:14

Ich hab mir schon ne ganze Menge Themen durchgeguckt und die Tipps probiert. Ich hab auch die.cnf nach C:\ kopiert, hilft aber nicht, MySQL schliesst sich nach einigen Sekunden wieder. Habs auch schon neu installiert etc.

Folgende Meldung kommt wenn ich die bat. starte

@echo off
echo Diese Eingabeforderung nicht waehrend des Running beenden
echo Please dont close Window while MySQL is running
echo MySQL is trying to start
echo Please wait ...
echo MySQL is starting with mysql\bin\my.cnf (console)
mysql\bin\mysqld --defaults-file=mysql\bin\my.cnf --standalone

was muss ich da machen?
Rick
 
Posts: 15
Joined: 24. January 2004 21:13

Postby Shoukri » 13. February 2004 19:50

nein da wird nicht nur der andere thread hochgepusht, nein da wird auch nochn neuer thread erstellt ... die ganzen @echo off und co meldeungen solltest du gar nicht sehen als fehlermeldung ... bist du dir sicher dass die datei nicht nur im editor geöffnet wird?
User avatar
Shoukri
 
Posts: 76
Joined: 29. October 2003 00:25

Postby Rick » 13. February 2004 20:25

Ich weiss das die echo off Meldungen keine Fehlermeldungen sind, ich meine auch eher die letzte Zeile.

Aber die bat wird nicht im Editor ausgeführt, die bat wird ganz normal gestartet und dann wird dass, was ich gepostet habe angezeigt und MySQL läuft nicht. Unter Prozess läuft aber die mysqld.exe
Rick
 
Posts: 15
Joined: 24. January 2004 21:13

Postby Shoukri » 13. February 2004 20:48

du darfst das fenster nicht schliessen wenns denn offen ist :P

wenn die mysqldim speicher ist läuft mysql auch
</shoukri>
User avatar
Shoukri
 
Posts: 76
Joined: 29. October 2003 00:25

Postby Rick » 13. February 2004 20:50

ja aber komischer weise läuft mysql auf der testsql seite nicht!
Rick
 
Posts: 15
Joined: 24. January 2004 21:13

Postby Shoukri » 13. February 2004 20:52

hast du das passwort zufälligerweise geändert für den mysql root user?
</shoukri>
User avatar
Shoukri
 
Posts: 76
Joined: 29. October 2003 00:25

Postby Rick » 13. February 2004 20:55

ne ich hab xampp ganz normal installiert und danach die bat. gestartet, also nichts irgendwie verändert!
Rick
 
Posts: 15
Joined: 24. January 2004 21:13

Postby basilius » 16. February 2004 13:01

ich habe das gleiche problem. apache ist gestartet, ein klick auf mysql_start öffnet das mysql fenster für ca 3 sekunden, dann schliesst es sich von selber wieder und die datenbank ist natürlich nicht erreichbar.

habe das ganze paket jetzt schon 3 mal neu installiett.. die ersten drei male funktioniert alles wunderbar, aber dann tritt das beschriebene problem ein.

hilfe
basilius
 
Posts: 8
Joined: 16. February 2004 12:56

Postby Wiedmann » 16. February 2004 13:19

Öffne mal eine Eingabeaufforderung:
Start --> Ausführen --> cmd (eingeben) --> OK

gib dort ein:
cd \xammp\mysql
(return drücken)

und starte jetzt durch eingeben von:
mysql_start.bat
(return drücken)
den MySQL-Server.

Er wird deshalb zwar nicht laufen.... Aber man hat jetzt eine Change die Fehlermeldung die MySQL ausgibt zu lesen...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby basilius » 16. February 2004 13:29

leider funktioniert auch das nicht - ist im prinzip ja auch das gleiche, wie normal auf die mysql_start.bat zu klicken..
basilius
 
Posts: 8
Joined: 16. February 2004 12:56

Postby basilius » 17. February 2004 10:33

gibts sonst noch wen die hilfestellung bringen kann?
basilius
 
Posts: 8
Joined: 16. February 2004 12:56

Hab dasselbe Problem mit wampp

Postby CrazyPlaya » 17. February 2004 21:24

hab dasselbe mit wampp, bei mir hilfts wenn ich denn rechner neu starte, dann kann er auch wieder auf mysql zugreifen. Würde gerne auch erfahren, warum man solche umwege gehen muss.

ps: Kommt aber auch vor das er selbst nach einem Neustart nicht auf mysql zugreifen kann.
CrazyPlaya
 
Posts: 9
Joined: 17. February 2004 21:16

Postby basilius » 16. March 2004 19:05

also sonderlich viel support gibts hier wohl nicht oder?

das thema ist mittlerweile uralt, es gibt 30 verschiedene threads dazu.. und keine lösung.


hallo?
basilius
 
Posts: 8
Joined: 16. February 2004 12:56

eine Lösung?

Postby else » 21. March 2004 20:18

Hi, ich hatte grad das gleiche Problem. Folgendes klappte dann: ich öffnete ein 2. Konsolenfenster (Win XP) und wollte mir nur so als Test die MySQL-Version anzeigen lassen (mysqladmin version). Durch die Abfrage meiner Firewall kam ich drauf, dass MySQL wohl eine Verbindung zum Internet braucht, um als localhost zu starten (So oder ähnlich muss es wohl sein, denn dann konnte ich sämtlich Abfragen starten und mir die TestDB anschauen).
Vielleicht hilfts ja....

Viel Erfolg!
else
 
Posts: 1
Joined: 21. March 2004 19:23

mysql als service

Postby jsb » 26. March 2004 14:09

Ich habe mysql als service mit der mysql_installservice.bat installier. Leider funktioniert der Start von MYSQL nicht richtig.

:?:

unter phpMyAdmin 2.5.6 erhalte ich folgende Fehlermeldung

#2003 - Can´t connect to mysql server on 'localhost' (10061)


Ich hab die Version 1.4 von xampp installiert. und sowohl Apache als auch mysql und filezilla als dienste installiert.

Hab grad nochmal was versucht
1. msql dienst deinstlliert
mysql mit mysql-start.bat gestartet und da funktioniert es.

finde es aber angenehmer und besser wenn es als Dienst laufen würde. Da ich dies auf einem rechner im Netz betreibe um dort projekte zu testen.

Wäre schön wenn mir jemand weiterhelfen kann.
Last edited by jsb on 26. March 2004 15:31, edited 1 time in total.
User avatar
jsb
 
Posts: 38
Joined: 26. March 2004 13:50
Location: Berlin

Next

Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 1 guest