Suse 9.0 Professional + Lampp 1.0 + Mysql-error!

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

Suse 9.0 Professional + Lampp 1.0 + Mysql-error!

Postby Lokian » 07. January 2004 17:33

Hi Leute,

bin hier neu! :oops:
Genau wie mit Linux und habe mir halt "Lampp" besorgt und auch richtig installiert!

Habe Statuscheck und so gemacht und habe halt folgendes Problem!

----------------------------------

ERROR 2002: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)

----------------------------------

Hatte das schon mal jemand?

Bitte helft mir!
Ich würde mich echt freuen!
Danke schon mal im Voraus!

Danke Loki!
User avatar
Lokian
 
Posts: 14
Joined: 07. January 2004 17:14

Postby Kristian Marcroft » 07. January 2004 20:37

Hi,

wann kommt diese Meldung?
Das hast du leider nicht gesagt....

Was auch immer das für ein Script/Prog ist, es greift nicht auf den mySQL von LAMPP zu.

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Wann diese Meldung kommt...

Postby Lokian » 08. January 2004 13:36

Ja genau, haste recht! :oops:

Ähem, erstmal wenn ich denn Statuscheck von Lampp mache läuft halt erst alles außer MySql und dann hatte ich in der normalen Konsole als root einfach mal "mysql" eingetippt.

Ansonsten hatte ich noch ein paar Pakete dazu installiert und dann hatte ich die Anwendung "mysqlcc" drauf und die hatte ich dann noch gestartet und habe einfach ne "Verbindung"(Connection succesfully added...)
hinzugefügt doch als ich dann richtig verbinden wollte gav er mir auch die oben stehende Meldung aus und es funzt einfach nix!

Ich hoffe, dass ihr mir jetzt vielleicht ein wenig besser helfen könnt! :)

MfG Loki
User avatar
Lokian
 
Posts: 14
Joined: 07. January 2004 17:14

Postby Kristian Marcroft » 08. January 2004 14:07

Hi,

wenn du in der console auf mySQL von LAMPP zugreiffen willst, musst du auch den vollen Pfad zu mysql angeben, da ein reines "mysql" immer auf das System MySQL verweist.

Also wäre es richtig:
/opt/lampp/bin/mysql

Zu dem rest kann ich nichts sagen, da es mir nichts sagt...

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Mysql

Postby Lokian » 10. January 2004 10:44

Tach...
Bins noch mal!

Sollte der Lampp/Xampp das alles nicht selber starten?
Hab zwar schon Erfahrungen mit dem WAMPP, wo man Mysql & apache so nach und nach starten muss, doch da lief das Alles! Das Linux und Windows nichts miteinander zu tun haben ist das jetzt auch Latte!

Naja, ich habe deinen Tip mal getestet und leider bekomme ich immer noch die selbe Antwort!

Trotzdem DANKE!

Ich werde es dann noch mal auf anderen Seiten versuchen!

MfG Loki :o
User avatar
Lokian
 
Posts: 14
Joined: 07. January 2004 17:14

Hat sich erledigt!

Postby Lokian » 10. January 2004 16:28

Hi!

Wollte sagen, dass sich das erledigt hat und ich mir den XAMPP 1.4 gezogen und es funzt alles, was ich brauche!

Wollte mich für die Hilfestellung bedanken!

Ciao Loki! :lol:
User avatar
Lokian
 
Posts: 14
Joined: 07. January 2004 17:14


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 3 guests