MySql Login

Alles, was MySQL betrifft, kann hier besprochen werden.

MySql Login

Postby schnecke » 24. September 2009 08:25

hallo,

nach der lokalen installation von xampp funktioniert alles prima.
wenn ich das passwort fuer mysql ueber http://localhost/security/xamppsecurity.php aendere, ist mysql im status deaktiviert (access problem). nach neuinstallation geht wieder alles, usw.

wer kann helfen?

gruss
schnecke
schnecke
 
Posts: 1
Joined: 24. September 2009 08:00

Re: MySql Login

Postby Pitze » 09. October 2009 19:56

Muss das hier mal aufgreifen.
Nach setzen einen Pass für den USER PMA ist ein Zugriff auf den DB_Server nur noch mit PHPmyadmin möglich und der schreit selber das ein fehler beim Zugriff auf den PMA-USER wie in Config nicht möglich.
Warum????? bin dabei aber es sollten sich einige unserer Profs damit auseinandersetzen vielleicht gehts dann schneller
Der grösste Vertrauensbruch ist der Blitzableiter auf der Kirchturmspitze
User avatar
Pitze
 
Posts: 210
Joined: 20. November 2003 21:38
Location: Huskvarna-Schweden
XAMPP Version: 5.6.3
Operating System: Windows Vista

Re: MySql Login

Postby Wiedmann » 09. October 2009 20:00

Nach setzen einen Pass für den USER PMA ist ein Zugriff auf den DB_Server nur noch mit PHPmyadmin möglich und der schreit selber das ein fehler beim Zugriff auf den PMA-USER wie in Config nicht möglich.
Warum?????

Hast du die Konfiguration von phpMyAdmin angepasst, nach Setzten eines Passwortes für den User "pma"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: MySql Login

Postby Pitze » 10. October 2009 01:49

Hast du die Konfiguration von phpMyAdmin angepasst, nach Setzten eines Passwortes für den User "pma"?

nein: Warum??
du hat die 1.7.2 doch gebaut, da ist es nicht nötig.
Noch mal. Setzt man über xampp_security das pma pass lässt sich MySQL nicht mer vom PHP_Skript ansprechen und Xampp_Status zeigt Deaktiviert an PhPMyAdmin ist aber noch in der Lage den Server zu erreichen.
Habe nun ein wenig Experimentiert, setzt man den pass von Hand ist es auch nicht anders. Schon ein wenig komisch in den 6 Jahren die ich jetzt mit xampp arbeite hatte ich so was noch nicht.
Kurze Frage: Wäre es nicht mal Zeit für ein kleines Update Apache-MySQL-PhpMyAdmin sind schon ein wenig weiter?
Der grösste Vertrauensbruch ist der Blitzableiter auf der Kirchturmspitze
User avatar
Pitze
 
Posts: 210
Joined: 20. November 2003 21:38
Location: Huskvarna-Schweden
XAMPP Version: 5.6.3
Operating System: Windows Vista

Re: MySql Login

Postby Wiedmann » 10. October 2009 08:17

du hat die 1.7.2 doch gebaut, da ist es nicht nötig.

Sofern man das "pma" Passwort über das Security Script setzt: korrekt. Das passt dann auch die phpMyAdmin Konfiguration an. In deinem Post hat sich das nur so angehört, als würdest du das Passwort von Hand setzten.

Setzt man über xampp_security das pma pass lässt sich MySQL nicht mer vom PHP_Skript ansprechen ...

Dann hat dein PHP Skript einen Fehler. Hier bräuchte man mehr Infos um das eigentliche Problem lokalisieren zu können.

... und Xampp_Status zeigt Deaktiviert an ...

Korrekt. Ein Fehler im Statusscript. (benutze die Forumssuche für einen Fix)

PhPMyAdmin ist aber noch in der Lage den Server zu erreichen.

So soll es ja sein. Das Security Script passt eben auch die phpMyAdmin Konfiguration an. Ansonsten ist phpMyAdmin ja ein simples PHp Script, womit man sieht, dass auch ein PHP Script nach wie vor auf den Server zugreifen kann.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: MySql Login

Postby Pitze » 10. October 2009 11:00

Sofern man das "pma" Passwort über das Security Script setzt: korrekt. Das passt dann auch die phpMyAdmin Konfiguration an. In deinem Post hat sich das nur so angehört, als würdest du das Passwort von Hand setzten.

Sorry ist vielleicht missverständlich rüber gekommen. Ich habe beides versucht von Hand und Security nichts und soweit bin ich auch mit dem Umgang der config von PhpMyAdmin vertraut.
Dann hat dein PHP Skript einen Fehler. Hier bräuchte man mehr Infos um das eigentliche Problem lokalisieren zu können.

Daran habe ich auch erst gedacht aber Fehlanzeige das Skript läuft einwandfrei(schon über drei Versionen), den sobalt wie ich das pma Pass aus der Datenbank entferne findet mein Skript auch Mysql wieder. Ist doch schon komisch oder da pma ja nur für PhpMyAdmin gedacht ist.
Korrekt. Ein Fehler im Statusscript. (benutze die Forumssuche für einen Fix)

Der Fehler ist mir wohl bekannt hat bzw darf aber doch keine Auswirkung auf MySQL haben. Hatte mich bis jetzt eigendlich nie gestört.
Der grösste Vertrauensbruch ist der Blitzableiter auf der Kirchturmspitze
User avatar
Pitze
 
Posts: 210
Joined: 20. November 2003 21:38
Location: Huskvarna-Schweden
XAMPP Version: 5.6.3
Operating System: Windows Vista

Re: MySql Login

Postby Wiedmann » 10. October 2009 11:19

den sobalt wie ich das pma Pass aus der Datenbank entferne findet mein Skript auch Mysql wieder.

Nun ja, mit einem Passwort für den "pma" wird das Scrtipt ja dann eine Fehlermeldung ausgeben. Ohne diese ist jede Antwort hier ein Blick in die Glaskugel.

Der Fehler ist mir wohl bekannt hat bzw darf aber doch keine Auswirkung auf MySQL haben.

Hat es auch nicht. (siehe phpMyAdmin der ja immer noch tut: "PhPMyAdmin ist aber noch in der Lage den Server zu erreichen.")
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: MySql Login

Postby Pitze » 10. October 2009 13:48

Nun ja, mit einem Passwort für den "pma" wird das Scrtipt ja dann eine Fehlermeldung ausgeben. Ohne diese ist jede Antwort hier ein Blick in die Glaskugel.

Na ja sicher doch. Fehler beim Aufbau der Serververbindung MySQL nicht erreichbar. Nur was hat das in drei Teufelsnamen mit pma zu tun der wird doch nur von PhpMyAdmin benutzt.
(siehe phpMyAdmin der ja immer noch tut: "PhPMyAdmin ist aber noch in der Lage den Server zu erreichen.")

Und genau das macht mich irre PhpMyAdmin kommt da hin,zwar mit fehler kann pma nicht erreichen, aber meine Skripte nicht und ohne pma pass alles wunderbar null problemo auch auf xampp 1.7.1 null problemo da klappert alles wunderbar.
Na was solls ein bisschen Wochenende ist ja noch da mal sehen was sich ergibt.
Der grösste Vertrauensbruch ist der Blitzableiter auf der Kirchturmspitze
User avatar
Pitze
 
Posts: 210
Joined: 20. November 2003 21:38
Location: Huskvarna-Schweden
XAMPP Version: 5.6.3
Operating System: Windows Vista

Re: MySql Login

Postby Wiedmann » 10. October 2009 13:55

Und genau das macht mich irre PhpMyAdmin kommt da hin,zwar mit fehler kann pma nicht erreichen,

Dann nochmal von vorne:
- Du hast einen (frischen) XAMPP installiert, wo der "pma" (und "root") kein Passwort hat.
- http://localhost/phpmyadmin/ lässt sich normal aufrufen.
- Dann gehst du auf http://localhost/security/xamppsecurity.php und wählst dort was genau aus (bzw. trägst du in das Feld ein)? Und schickst das Formular weg.
- Jetzt gehst du wieder auf http://localhost/phpmyadmin/ und nun bringt dir der phpMyAdmin eine Fehlermeldung wegen dem "pma" (kannst Ihn aber ansonsten normal bendienen, sprich einloggen)?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: MySql Login

Postby Pitze » 10. October 2009 16:01

- Du hast einen (frischen) XAMPP installiert, wo der "pma" (und "root") kein Passwort hat.
- http://localhost/phpmyadmin/ lässt sich normal aufrufen.

Ja
- Dann gehst du auf http://localhost/security/xamppsecurity.php und wählst dort was genau aus (bzw. trägst du in das Feld ein)? Und schickst das Formular weg.

nun pass für MySQL-und der Radiobutton ist ja schon auf JA Aktiv
- Jetzt gehst du wieder auf http://localhost/phpmyadmin/ und nun bringt dir der phpMyAdmin eine Fehlermeldung wegen dem "pma" (kannst Ihn aber ansonsten normal bendienen, sprich einloggen)?

Ja
So bin da noch am rumfummeln näheres in ca 1 Std
Der grösste Vertrauensbruch ist der Blitzableiter auf der Kirchturmspitze
User avatar
Pitze
 
Posts: 210
Joined: 20. November 2003 21:38
Location: Huskvarna-Schweden
XAMPP Version: 5.6.3
Operating System: Windows Vista

Re: MySql Login

Postby Wiedmann » 10. October 2009 16:31

- Du hast einen (frischen) XAMPP installiert, wo der "pma" (und "root") kein Passwort hat.
- http://localhost/phpmyadmin/ lässt sich normal aufrufen.

Ja

Ok. An diesem Punkt steht in der "config.inc.php":
Code: Select all
$cfg['Servers'][$i]['auth_type']            = 'config';
$cfg['Servers'][$i]['user']                 = 'root';
$cfg['Servers'][$i]['password']             = '';
...
$cfg['Servers'][$i]['controluser'] = 'pma';
$cfg['Servers'][$i]['controlpass'] = '';


In der Shell funktioniert auch jeder der 2 folgenden Befehle:
Code: Select all
mysqladmin -u root ping
mysqladmin -u pma ping



- Dann gehst du auf http://localhost/security/xamppsecurity.php und wählst dort was genau aus (bzw. trägst du in das Feld ein)? Und schickst das Formular weg.

nun pass für MySQL-und der Radiobutton ist ja schon auf JA Aktiv

Also zwei mal das Wort "pass" eintragen und dann auf den Button "Passwort ändern" klicken.

An diesem Punkt steht jetzt in der "config.inc.php":
Code: Select all
$cfg['Servers'][$i]['auth_type']            = 'cookie';
$cfg['Servers'][$i]['user']                 = 'root';
$cfg['Servers'][$i]['password']             = '';
...
$cfg['Servers'][$i]['controluser'] = 'pma';
$cfg['Servers'][$i]['controlpass'] = '4ad0a667cc3c5';


In der Shell funktioniert jetzt diese 2 Befehle nicht mehr:
Code: Select all
mysqladmin -u root ping
mysqladmin -u pma ping

(access denied)

Dafür funktioniert jetzt:
Code: Select all
mysqladmin -u root -ppass ping
mysqladmin -u pma -p4ad0a667cc3c5 ping


("4ad0a667cc3c5" stimmt natürlich nur in diesem Beispiel, und ist jedesmal verschieden)

Wenn man jetzt auf
Code: Select all
http://localhost/phpmyadmin/
geht, kommt eine Anmeldemaske und man muss als Benutzername "root" und als Passwort "pass" eingeben. Danach kommt man ganz normal in phpMyAdmin und es gibt keine Fehlermeldung bezüglich dem "pma".

(Das sind genau die Schritte die ich jetzt ausgeführt habe...)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: MySql Login

Postby Pitze » 10. October 2009 18:07

So nach dem ich das ganze nun zum x-ten mal neu aufgelegt haben und das getan habe was ich schon hätte sofort tun sollen, nämlich meine Autostart bis auf wichtige Dinge geleert habe "tut ihn wieder wie er soll".
Nur warum weshalb weiss ich auch nicht wirklich, vorallem warum Windos so empfindlich reagiert, war die erste richtige Störung seit über fünf Jahren. Meine Vermutung, da ich bisher eigendlich immer alle unnötigen Programme aus der Autostart entfernt hatte, hatte ich eigendlich nie grössere Probleme. In letzter Zeit hatte ich mit einigen Programmen experimentiert und habe meine Routine dabei vernachlässigt :oops:. Nun ist Autostart mehr oder weniger blank und es funzt wieder. Warum?? Keine wirkliche Ahnung.
Der grösste Vertrauensbruch ist der Blitzableiter auf der Kirchturmspitze
User avatar
Pitze
 
Posts: 210
Joined: 20. November 2003 21:38
Location: Huskvarna-Schweden
XAMPP Version: 5.6.3
Operating System: Windows Vista


Return to MySQL

Who is online

Users browsing this forum: No registered users and 4 guests