Kleines Problem... (vielleicht ne dumme frage(vom n00b!))

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

Kleines Problem... (vielleicht ne dumme frage(vom n00b!))

Postby DagobertDuckGSG » 25. December 2003 00:27

Hallo Leutz! Ich bin n völliges Newbie (muss ich leider sagen *g*), habs aber schon geschafft mir nen Webserver mit php, mysql etc. zu backen!

Aaaaber ich hab auch ein Problem!

In der Textdatei steht das:
Der MySQL-Server startet ohne Passwort für MySQl-Administrator "root".
Für eine Zugriff in PHP sähe das also aus:
mysql_connect("localhost","root","");
Ein Passwort für "root" könnt ihr über den mysqladmin in der Eingabforderung
setzen. Z.B:
\php5xampp-dev\mysql\bin\mysqladmin -u root password geheim
Wichtig: Nach dem einsetzen eines neuen Passwortes für root muss auch
PHPMyAdmin informiert werden! Das geschieht über die Datei "config.inc.php"
zu finden als \php5xampp-dev\phpmyadmin\config.inc.php. Dort also folgenden
Zeilen editieren:



usw.
Ich hab die Textdatei jetzt geändert! also da stehen unter user root, unter password mein passwort und als auth_type http! Das oben beschreibene passwort setzten per eingabeaufforderung klappt jedoch nicht! Es gibt eine Fehlermeldung dass kein Password verwendet wird! ('Access denied for user: 'root@127.0.0.1' (Using password: NO)') joa... und wenn ich jetzt per phpmyadmin zugreifen will kommt diese fehlermelldung:
Access denied for user: 'ODBC@127.0.0.1' (Using password: YES)

Also meine Fragen: WIE krieg ich das Passwort eingesetzt?
Und was zum Geier is ODBC? Ich dachte, wenn man als auth_type http angibt, wird man gefragt als wer/was man sich einloggen will! ich wurde nämlich immer als odbc eingeloggt und konnte dann auch keine passwörter ändern etc.!

Sorry, vielleicht unterfordere ich euch, aber das is mir sehr wichtig!

MfG Dago
DagobertDuckGSG
 
Posts: 2
Joined: 25. December 2003 00:17
Location: Winsen (nahe Hamburg)

Postby DagobertDuckGSG » 25. December 2003 00:34

Tut mir leid, dass ich soviel Traffic hier verursacht hab ;) Lag wahrscheinlich an der alten Version meines myphpadmin!

MfG Dago

PS: Also hat sich wohl ersma erledigt!
DagobertDuckGSG
 
Posts: 2
Joined: 25. December 2003 00:17
Location: Winsen (nahe Hamburg)


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 1 guest