MySQL kann nicht starten

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

MySQL kann nicht starten

Postby yox » 18. October 2008 15:53

Hallo ich habe mein MySQL ( Xampp ) neuinstalliert sprich deinstalliert und neuinstalliert. Nun kommt bei dem starten von MySQL folgende fehler Meldung.

Code: Select all
081018  16:47:29 InnoDB: Started; log sequence number 0 43655
081018  16:47:29 [ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.user' doen't exist


Vorher hatte ich eine DB mit Password nur ich weis nicht wie ich es jetzt in MySQL resete oder das alte wieder rein bekomme, wobei mir letzeres lieber wäre. :D

MfG yox
yox
 
Posts: 7
Joined: 18. October 2008 15:46

Postby Wiedmann » 18. October 2008 16:02

Can't open and lock privilege tables: Table 'mysql.user' doen't exist

Gibts die Datei (user.*) denn bei dir in "\xampp\mysql\data\mysql"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby yox » 18. October 2008 16:06

ja gibt es 3 stück sogar .frm .myd .myi zusätzlich noch mein laptop (Laptop-Tobias.err)

Oda moment hier die letzten error logs.

Code: Select all
081018 16:13:47 [Note] c:\xampp\mysql\bin\mysqld-nt.exe: Normal shutdown

081018 16:13:49  InnoDB: Operating system error number 32 in a file operation.
InnoDB: The error means that another program is using InnoDB's files.
InnoDB: This might be a backup or antivirus software or another instance
InnoDB: of MySQL. Please close it to get rid of this error.
081018 16:13:49 [Warning] c:\xampp\mysql\bin\mysqld-nt.exe: Forcing close of thread 43  user: 'root'

081018 16:13:49  InnoDB: Starting shutdown...
081018 16:13:51  InnoDB: Shutdown completed; log sequence number 0 43655
081018 16:13:51 [Note] c:\xampp\mysql\bin\mysqld-nt.exe: Shutdown complete

081018 16:13:59  InnoDB: Started; log sequence number 0 43655
081018 16:13:59 [ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.user' doesn't exist
yox
 
Posts: 7
Joined: 18. October 2008 15:46

Postby Wiedmann » 18. October 2008 16:22

081018 16:13:49 InnoDB: Operating system error number 32 in a file operation.
InnoDB: The error means that another program is using InnoDB's files.

Irgendeinen Virenscanner laufen?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby yox » 18. October 2008 16:26

nein eben lief nur ein restarter für die db falls sie abschmiert
yox
 
Posts: 7
Joined: 18. October 2008 15:46

Postby Nobbie » 18. October 2008 20:41

Wiedmann wrote:
Can't open and lock privilege tables: Table 'mysql.user' doen't exist

Gibts die Datei (user.*) denn bei dir in "\xampp\mysql\data\mysql"?


InnoDB legt nicht (wie MyISAM) pro Tabelle die "bekannten" drei Dateien pro Tabelle an.

ja gibt es 3 stück sogar .frm .myd .myi zusätzlich noch mein laptop (Laptop-Tobias.err)


Das sind keine InnoDB Tabellen (s.o.).
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Postby Wiedmann » 18. October 2008 21:24

Nobbie wrote:InnoDB legt nicht (wie MyISAM) pro Tabelle die "bekannten" drei Dateien pro Tabelle an.

"mysql.user" ist nach wie vor eine MyISAM-Tabelle (Fehlermeldung 2). Die InnoDB-Engine hat zusätzlich auch ein Problem beim Zugriff (Fehlermeldung 1)

yox wrote:Hallo ich habe mein MySQL ( Xampp ) neuinstalliert sprich deinstalliert und neuinstalliert.

Welches OS?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Nobbie » 18. October 2008 22:13

Wiedmann wrote:"mysql.user" ist nach wie vor eine MyISAM-Tabelle (Fehlermeldung 2).


Woran erkennst Du das?
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Postby yox » 19. October 2008 00:10

hmm danke das ihr euch darum kümmert ... weis absolut net wie ich des wieda hinbekommen soll .... vorallem nach neuinstall ist das problem ja immer noch da xD
yox
 
Posts: 7
Joined: 18. October 2008 15:46

Postby Wiedmann » 19. October 2008 00:23

hmm danke das ihr euch darum kümmert ...

Das wäre einfacher, wenn du z.B: die obige Frage beantwortest...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby yox » 19. October 2008 01:32

Nobbie wrote:
Wiedmann wrote:"mysql.user" ist nach wie vor eine MyISAM-Tabelle (Fehlermeldung 2).


Woran erkennst Du das?


das soll ich beantworten ? Habs net an mich gerichtet empfunden .... habe ka was ne MyISAM Tabelle ist ....
yox
 
Posts: 7
Joined: 18. October 2008 15:46

Postby Nobbie » 19. October 2008 10:05

Aus irgendeinem Grund wird bei Dir InnoDB als Datenbanktyp aktiviert, aber bei Xampp ist normalerweise MyISAM aktiviert.

Ich vermute (mehr geht bei den wenigen Infos nicht), dass Du die Konfiguration von MySQL "zerschossen" hast. Diese wird (auch "normalerweise") in einer Datei mit dem Namen "my.cnf" gespeichert.

Du hast auch immer noch nicht geschrieben, welches Betriebssystem Du benutzt (wahrscheinlich Windows XP?).
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Postby yox » 19. October 2008 23:01

Also ich fahre Vista ... auf einen Laptop. Zerschossen könnte stimmen denn es kam erst nachdem ich nen blue screen hatte ... weis net ob das jetzt dazu beigetragen hat. Und diese my.cfg find ich net in mysql oder meintest du jetzt in Xampp generell ?
yox
 
Posts: 7
Joined: 18. October 2008 15:46

Postby Wiedmann » 19. October 2008 23:12

Also ich fahre Vista ...

UAC natürlich deaktiviert (für's XAMPP-Dir) und der XAMPP nicht unterhalb von "\Programme" installiert?

Zerschossen könnte stimmen denn es kam erst nachdem ich nen blue screen hatte ...

Nach einer Neuinstallation (siehe dein erster Post) wären ja alle Datenbanken wieder neu und im Ursprungszustand. (Oder hast du uns noch irgendwelche Sachen verschwiegen?)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby yox » 20. October 2008 07:40

Wiedmann wrote:
Also ich fahre Vista ...

UAC natürlich deaktiviert (für's XAMPP-Dir) und der XAMPP nicht unterhalb von "\Programme" installiert?

Zerschossen könnte stimmen denn es kam erst nachdem ich nen blue screen hatte ...

Nach einer Neuinstallation (siehe dein erster Post) wären ja alle Datenbanken wieder neu und im Ursprungszustand. (Oder hast du uns noch irgendwelche Sachen verschwiegen?)


Okay das Sprichwort "Der Computer ist nur so schlau wie sein Besitzer" passt mal wieder total XDDD

Habs nocheinmal gelöscht... diesmal alles was mit Xampp zutun hatte. Da er den Backup ordner nicht gelöscht hat ( den ich selbst angelegt hatte ) aus diesem hat er wohl die Daten bezogen.... nun geht alles wieder :D

Danke für die mühe... gute hilfe doch wenn der Benutzer es verbockt kanns ja net klappen.


MfG yox

PS: Bis zum nächsten mal :D *Wiedmann lob*
yox
 
Posts: 7
Joined: 18. October 2008 15:46


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 3 guests