mysql administrator problem

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

mysql administrator problem

Postby imsDave » 24. March 2008 21:23

I am trying to connect to mysql database remotely via mysql administrator gui. I am able to connect locally (localhost) but when i try connect remotely i get the following error:
Code: Select all
Could not connect to the specified instance.

MySQL Error Number 2003
Can't connect to MySql server on '[i]ipaddress[/i]' (10065)

If you want to check the network connection, please click the Ping button.


MySql is hosted on a linux machine. And my remote client is a windows os. Does anyone know why this doesn't work?

Thanks
imsDave
 
Posts: 9
Joined: 24. March 2008 17:45

Postby Xardas der Dunkle » 24. March 2008 22:30

Some MySQL-Servers block remote connections, for limiting the traffic.
Last edited by Xardas der Dunkle on 24. March 2008 22:31, edited 1 time in total.
User avatar
Xardas der Dunkle
 
Posts: 482
Joined: 09. March 2008 19:40
Location: /var/www

Postby imsDave » 24. March 2008 22:31

Xardas der Dunkle wrote:Some MySQL-Servers block remote connections.


How do i find one that doesn't?
imsDave
 
Posts: 9
Joined: 24. March 2008 17:45

Postby Xardas der Dunkle » 24. March 2008 22:32

Where you host your MySQL-Database?
User avatar
Xardas der Dunkle
 
Posts: 482
Joined: 09. March 2008 19:40
Location: /var/www

Postby imsDave » 24. March 2008 22:33

Xardas der Dunkle wrote:Where you host your MySQL-Database?


On RHEL 5.0. It's just a virtual machine on the same computer that runs windows.
imsDave
 
Posts: 9
Joined: 24. March 2008 17:45

Postby Xardas der Dunkle » 24. March 2008 22:45

On a virtual Machine?

First you shoult test if the network connection of the virtual machine ist alive.

The mysql-user need the permissions to deal with remote-connections. For that you have to change the value of the field 'host' in the table user (on database 'mysql') to '%'.

Sorry my english is not very well .__.
User avatar
Xardas der Dunkle
 
Posts: 482
Joined: 09. March 2008 19:40
Location: /var/www

Postby imsDave » 24. March 2008 22:56

Xardas der Dunkle wrote:On a virtual Machine?

First you shoult test if the network connection of the virtual machine ist alive.

The mysql-user need the permissions to deal with remote-connections. For that you have to change the value of the field 'host' in the table user (on database 'mysql') to '%'.

Sorry my english is not very well .__.


The connection is alive. I can ping the Linux machine.

I don't have any 'mysql-user' in this table. I installed Lampp using the root user. Is that a problem? I have 5 records in this table.
imsDave
 
Posts: 9
Joined: 24. March 2008 17:45

Postby Xardas der Dunkle » 24. March 2008 23:02

The root-user is in taht table too. And the host of him, can also be 'localhost'. You have to change it to: '%' for connection by remote.
User avatar
Xardas der Dunkle
 
Posts: 482
Joined: 09. March 2008 19:40
Location: /var/www

Postby imsDave » 24. March 2008 23:11

Xardas der Dunkle wrote:The root-user is in taht table too. And the host of him, can also be 'localhost'. You have to change it to: '%' for connection by remote.


Ok. So I have a record that looks like this:

localhost root ...

I changed it to look like:

% root ...

This didn't work. Is this what you were talking about?
imsDave
 
Posts: 9
Joined: 24. March 2008 17:45

Postby Xardas der Dunkle » 24. March 2008 23:13

Yes thats it. Have you restartet the mysql-server?
User avatar
Xardas der Dunkle
 
Posts: 482
Joined: 09. March 2008 19:40
Location: /var/www

Postby imsDave » 24. March 2008 23:19

Xardas der Dunkle wrote:Yes thats it. Have you restartet the mysql-server?


didn't work. Also, now i can't see my database when i connect on the localhost.
imsDave
 
Posts: 9
Joined: 24. March 2008 17:45

Postby sari42 » 25. March 2008 11:20

some installations need both :
localhost | root
and
% | root

btw, I'd suggest a special
% | remoteadmin
instead of root - YMMV
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby imsDave » 25. March 2008 17:42

sari42 wrote:some installations need both :
localhost | root
and
% | root

btw, I'd suggest a special
% | remoteadmin
instead of root - YMMV


That didn't work either :( Is there a configuration setting in my.cnf that im missing maybe?

BTW, I appreciate all the help.
imsDave
 
Posts: 9
Joined: 24. March 2008 17:45


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 2 guests