Fehlermeldung beim anlegen einer neuen DB

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

Fehlermeldung beim anlegen einer neuen DB

Postby Freelancer » 20. October 2003 14:19

Wenn ich mit "mysqladmin create name" eine neue DB anlegen will, bekomm ich folgende fehlermeldung:

Code: Select all
/opt/lampp/bin/mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user: 'root@localhost' (Using password: NO)'


Was muss ich machen damit das funktioniert? Thx
Freelancer
 
Posts: 2
Joined: 20. October 2003 14:15

Postby Oswald » 20. October 2003 14:30

Hallo Freelancer!

Hast Du für den MySQL-root ein Passwort gesetzt?

Wenn ja dann mit -pxxx beim Aufruf angeben. xxx steht für Dein Passwort. Zwischen -p und Passwort kein Leerzeichen.

Lieben Gruß
Oswald

PS: Geht's so?
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Freelancer » 20. October 2003 14:37

Also zumindest bekomm ich keine Fehlermeldung mehr, aber es wird trotzdem keine neue DB angelegt.

Edit: Zumindest wird sie nich unter phpmyadmin angezeigt. Im verzeichniss vom mysql wurde sie angelegt
Last edited by Freelancer on 20. October 2003 14:40, edited 1 time in total.
Freelancer
 
Posts: 2
Joined: 20. October 2003 14:15

Postby Oswald » 20. October 2003 14:40

Wie guckst Du nach ob die Datenbank da ist? Wenn mit phpMyadmin ist: Mal ganz rausgehen und quasi phpMyAdmin neu starten/aufrufen.

Ansonsten ruf mal /opt/lampp/bin/mysql -pxxx auf und gib dann SHOW DATABASES ein. Dort solltest Du nun auch Deine neue Datenbank sehen.

Gruß
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 2 guests