MySQL übers Netzwerk

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

MySQL übers Netzwerk

Postby Herst » 22. January 2008 12:48

Hallo!

was muss ich tun, damit ich auf den von XAMPP vorinstallierte MySQL-Server übers Netzwerk zugreifen kann? ... unter Sicherheit steht bei MySQL folgendes:
MySQL ist über's Netzwerk erreichbar UNSICHER
Auf die MySQL-Datenbank kann potentiell über's Netzwerk zugegriffen werden. Zwar ist es in der Standardinstallation von XAMPP trotzdem nicht möglich von außen Zugriff zur Datenbank zu bekommen. Aber um eine absolute Sicherheit zu bekommen sollte der Netzwerkzugriff auf MySQL abgeschaltet werden.


Betriebssystem: Ubuntu Linux

Vielen Dank im Voraus für Eure Hilfe
Herst
 
Posts: 10
Joined: 22. January 2008 11:45

Postby Scory » 22. January 2008 17:14

>was muss ich tun, damit ich auf den von XAMPP vorinstallierte MySQL-Server übers Netzwerk zugreifen kann?

Zugreifen.

Die Frage verstehe ich nicht. Du mußt das tun, was man tun muss, um auf MySQL zuzugreifen.

In PHP wäre das beispielsweise via mysql_connect() und dort den Servernamen (= IP-Adresse im LAN), einen gültigen User sowie dessen Passwort angeben. Wichtig ist, dass dieser (MySQL-User) einen Zugriff von beliebigen Rechnern erlaubt (kannst Du mit phpmyadmin überprüfen).
Scory
 

Postby DJ DHG » 23. January 2008 00:41

Moin Moin!

Falls in der my.conf "skip-networking" zu finden ist, kann gar nicht auf MySql von "außen" zugegriffen werden.
Nur von localhost.

Falls bind-address=<IP-Adresse>, dann nur über eben diese IP.

Und dann muss der User selbst es auch noch dürfen.
Sprich unter "host" entweder die IP von der aus zugegriffen werden darf oder ein * falls es
von überall aus erlaubt sein soll.

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby Herst » 23. January 2008 15:53

erstmal danke für die Antworten!

Original von Scory
Die Frage verstehe ich nicht. Du mußt das tun, was man tun muss, um auf MySQL zuzugreifen.


Ich würde gerne wissen welche Einstellungen ich am Server treffen muss damit ich zum MySQL-Server via Telnet oder einem Programm wie z.B. "Navicat" eine Verbindung aufbauen kann. Jetzt verständlich?

@DJ DHG
- in der my.cnf steht skip networking... ist aber auskommentiert ... dürfte also nicht stören, oder?
- bind-address kommt gar nicht in der my.cnf vor
- ich habe mit phpMyAdmin einen User angelegt und ins Feld "host" einen * geschrieben
- Die Fehlermeldung lautet: Host ist not allowed to connect to this MySQL server

vielleicht hilfts etwas wenn ich mal meine my.cnf reinstelle:
    # Example MySQL config file for medium systems.
    #
    # This is for a system with little memory (32M - 64M) where MySQL plays
    # an important part, or systems up to 128M where MySQL is used together with
    # other programs (such as a web server)
    #
    # You can copy this file to
    # /etc/my.cnf to set global options,
    # mysql-data-dir/my.cnf to set server-specific options (in this
    # installation this directory is /opt/lampp/var/mysql) or
    # ~/.my.cnf to set user-specific options.
    #
    # In this file, you can use all long options that a program supports.
    # If you want to know which options a program supports, run the program
    # with the "--help" option.

    # The following options will be passed to all MySQL clients
    [client]
    #password = your_password
    port = 3306
    socket = /opt/lampp/var/mysql/mysql.sock

    # Here follows entries for some specific programs

    # The MySQL server
    [mysqld]
    port = 3306
    socket = /opt/lampp/var/mysql/mysql.sock
    skip-locking
    key_buffer = 16M
    max_allowed_packet = 1M
    table_cache = 64
    sort_buffer_size = 512K
    net_buffer_length = 8K
    read_buffer_size = 256K
    read_rnd_buffer_size = 512K
    myisam_sort_buffer_size = 8M

    # Don't listen on a TCP/IP port at all. This can be a security enhancement,
    # if all processes that need to connect to mysqld run on the same host.
    # All interaction with mysqld must be made via Unix sockets or named pipes.
    # Note that using this option without enabling named pipes on Windows
    # (via the "enable-named-pipe" option) will render mysqld useless!
    #
    #skip-networking

    # Replication Master Server (default)
    # binary logging is required for replication
    # log-bin deactivated by default since XAMPP 1.4.11
    #log-bin=mysql-bin

    # required unique id between 1 and 2^32 - 1
    # defaults to 1 if master-host is not set
    # but will not function as a master if omitted
    server-id = 1

    # Replication Slave (comment out master section to use this)
    #
    # To configure this host as a replication slave, you can choose between
    # two methods :
    #
    # 1) Use the CHANGE MASTER TO command (fully described in our manual) -
    # the syntax is:
    #
    # CHANGE MASTER TO MASTER_HOST=<host>, MASTER_PORT=<port>,
    # MASTER_USER=<user>, MASTER_PASSWORD=<password> ;
    #
    # where you replace <host>, <user>, <password> by quoted strings and
    # <port> by the master's port number (3306 by default).
    #
    # Example:
    #
    # CHANGE MASTER TO MASTER_HOST='125.564.12.1', MASTER_PORT=3306,
    # MASTER_USER='joe', MASTER_PASSWORD='secret';
    #
    # OR
    #
    # 2) Set the variables below. However, in case you choose this method, then
    # start replication for the first time (even unsuccessfully, for example
    # if you mistyped the password in master-password and the slave fails to
    # connect), the slave will create a master.info file, and any later
    # change in this file to the variables' values below will be ignored and
    # overridden by the content of the master.info file, unless you shutdown
    # the slave server, delete master.info and restart the slaver server.
    # For that reason, you may want to leave the lines below untouched
    # (commented) and instead use CHANGE MASTER TO (see above)
    #
    # required unique id between 2 and 2^32 - 1
    # (and different from the master)
    # defaults to 2 if master-host is set
    # but will not function as a slave if omitted
    #server-id = 2
    #
    # The replication master for this slave - required
    #master-host = <hostname>
    #
    # The username the slave will use for authentication when connecting
    # to the master - required
    #master-user = <username>
    #
    # The password the slave will authenticate with when connecting to
    # the master - required
    #master-password = <password>
    #
    # The port the master is listening on.
    # optional - defaults to 3306
    #master-port = <port>
    #
    # binary logging - not required for slaves, but recommended
    #log-bin=mysql-bin


    # Point the following paths to different dedicated disks
    #tmpdir = /tmp/
    #log-update = /path-to-dedicated-directory/hostname

    # Uncomment the following if you are using BDB tables
    #bdb_cache_size = 4M
    #bdb_max_lock = 10000

    # Comment the following if you are using InnoDB tables
    skip-innodb
    innodb_data_home_dir = /opt/lampp/var/mysql/
    innodb_data_file_path = ibdata1:10M:autoextend
    innodb_log_group_home_dir = /opt/lampp/var/mysql/
    innodb_log_arch_dir = /opt/lampp/var/mysql/
    # You can set .._buffer_pool_size up to 50 - 80 %
    # of RAM but beware of setting memory usage too high
    innodb_buffer_pool_size = 16M
    innodb_additional_mem_pool_size = 2M
    # Set .._log_file_size to 25 % of buffer pool size
    innodb_log_file_size = 5M
    innodb_log_buffer_size = 8M
    innodb_flush_log_at_trx_commit = 1
    innodb_lock_wait_timeout = 50

    [mysqldump]
    quick
    max_allowed_packet = 16M

    [mysql]
    no-auto-rehash
    # Remove the next comment character if you are not familiar with SQL
    #safe-updates

    [isamchk]
    key_buffer = 20M
    sort_buffer_size = 20M
    read_buffer = 2M
    write_buffer = 2M

    [myisamchk]
    key_buffer = 20M
    sort_buffer_size = 20M
    read_buffer = 2M
    write_buffer = 2M

    [mysqlhotcopy]
    interactive-timeout
Herst
 
Posts: 10
Joined: 22. January 2008 11:45

Postby sari42 » 23. January 2008 17:25

> ich habe mit phpMyAdmin einen User angelegt und ins Feld "host" einen * geschrieben
es muß aber ein "%" (mysql-wildcard sein)

p.s.
keine Zeit den Rest zu lesen...
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby DJ DHG » 23. January 2008 19:27

sari42 wrote:es muß aber ein "%" (mysql-wildcard sein)


Sorry, damit hast du natürlich recht!
Mein Fehler.

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby Herst » 24. January 2008 14:11

ich hab jetzt alles durch ein % ersetzt, hab aber nachwievor die Fehlermeldung:
Host '<IP-Adresse>' is not allowed to connect to this MySQL-Server
Herst
 
Posts: 10
Joined: 22. January 2008 11:45

Postby Scory » 24. January 2008 15:41

>ich hab jetzt alles durch ein % ersetzt

Was heißt "alles durch ein % ersetzt" - das ist todsicher falsch. Du sollst nicht "alles" (was alles das auch immer ist) durch % ersetzen, sondern ganz gezielt nur bei einem MySQL-User an einer Stelle ein einziges %-Zeichen setzen, dort wo der Zugriffsrechner spezifiziert wird. Das wäre aber Meilen entfernt vom unbestimmten "alles".
Scory
 

Postby Herst » 24. January 2008 16:07

ich meinte in phpMyAdmin die * im Host-Feld bei allen Benutzern
Herst
 
Posts: 10
Joined: 22. January 2008 11:45

Postby Herst » 25. January 2008 07:27

für mein Verständnis ist das auch kein Benutzerproblem (korrigiert mich wenn ich falsch liege) wenn ich bereits vom Server abgewiesen werde bevor ich einen User angebe, ausserdem die Fehlermeldung "Host is not allowed..." lässt mich eher annehmen, dass in der my.cnf was nicht stimmt....
wäre nett wenn sich jemand die my.cnf mal ansehen würde (siehe mein 2. Posting) und mir sagen würde ob die so in Ordnung ist

mfg
Herst
Herst
 
Posts: 10
Joined: 22. January 2008 11:45

Postby Scory » 25. January 2008 15:23

Auch wenn es überraschend klingt: niemand hier kann Gedanken lesen, geschweige denn Deinen Bildschirm sehen.

Du bist Dir im Klaren darüber, dass hier niemand auch nur ansatzweise versteht, wann wo von wem oder was wie welche Meldung kommt. Du jedenfalls hast keinerlei (nicht ein Byte) Infos dazu gegeben.

Nur, dass Du gerne mit Navicat auf MySQL zugreifen willst. Mehr weiß hier leider niemand. Deine angedeuteten Fehlermeldungen kann niemand zuordnen, weder einer Software noch einem Zustand.
Scory
 

Postby Herst » 25. January 2008 16:43

sorry... dachte es wäre klar dass ich die Fehlermeldung beim Versuch die Verbindung herzustellen sowohl in der cmd per telnet als auch im navicat bekomme.
Herst
 
Posts: 10
Joined: 22. January 2008 11:45

Postby Scory » 25. January 2008 23:15

Nö, gar nichts ist klar.

Es ist noch nicht einmal klar, WIE Du versuchst, die Verbdindung herzustellen, geschweige denn, welche Rechner beteiligt sind und welche Betriebssysteme.

Der einzige, der halbwegs weiß, was da stattfindet, sitzt auf Deinem Stuhl. Niemand sonst auf der Welt.

Also sei nicht verzweifelt, dass keine Hilfevorschläge kommen - es KANN KEINER helfen, egal wie groß der Wille ist.
Scory
 

Postby Herst » 28. January 2008 10:41

ich weiß nur leider auch nicht welche Informationen du benötigst.

Der Server ist ein IBM e-Server xSeries335, wie ich oben schon geschrieben hab ist ein Ubuntu mit XAMPP installiert

Der Rechner mit dem ich zugreifen will ist ein IBM Think Centre mit Windows XP Pro

zwischen dem Netzwerk in dem der Client steht und dem in dem der Server steht ist ein Router mit Firewall bei der alle Ports offen sind!

meine Arbeitsschritte beim Versuch eine Verbindung herzustellen:

Navicat starten:
Start-->Alle Programme-->Premium Soft-->Navicat 8.0 Lite for MySQL-->Navicat Lite for MySQL


Verbindung herstellen:
(in Navicat) Datei --> Neue Verbindung -->
Reiter "Allgemein" --> IP Adresse, Port, Benutzername, Passwort eingeben --> Button "Verbindung Testen" klicken

Fehlermeldung: 1130 - Host '<Client-IP-Adresse>' ist not allowed to connect to this MySQL server.
Herst
 
Posts: 10
Joined: 22. January 2008 11:45

Postby Scory » 28. January 2008 21:10

Reiter "Allgemein" --> IP Adresse, Port, Benutzername, Passwort eingeben --> Button "Verbindung Testen" klicken

Fehlermeldung: 1130 - Host '<Client-IP-Adresse>' ist not allowed to connect to this MySQL server.


Stück für Stück Knabberglück - jetzt mußt Du nur noch die obigen Angaben "entanonymisieren", sprich: sage uns doch bitte bitte welche IP du dort angibst, welchen Port, welchen User und welches Passwort. Kannst Du später auch bestimmt wieder ändern.

Danach frage ich weiter - in ein paar Wochen haben wir es dann sicher langsam geschafft, bei der mühseligen "Würmer-aus-der-Nase-Zieherei".

Vergiss nie: wir wissen alle gar nichts von Deinem Netzwerk, keine IPs, keine Datenbanken, keine Benutzer, nichts, null, de nada. Um aber die Ursache zu finden, müssen wir genau das Gegenteil wissen: nämlich alles dieses und NOCH VIEL MEHR.
Scory
 

Next

Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 4 guests