LAMPP 1.6.4 -> MySQL ist über's Netzwerk erreichbar

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

LAMPP 1.6.4 -> MySQL ist über's Netzwerk erreichbar

Postby CrazyDigital » 29. October 2007 06:44

Hallo zusammen,


bis vor kurzem hatte ich den LAMPP 1.6.3 bei mir am laufen, flutschte alles einwandfrei. Ich war super zufrieden!

Aber nach einem Hardware-Crash (und kompletter Neuinstallierung) auf dem Server bin ich gerade dabei, den XAMPP 1.6.4 einzurichten.

Allerdings habe ich ff. Problem:

Jedesmal, wenn ich ein "./lampp security" mache, und sage, das MySQL über das Netzwerk NICHT zu ereichen sein soll, erscheint im Script ff. ausgabe ->

----
XAMPP: MySQL ist ueber's Netzwerk erreichbar.
XAMPP: Normalerweise wird dies nicht benoetigt. Soll ich es abschalten? [ja]
XAMPP: Abgeschaltet!
XAMPP: Stoppe MySQL...
XAMPP: Starte MySQL...
----

So, wenn ich jetzt allerdings den Sicherheitscheck auf http://localhost betrachte, steht dort ->

----
MySQL ist über's Netzwerk erreichbar **UNSICHER**
Auf die MySQL-Datenbank kann potentiell über's Netzwerk zugegriffen werden. Zwar ist es in der Standardinstallation von XAMPP trotzdem nicht möglich von außen Zugriff zur Datenbank zu bekommen. Aber um eine absolute Sicherheit zu bekommen sollte der Netzwerkzugriff auf MySQL abgeschaltet werden.
----

Komisch komisch. Ich denke, er hat den Zugriff abgeschaltet?!?

So, ab in's Forum, und mal ein wenig rumgewuselt. Da bin ich auf den Eintrag http://community.apachefriends.org/f/viewtopic.php?t=26171 gestoßen.

Hier habe ich mal in meine my.cnf statt dem "skip-networking" den "bind-address" ausprobiert. Immernoch ist MYSQL über's Netz zu erreichen. Auch bei beiden Einträgen parallel besteht dieses Problem. :evil: :evil:


Nun meine Frage:

Wie kann ich XAMPP so einstellen, das MYSQL "nicht" mehr über's Netzwerk zu erreichen ist? Was mache ich falsch? :oops:

BTW: Ich hab openSUSE 10.3 am laufen. "Lokal" sind alle Dienste deaktiviert, nur LAMPP ist aktiv, falls das jmd. von Euch von Bedeutung ist :-s


Lieben Dank schon jetzt für Eure Hilfen / Infos,


der Marc...
CrazyDigital
 
Posts: 3
Joined: 29. October 2007 06:28
Location: 35390 Gießen

Postby CrazyDigital » 30. October 2007 08:40

kann mir denn keiner helfen?!?!?? :cry:
CrazyDigital
 
Posts: 3
Joined: 29. October 2007 06:28
Location: 35390 Gießen

Postby high-voltages » 30. October 2007 22:38

habe das selbe Problem ! ! !

weis da keine ne antwort drauf ?

MFG
High-voltages
Image
high-voltages
 
Posts: 11
Joined: 25. February 2006 14:36

Postby Gitarremann » 05. November 2007 16:25

Moin Forum!

Ich hab das gleiche Problem

Ich hab auch schon versucht in der

/opt/lampp/etc/my.cnf

diesen Eintrag skip_networking zu kommentieren, nicht zu kommentieren und ganz rauszunehmen, jede Änderung bei ein und ausgeschaltetem lampp bzw mysql und mit restart und komplettem Rechnerneustart aber es ändert sich nix. Die Meldung, dass mysql über das Netzwerk erreichbar ist bleibt.
Gitarremann
 
Posts: 7
Joined: 05. November 2007 16:18

Postby Zaeggu » 06. November 2007 12:35

Yap, ich habe mit der neuesten Version das selbe, es bleibt immer UNSICHER, kommt mir vor, als ob der Befehl gar nicht Ausgeführt würde!

Edit: Ich habe Xampp in Ubuntu Gutsy 32bit auf nem 64bit Rechner, wo ich die änderung vorgenommen hatte, damit lampp starten kann, ist dies eventuell das selbe problem, da es ein 64bit Rechner ist?
Gruss Zaeggu
Zaeggu
 
Posts: 37
Joined: 20. April 2006 08:00

Postby CrazyDigital » 06. November 2007 15:33

ich hab wie schon gesagt das openSUSE 10.3 (sauber aktuell) als i586 am laufen.


es muss doch jemanden geben, der uns da weiterhelfen kann, oder?

solange, wie dieses problem bei mir besteht, ist das LAMPP bei mir auf "stop".
und somit gibts bei mir auch keinen DDNS-Server :cry:
CrazyDigital
 
Posts: 3
Joined: 29. October 2007 06:28
Location: 35390 Gießen

Postby Wiedmann » 06. November 2007 15:55

solange, wie dieses problem bei mir besteht, ist das LAMPP bei mir auf "stop".

Hm, wenn ich dich richtig verstanden habe, läuft Apache + MySQL doch bei dir. Wieso ist der jetzt dann auf "stop"? Von einem Startfehler hast du bisher nichts berichtet...

es muss doch jemanden geben, der uns da weiterhelfen kann, oder?

Wie wäre es, wenn du den Wahrheitsgehalt der Aussage von der Sicherheitscheck Seite einfach selbst mal überprüfst, und uns das Ergebnis dann mitteilst?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Scory » 06. November 2007 16:25

Das Problem liegt im fehlerhaften Script checkmysqlport im Verzeichnis /opt/lampp/share/lampp - da sind einige Fehler drin.

Es wird dort gesucht, ob es in /opt/lampp/etc/my.cnf einen Bereich [mysqld] oder [mysqldump] gibt und ob es dort einen Eintrag "port = xxxx" gibt. Meistens steht da dann "port = 3306".

Leider ist in diesem Script einiges falsch programmiert (würde hier zu weit führen), deswegen ignoriert es einfach und schreibt entweder "port = 0" unter [mysqld] oder eben skip-network in my.cnf hinein. Letzteres tut das o.g. Script auch (manche werden das jetzt x-fach dort finden, löscht die überflüssigen Zeilen wieder weg), kümmert sich aber einen Dreck darum, ob das nicht schon so da steht und wertet es auch nicht aus.

Wenn ihr Lampp dann startet, ist alles in Ordnung.
Scory
 

Postby Zaeggu » 06. November 2007 18:15

Sorry Scory, aber deine Aussage: "Wenn ihr Lampp dann startet, ist alles in Ordnung." ist sowas von Müll, was nicht einmal ne Korrektur des Fehlers nachweist, sondern nur: Ha, bei mir läuft alles wie es sollte!

Giebt es noch Anwender, oder Supporter, die Richtig Antworten?

Edit: Gerade mal 7 Tage Registriert, und 10 Posts, und schon so Anwenderabweisend! Wirklich Klasse!
Gruss Zaeggu
Zaeggu
 
Posts: 37
Joined: 20. April 2006 08:00

Postby Gitarremann » 06. November 2007 20:58

Scory wrote:Das Problem liegt im fehlerhaften Script checkmysqlport im Verzeichnis /opt/lampp/share/lampp - da sind einige Fehler drin.

Es wird dort gesucht, ob es in /opt/lampp/etc/my.cnf einen Bereich [mysqld] oder [mysqldump] gibt und ob es dort einen Eintrag "port = xxxx" gibt. Meistens steht da dann "port = 3306".

Leider ist in diesem Script einiges falsch programmiert (würde hier zu weit führen), deswegen ignoriert es einfach und schreibt entweder "port = 0" unter [mysqld] oder eben skip-network in my.cnf hinein. Letzteres tut das o.g. Script auch (manche werden das jetzt x-fach dort finden, löscht die überflüssigen Zeilen wieder weg), kümmert sich aber einen Dreck darum, ob das nicht schon so da steht und wertet es auch nicht aus.

Wenn ihr Lampp dann startet, ist alles in Ordnung.


Das mit dem "skip-network" hab ich ja bereits probiert, siehe oben. Funktioniert aber nicht.
Gitarremann
 
Posts: 7
Joined: 05. November 2007 16:18

Postby Scory » 07. November 2007 00:10

Zaeggu wrote:Sorry Scory, aber deine Aussage: "Wenn ihr Lampp dann startet, ist alles in Ordnung." ist sowas von Müll, was nicht einmal ne Korrektur des Fehlers nachweist, sondern nur: Ha, bei mir läuft alles wie es sollte!!


Du bist doch so ein blödes Arsch, das gibt es doch wohl nicht. Ich bin genau so ein Anwender wie jeder andere auch, habe das gleiche Problem festgestellt UND mir die Mühe gemacht, den Fehler zu finden.

Der "Fehler" ist der, dass die Fehlermeldung falsch ist - das scheint für Dich schon zu hoch zu sein. Ich könnte echt kotzen, lies doch demnächst einfach keine Hilfetexte mehr, wenn Du zu dämlich bist, selbst die gutgemeinte (und durchaus aufwändige) Unterstützung zu begreifen.
Scory
 

Postby Gitarremann » 07. November 2007 00:32

Ui hier brennt ja die Luft. Also das mit dem port=0 funktioniert aber skip-networking geht nicht. Wenn das aber so ist, wie hier dargestellt, wirds doch sicher von offizieller Seite ein Fehlerbehebung bzw. einen entsprechenden Hinweis geben. Ich wäre zumindest erstmal dafür, das Problem ohne persönliche Beleidigungen zu lösen.
Gitarremann
 
Posts: 7
Joined: 05. November 2007 16:18

Postby Scory » 07. November 2007 11:22

Gitarremann wrote:Also das mit dem port=0 funktioniert aber skip-networking geht nicht.


Was verstehst Du unter "geht nicht"? Die "falsche Fehlermeldung" taucht immer auf, weil das check-Script fehlerhaft ist - das ist aber kein provibitiver Grund. Diese Script sind uralt und offensichtlich unsauber angepasst worden.

Wichtiger ist doch, ob der MySQL Server wirklich via Netzwerk erreichbar ist (über Port 3306 meistens) oder nicht. Hast Du das getestet, konkret, mit Login usw.?

Last not Least verstehe ich die Panik sowieso nicht, was sollte "unsicher" daran sein, dass der Port 3306 zur Verfügung steht? Wenn von außen keiner einen gültigen MySQL User Access hat (inkl. Passwort), kommt auch keiner in die Datenbank hinein. Wobei der vorgenannte MySQL User sogar autorisiert sein muss, von externen Servern zugreifen zu dürfen. Es würde schon genügen (was die meisten auch so tun), in MySQL alle User nur für "localhost" freizugeben.

Dieses "./lampp security" ist NUR ein Shellscript für Dinge, die man auch mit dem Editor von Hand erledigen kann (in diesem Fall die entsprechenden Einträge in der my.cnf). Das fehlerhafte Scipt analysiert NICHT, ob und wie MySQL läuft, sondern analysiert selbst NUR die Datei my.cnf (und das eben auch noch ungenau).

So, noch besser kann ich es nicht erklären, ich kann jedem nur raten, schaut doch selbst in die Scripte hinein, das ist ganz normaler Shell Syntax.

Grüße
Scory
Scory
 

Postby Gitarremann » 07. November 2007 12:47

Ja das weiß man aber doch als User nicht, ob etwas unsicher ist oder ob unsicher nur da steht, weil ne falsche Fehlermeldung kommt. Vor allem weil man nicht weiß, was in dieser my.cnf nun drin stehen muß. Ich hab nun schon mehrere varianten gefunden

skip-network
skip-networking
skip_network
skip_networking

und dazu immer unterschiedlich erklärt, ob mit diesem Eintrag nun der Zugriff von außen ermöglicht wird oder unterbunden wird. Also völlig unabhängig davon, ob es nun überhaupt wahrscheinlich ist, dass sich da jetzt jemand einen Zugang verschaffen kann.
Gitarremann
 
Posts: 7
Joined: 05. November 2007 16:18

Postby Scory » 07. November 2007 14:09

Gitarremann wrote:Ja das weiß man aber doch als User nicht, ob etwas unsicher ist oder ob unsicher nur da steht, weil ne falsche Fehlermeldung kommt.


Wieso "weiß man" das nicht? Du mußt doch selbst ein Gefühl dafür haben, was daran so "unsicher" ist. Sicherlich ist es der Vorschlaghammer in Sachen Sicherheit, wenn mysqld erst gar nicht zu erreichen ist. Aber ob das so notwendig ist, muss jeder für sich entscheiden - da gibt es kein allgemeines "richtig" und "falsch".

Gitarremann wrote:Vor allem weil man nicht weiß, was in dieser my.cnf nun drin stehen muß. Ich hab nun schon mehrere varianten gefunden

skip-network
skip-networking
skip_network
skip_networking


Wieso schaust Du nicht an die einzige verbindlich richtige Stelle, nämlich die MySQL-Dokumentation? Dafür gibt es sie doch - siehe http://dev.mysql.com/doc/refman/5.1/de/ ... tions.html

Dort steht --skip-networking als Zeilenoption für mysqld. Dann heißt die Option skip-networking (ohne die beiden Striche), wenn man sie nicht auf der Kommandozeile angibt (was auch möglich wäre), sondern in my.cnf. Auch das ist beschrieben in der Doku.

Gitarremann wrote:und dazu immer unterschiedlich erklärt, ob mit diesem Eintrag nun der Zugriff von außen ermöglicht wird oder unterbunden wird. Also völlig unabhängig davon, ob es nun überhaupt wahrscheinlich ist, dass sich da jetzt jemand einen Zugang verschaffen kann.


Und wieder empfiehlt sich die einzig verbindlich richtige Stelle - s.o., die Originaldoku. Und die schreibt:

Unterbindet das Horchen auf TCP/IP-Verbindungen ganz. ...


Das ist doch mal ein klares Wort, oder nicht? Also, nochmal zum mitschreiben: wenn die Option skip-networking aktiviert ist, wobei wir jetzt wissen, dass das nicht nur in my.cnf geht (am bestem schaust mal in die Doku, wo man sonst noch Optionen angeben kann - gibt nämlich noch mehr Möglichkeiten!), dann wird nichts über die TCP/IP-Verbindung übertragen, niemand "horcht" auf irgendeinem Port - absolute Funkstille!

Grüße
Scory

P.S.: Ich bin auch "nur" Anwender, aber ich habe keine Angst vor Dokumentation. Ich habe auch jetzt gerade erst (extra für Dich!) die genaue Doku gelesen. Das muss man eben manchmal, wenn man etwas genau wissen will.
Scory
 

Next

Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 1 guest