MySQL geht nicht auf der Shell

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

MySQL geht nicht auf der Shell

Postby Schnuckel » 02. October 2003 21:31

Hi.

Hab Lampp auf Debian3 woody installiert. Läuft (fast) alles wunderbar.
Mysql ist sowohl über php als auch phpMyAdmin zu erreichen, will ich aber auf der Shell z.b. /opt/lampp/bin/mysqladmin benutzen kommt folgende Meldung:
error: 'Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)'
Check that mysqld is running and that the socket: '/tmp/mysql.sock' exists!


In my.cnf ist die richtige socket (/opt/lampp/...) eingetragen, trotzdem geht da was nicht. Bevor ich lampp installiert habe hat mir ein befreundeter linux-pro den ganzen alten müll restlos entfernt damit keine probleme auftreten. Kann da evtl. noch irgendwas vorhanden sein was einen konflikt verursacht oder so?

ciao,
schnuck
User avatar
Schnuckel
 
Posts: 35
Joined: 02. October 2003 21:22
Location: Bayern

Postby Oswald » 02. October 2003 23:57

Hi Schnukel!

Bist Du Dir sicher, dass Du wirklich /opt/lampp/bin/mysqladmin aufgerufen hast? Ruf den Befehl bitte genau so noch mal auf! Am besten mit Copy & Paste.. ;)

Wenn es wirklich nicht geht: Welche Version von LAMPP benutzt Du?

Liebe Grüße,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Schnuckel » 03. October 2003 09:01

Hmm,
sowas nennt man wohl den 'Vorführ-Effekt' :?
Habs eben nochmal probiert und es klappte. Ich schwöre, gestern genau das selbe getan zu haben. Gut, dazwischen liegt ein server-reboot, den gabs aber vorsichtshalber auch gleich nach der installation von lampp 1.2 und da ging das mit dem sql server nicht. Naja anyway, nun scheint es ja richtig zu laufen.
Auch wenn es nicht in diesen Thread passt hätte ich noch eine weitere frage. Hab die unten genannten parameter in die my.cnf im abschnitt [mysqld] eingetragen um etwas performance rauszuholen. Dann startet der mysqlserver aber nicht mehr. Ist die konfig etwa so nicht richtig oder die parameter an der falschen stelle?

[mysqld]
...
set-variable = query_cache_limit=1M
set-variable = query_cache_min_res_unit=4K
set-variable = query_cache_type=1
User avatar
Schnuckel
 
Posts: 35
Joined: 02. October 2003 21:22
Location: Bayern

Postby Oswald » 03. October 2003 11:26

Bitte schön!

Zu Deiner zweiten Anfrage: Eigentlich sollte in der Logdatei vom MySQL auch ein entsprechender Hinweis auftauchen: query_cache_min_res_unit ist meines Erachtens nur für MySQL > 4.1. Das ist eine Alpha-Version von MySQL, die im XAMPP nicht eingesetzt wird. Wir schwören noch auf 4.0.x, die zur Zeit aktuelle stabile Version.

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Schnuckel » 03. October 2003 15:49

Vielen Dank!

Hab query_cache_min_res_unit rausgenommen und schon rennt das ding:
Und hat sogar gute speed gebracht bei immer gleichen querys.

Thanx bye
User avatar
Schnuckel
 
Posts: 35
Joined: 02. October 2003 21:22
Location: Bayern


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 2 guests