Problem mit auth_typ http bei phpMyAdmin 2.5.4-rc1

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

Problem mit auth_typ http bei phpMyAdmin 2.5.4-rc1

Postby Arestris » 02. October 2003 05:04

Hallo!

Ich habe ein kleineres Problem mit mysql, genauer mit phpMyAdmin! Und zwar wollte ich, wie auf dem FAQ auf dieser Seite angegeben, den auth_typ von phpMyAdmin auf http umschalten, damit der Server auch sicher ist, wenn jemand von außen zugreift!

rootpasswort habe ich gesetzt über c:\>mysqladmin -u root password meinpass halt wie beschrieben und über auth_typ config in der config.inc.php (User: root und als Passwort: meinpass) geht das auch wunderbar, ich kann ohne Probleme auf phpMyAdmin zugreifen!

Stell ich nun aber den auth_typ um auf http werde ich beim aufrufen von phpMyAdmin korrekterweise nach Username und Passwort gefragt und genau da endet mein Versuch auch schon... ich habe es 100fach probiert, Username und passwort ein zu geben, sogar von verschiedenen Usern, die ich in MySQL angelegt hab oder root ohne vergebenes passwort, es tut sich nichts ich kann nur abbrechen und erhalte dann natürlich keinen Zugriff! Heisst: will ich was in phpMyAdmin machen muss ich im config-file erst wieder auf auth_typ config stellen!

Damit man vieleicht besser was sagen kann, mal kurz etwas über mein System:

amd Athlon xp 2000+ (wohl nebensächlich, aber der vollständigkeithalber mal genannt)
Windows XP Professional
Apache 2 Server, läuft als Systemdienst
MySQL 4.0.15-win, läuft als Systemdienst
PHP 4.3.3, in apache über die php.exe eingebunden und läuft ohne Probleme
phpMyAdmin 2.5.4-rc1, läuft bis auf genannten Fehler auch ohne Probleme!
Der Rechner geht übers Netzwerk per DSL ins Internet (der mit dem DSL direkt verbundene Rechner hat 2 Netzwerkkarten und leitet das Inet per InternetConnectionSharing von Windows XP an mich weiter, die Ports für http, https und so weiter sind alle an meinen Rechner forwardet)
Interne IP von meinem Rechner: 192.168.0.2 die vom Server (eigentlich Familienrechner, der halt inet an meinen weitergibt, aber der einfachheit habler mal so genannt) 192.168.0.1

Die Internetverbindung hat eine dynamische IP unter Servername in der http.conf steht localhost:80 und Hostname ist auch localhost ist vom netzwerk aus nur über die interne ip/localhost ansprechbar (eben wegen dem Routing), von aussen aber auch über no-ip-adresse oder externer ip!

Hier noch ein ausschnitt aus meiner config.inc.php:

Code: Select all
$i++;
$cfg['Servers'][$i]['host']          = 'localhost'; // MySQL hostname or IP address
$cfg['Servers'][$i]['port']          = '';          // MySQL port - leave blank for default port
$cfg['Servers'][$i]['socket']        = '';          // Path to the socket - leave blank for default socket
$cfg['Servers'][$i]['connect_type']  = 'tcp';       // How to connect to MySQL server ('tcp' or 'socket')
$cfg['Servers'][$i]['compress']      = FALSE;       // Use compressed protocol for the MySQL connection
                                                    // (requires PHP >= 4.3.0)
$cfg['Servers'][$i]['controluser']   = '';          // MySQL control user settings
                                                    // (this user must have read-only
$cfg['Servers'][$i]['controlpass']   = '';          // access to the "mysql/user"
                                                    // and "mysql/db" tables)
$cfg['Servers'][$i]['auth_type']     = 'http';    // Authentication method (config, http or cookie based)?
$cfg['Servers'][$i]['user']          = 'root';      // MySQL user
$cfg['Servers'][$i]['password']      = 'meinpass';  // MySQL password (only needed
                                                    // with 'config' auth_type)


auch hab ich irgendwo gelesen das der PmaAbsoluteUri Eintrag was damit zu tun haben könnte (aber hab da echt keine Ahnung) darum der auch mal hier, der Vollständigkeit halber:
Code: Select all
$cfg['PmaAbsoluteUri'] = 'http://localhost/phpMyAdmin/';


Für jegliche Hilfe im Vorraus dankend

Arestris
Arestris
 

Zusätzliche Info:

Postby Arestris » 02. October 2003 05:07

Noch eine Info: Ansonsten laufen PHP als auch mysql absolut Fehlerlos! Ich habe als neue Datenbank angelegt und da ein phpBB2-Bord installiert, welches ohne Probleme läuft! Ich kann da also Beiträge erstellen, etc... wollt das nur mal als Zusatzinfo hinterherschicken.
Arestris
 


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 3 guests