Frage zur Kompatibilität Mysql/php 5 und 4

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

Frage zur Kompatibilität Mysql/php 5 und 4

Postby lena_x » 28. August 2007 14:04

Hallo!

Bitte, ich bräuchte zur Sicherheit eine Information, ich habe die Suchfunktion benutzt und auch Beiträge zu dem Thema gefunden, aber keine wirklich klare und beruhigende Information...
Ich bin Anfängerin und verstehe davon noch sehr wenig.

Auf meinem Computer ist die neueste Version von xampp installiert, also mit # MySQL 5.0.45 und # PHP 5.2.3.
Ich entwickele nun hier lokal mit Hilfe von dreamweaver und sehr basalen php-Kenntnissen eine kleines Mini-CMS. Auf dem Server, auf dem das einmal laufen soll, läuft nun aber php 4 und MySql 4. Der nette Herr am Telefon sagte, solange ich keinen speziellen php5-code verwenden würde, und das würde ich sicherlich nicht, wenn ich nicht Spezialanwendungen wie für die Deutsche Bank oder das Pentagon oder so ähnlich programmieren würde, würde es da keinerlei Kompatibilitätsprobleme geben, und alles, was ich hier lokal entwickele, läuft dann dort auch ohne Probleme.
Notfalls könne man mir auch einen Server mit php5 geben, aber was die Datenbanken betrifft sind sie wohl alle Version 4.
Stimmt denn das mit der problemlosen Kompatibilität von php 4 und 5 und auch MySql 4 und 5 wirklich?
Und kann ich die Tabellen wirklich via dump dorthin exportieren, auch wenn die MySql-Versionen nicht übereinstimmen? Ich weiß, es gibt die Kompatibilitätsfunktion, aber funktioniert das wirklich?

Vielen Dank, viele Grüße

lena
lena_x
 
Posts: 1
Joined: 28. August 2007 12:51

Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 3 guests