MySQL tut nicht

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

MySQL tut nicht

Postby rami » 11. July 2007 17:13

Ich habe vor einiger Zeit XAMPP installiert.
PHP funktioniert
FileZilla funtioniert
Mail funktioniert
MySQL - FUNKTIONIERT NICHT!
Ich weiß überhauptnicht was ich machen soll. ich habe nix. in phpmyadmin komm ich nicht rein. ich glaube, weil es dafür keine userdatenbank gibt. muss ich phpmyadmin extra installieren? wie lege ich die erste datenbank an?
rami
 
Posts: 13
Joined: 08. March 2007 12:25

Postby WeissA » 11. July 2007 20:50

Hallo,

zu phpmysql: das musst Du nicht extra installieren, ist bei Xampp dabei.

zu mysql: müsste eigentlich im Ordner Xampp vorhanden sein. Schau mal nach, welche Ordner es da gibt.
WeissA
 
Posts: 18
Joined: 17. June 2007 10:36

Postby rami » 12. July 2007 06:41

da gibts auch mysql, es ist alles vorhanden.
ich kannn mich nur nich in phpMyAdmin einloggen.
rami
 
Posts: 13
Joined: 08. March 2007 12:25

Postby WeissA » 12. July 2007 09:06

beschreib mal ein bißchen näher.
z.B. wenn Du die Myphpadmin-Oberfläche geöffnet hast auf 'Demos' gehst, geht die CD-Verwaltung?
Was sagt die Status-Anzeige- MYSQL aktiviert oder deaktiviert?
WeissA
 
Posts: 18
Joined: 17. June 2007 10:36

Postby rami » 12. July 2007 14:52

das xampp-control-panel sagt:

[x] Svc MySQL Runing [stop] [admin]

die ample unten rechts zeigt grün.

die cd-demo tut nicht, aber ich habe auch im security-panel (localhost/security) das Passwort für root geändert. Doch auch mit dem neuen PW komm ich nicht in phpMyAdmin.
rami
 
Posts: 13
Joined: 08. March 2007 12:25

Postby Hanspeter Thöni » 12. July 2007 15:52

Wurde beachtet, dass wenn man in der Konfiguration von phpmyadmin etwas anpassen muss, wenn man in der mysql das passwort ändert?

siehe hier:
http://faq.kwm-web.info/doku.php/phpmyadmin
Gruss Hanspeter
User avatar
Hanspeter Thöni
 
Posts: 233
Joined: 17. August 2004 10:29
Location: Schweiz

Postby rami » 12. July 2007 15:58

ja
rami
 
Posts: 13
Joined: 08. March 2007 12:25

Postby WeissA » 12. July 2007 17:27

nochmal: wenn Du in der Xampp-Oberfläche bist, dann ist doch links ein oranger Streifen auf dem steht: XAMPP
[PHP: 5.2.2]


Willkommen
Status
Sicherheitscheck
Dokumentation
Komponenten
phpinfo()

wenn Du jetzt bei Status draufklickst, dann müsste dort mysql "ativiert" sein.
Wenn nicht, hast Du schlechte Karten. Wenn ja, dann musst du die Zugangsdaten für mysql richtig eingeben.
Aber schau zuerst mal, ob bei "Status" mysql aktiviert ist.
WeissA
 
Posts: 18
Joined: 17. June 2007 10:36

Postby rami » 12. July 2007 17:46

is:
MySQL-Datenbank AKTIVIERT
rami
 
Posts: 13
Joined: 08. March 2007 12:25

Postby kampfgnom » 12. July 2007 18:13

Ich hab ein ähnliches Prb, Mysql läuft laut Controll pannel, aber im Status steht deaktiviert.

Und der PHPmyadmin spuckt folgendes aus:
Code: Select all
phpMyAdmin - Fehler

Die Erweiterung mysql kann nicht geladen werden. Bitte überprüfen Sie Ihre PHP-Konfiguration. - Dokumentation
kampfgnom
 
Posts: 6
Joined: 02. March 2007 21:49

Postby WeissA » 12. July 2007 18:27

an rami
was passiert denn genau , wenn Du bei Tools phpmyadmin anklickst?
Welche Fehlermeldung?
Welche Fehlermeldung bekommst Du, wenn du bei CD-Verwaltung draufklickst?
WeissA
 
Posts: 18
Joined: 17. June 2007 10:36

Postby rami » 12. July 2007 18:31

Bei CD-Verwaltung:
Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'root'@'localhost' (using password: NO) in D:\Programme\xampp\htdocs\xampp\cds.php on line 64
Kann die Datenbank nicht erreichen!
Läuft MySQL oder wurde das Passwort geändert?


Wenn ich bei phpMyAdmin root und [meinpasswort] eingegeben habe (dies steht auch in der config.inc.php) kommt:
Fehler
Die Anmeldung am MySQL-Server ist fehlgeschlagen.
rami
 
Posts: 13
Joined: 08. March 2007 12:25

Postby WeissA » 12. July 2007 18:54

für cd- verwaltung öffne die datei cds.php im Verzeichnis xampp\htdocs\xampp und öffne mit Wordpad.
Dann gehe mal auf suchen und gebe root ein. wahrscheinlich beim 2. Wort das gefunden wir kommt folgender Befehl:

if(!mysql_connect("localhost","root","PASSWORT"))
{
echo "<h2>".$TEXT['cds-error']."</h2>";
die();
}
mysql_select_db("cdcol");

Dort gebe mal dein Passwort ein, wo jetzt PASSWORT steht und im original so " " aussehen sollte ein, speicher und probier mal, ob Du jetzt auf deine "CDs" zugreifen kannst.
Der Rest später, wenn das oben funktioniert.
WeissA
 
Posts: 18
Joined: 17. June 2007 10:36

Postby rami » 12. July 2007 19:01

ändert sich nix

(außerdem, die datenbank mysql_select_db("cdcol"); existiert doch nicht, oder?)
rami
 
Posts: 13
Joined: 08. March 2007 12:25

Postby WeissA » 12. July 2007 19:08

die datenbank cdcol wird oder wurde bei mir zumindest automatisch mit Xampp installiert. Kannst ja mal nachschauen unter : xampp\mysql\data dort sollte eigentlich die cdcol sein.
Wenn nicht, was hast du denn für ein Betriebssystem, welches Xampp etc.?

Du solltest mal in Deiner config.inc. php die richtigen Einstellungen vornehmen, damit Du auf deine SQLDatenbank zugreifen kannst.
Hattest Du überhaupt schon mal Zugriff ?
WeissA
 
Posts: 18
Joined: 17. June 2007 10:36

Next

Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 1 guest