phpmyadmin Anmeldung

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

phpmyadmin Anmeldung

Postby mammut » 24. June 2007 13:32

Hi zusammen,
Vielleicht kann mir jemand hier helfen.

Ich habe einen Apache aufgesetzt und dazu mysql. betriebssytem ist ubuntu 7.04 minimal.
Damit ich über Browser den mysql administrieren kann, habe ich phpmyadmin installiert.
Die Anmeldemaske kommt problemlos.
Wenn ich mich jetzt über phpmyadmin mit "root" einloggen will dann funktioniert das nur manchmal. (Versuch immer mit dem selben Passwort. Vertipper sind ausgeschlossen ;-) )
Meistens funktioniert es nicht.
Falls ich mich mal anmelden konnte, schmeißt mich phpmyadmin nach ein paar Klicks gleich wieder raus.
Auf dem Server lokal kann ich mich problemlos anmelden und tabellen anschauen und verändern wie ich will. Lokal kann ich aber nur die mysql-Konsole verwenden.
In den log-Files finde ich nichts, was mir hier helfen könnte.
Wenn ich abgeleht werde, meldet das log nur, dass "root@localhost" nicht dürfte. Aber warum funktioniert es dann manchmal?

Hoffentlich kann mir hier jemand helfen.
mammut
 
Posts: 6
Joined: 24. June 2007 13:20
Location: Oberkochen

Postby kschroeder » 24. June 2007 20:00

Für mich klingt das irgendwie nach nem Session-Problem. Du kannst ja mal zwischen den Anmeldemethoden wechseln, die Dir phpmyadmin über die config.inc.php bietet. Vielleicht klappt ja schonmal eine der anderen Methoden?
kschroeder
 
Posts: 254
Joined: 11. May 2007 13:33

Postby mammut » 25. June 2007 07:44

Ist ja klasse. Mit AUTH_TYPE=http funktioniert das ganze problemlos.
Ist nur nicht so schön. Mit cookie wäre es eigentlich besser. Ich habe noch andere Server, bei denen das problemlos mit cookie klappt. Warum hier nicht. Fehlt vielleicht irgendein Paket für den Apache, dass die Cookieverwaltung löst?
mammut
 
Posts: 6
Joined: 24. June 2007 13:20
Location: Oberkochen

Postby kschroeder » 25. June 2007 09:02

Na das schränkt doch das Problem ganz schön ein :wink:
Jetzt tippe ich auf einen Konfigurationseintrag, der die cookies zu schnell sterben lässt?
kschroeder
 
Posts: 254
Joined: 11. May 2007 13:33

Postby mammut » 26. June 2007 20:59

Wenn ich jetzt nur wüsste, ob ich auf dem Client oder auf dem Server suchen muss. Auf einem anderen Server von mir klappt das mit den Cookies problemlos. Also kann es nicht der Client sein.
Wo kann ich nach so einem Eintrag suchen? Da bin ich noch ganz blank.
mammut
 
Posts: 6
Joined: 24. June 2007 13:20
Location: Oberkochen

Postby kschroeder » 27. June 2007 05:49

Da bin ich leider selber nicht wirklich so fit. Da bei mir das meiste auf anhieb geklappt hat, musste ich nicht groß schauen. :oops:

Aber ich würd mal die gängigen Konfigurationsdateien durchgehen, also php.ini und Apache-Konfig(s).

Schau doch auch mal, ob's nicht auch in den Logs vom Apache und php Hinweise gibt.
kschroeder
 
Posts: 254
Joined: 11. May 2007 13:33

Postby mammut » 27. June 2007 11:14

Es gibt in der php.ini Informationen über die Session-Lifetime.
Die ist für die Cookies
session.cookie_lifetime
auf 0 für die Lifetime, solange bis der Browser geschlossen wird.
Ansonsten finde ich nichts über einen Ablauf von cookies.
Auch die Logs von Apache und php zeigen mir nichts an. Wenigstens finde ich nichts ungewöhnliches.
mammut
 
Posts: 6
Joined: 24. June 2007 13:20
Location: Oberkochen


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 3 guests