Where is the command line interface for mysql?

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

Where is the command line interface for mysql?

Postby zak » 30. May 2007 21:09

I cannot get this to work. I have ran every file in the bin from the command line and the only one that works is the mysqladmin which asks me to enter a password. Some other .exe's give me a blank interface and other flash up for a nano second and then dissapear (handy) :twisted:

I am learning the mysql query language and need the command line interface to do this. I do not want a GUI as I am a student and need to learn with the commamd line interface.

Everything is running and I have set the port for msql.

First can someone tell me which .exe it should be and second why it wont run?

I am running vista business, dell xps, administer user account control is off and staying off---forever :x
zak
 
Posts: 5
Joined: 30. May 2007 20:54

Postby ManUnix » 30. May 2007 23:31

Hi zak,

open the Windows command-line ("cmd") and then you can use "xampp/mysql/bin/mysql.exe".
User avatar
ManUnix
 
Posts: 113
Joined: 16. April 2006 15:14

Postby zak » 31. May 2007 00:41

Thanks for your swift reply,

The problem is that when I run the line you say I get a blank command line interface appear with a flashing curser, but I can't type anything into it??

Any suggestions appreciated,

Thanks

Zak
zak
 
Posts: 5
Joined: 30. May 2007 20:54

Postby zak » 31. May 2007 12:42

Come to think of it, if I install mysql from the official site and not from xampp then the same thing happens.

The only way I can access a usable command line with the official site version is if I use the shortcut provided in the start-programs-mysql menu.

But xampp does not give the shortcut?

I think I must be doing something fundementally wrong then,

Any experts willing to help,

Thanks all,

Zak
zak
 
Posts: 5
Joined: 30. May 2007 20:54

Postby Wiedmann » 31. May 2007 14:06

I think I must be doing something fundementally wrong then,

What are you doing exactly?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby zak » 31. May 2007 14:59

I have installed xampp on vista business and all installed fine, I added a port in windows firewall for port 3306 for mysql.

Then i go to the cmd line and run

"C: xampp/mysql/bin/mysql.exe".

All I get is a blank command interface with a flashing curser. I cannot type anything into it.

The other thing I was doing before I installed xampp on my laptop with vista business was on another computer that runs xp pro.

Here I installed the MySql Windows Essentials (x86) 5.0.41 installer.

again all installed fine

Then i go to the cmd line and run

"C: xampp/mysql/bin/mysql.exe".

All I get is a blank command interface with a flashing curser. I cannot type anything into it.

On this occasion though there is a shortcut to the command line interface in the start menu under programs>MySql>ect

and this shortcut works.

But in xampp there is no shortcut so I cannot get mysql command line to run, only the blank screen with the flashing curser.

The reason I am using xampp on the vista machine is because I have had great problems configuring php in IIS 7.0 and trying to configure apache with php.

So Xampp works fine except for the mysql command line.

Thanks for you help and your replys, and hope thats a bit more clearer

Zak
zak
 
Posts: 5
Joined: 30. May 2007 20:54

Postby Wiedmann » 31. May 2007 15:11

Then i go to the cmd line and run
"C: xampp/mysql/bin/mysql.exe".

a) there is a slash missing
b) the Windows shell want have backslashs:
Code: Select all
C:\xampp\mysql\bin\mysql.exe


Second, according to the MySQL-manual [1], you should provide your login informations as parameter to the tool:
Code: Select all
C:\xampp\mysql\bin\mysql.exe --user=user_name --password=your_password


[1] http://dev.mysql.com/doc/refman/5.0/en/mysql.html
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby zak » 01. June 2007 22:35

Hi Thanks for your reply, I worked it out with your help,

I had been using the right backlash but not the right users and password

I used...

C:\xampp\mysql\bin\mysql.exe -u root -p

This worked and then hit enter at enter password prompt,

Thanks :P

I had also messed around with skip-grant-table...not sure if that did anything aswell

Thanks again
zak
 
Posts: 5
Joined: 30. May 2007 20:54


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 1 guest