#1064 Error - Konflikt zwischen zwei Datenbank versionen?

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

#1064 Error - Konflikt zwischen zwei Datenbank versionen?

Postby pRe » 10. February 2007 08:07

Hallo
Ich habe ein Problem. Ich habe ein PHP Script mit MySQL Datenbank auf Server A liegen. Da ich mit dem Script inkl. DB auf Server B umziehen möchte, wollte ich die DB auf Server B installieren. Dabei bekomme ich folgende Fehlermeldung:
#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'INSERT INTO `mt_settings` (`startcredits`, `extrapunkte`, `extr

Der komplette Code lautet
Code: Select all
CREATE TABLE `mt_settings` (
`startcredits` decimal( 10, 0 ) NOT NULL default '0',
`extrapunkte` decimal( 10, 0 ) NOT NULL default '0',
`extramin` decimal( 10, 0 ) NOT NULL default '0',
`extraverguetung` decimal( 10, 0 ) NOT NULL default '0',
`popupverguetung` decimal( 10, 0 ) NOT NULL default '0',
`maxpopups` decimal( 10, 0 ) NOT NULL default '0',
`maxverschicken` decimal( 10, 0 ) NOT NULL default '0',
`refbonus` decimal( 10, 0 ) NOT NULL default '0',
`maxmails` decimal( 10, 0 ) NOT NULL default '0',
`maxurlaub` decimal( 10, 0 ) NOT NULL default '0',
`mailsmin` decimal( 10, 0 ) NOT NULL default '0',
`mailsbuchen` decimal( 10, 0 ) NOT NULL default '0',
`mailgueltig` decimal( 10, 0 ) NOT NULL default '0',
`doppel` tinyint( 1 ) NOT NULL default '0',
`doppelzeit` decimal( 20, 0 ) NOT NULL default '24',
`unbestaetigt` decimal( 10, 0 ) NOT NULL default '0',
`bannerbuchen` decimal( 10, 0 ) NOT NULL default '0',
`extrareload` decimal( 10, 0 ) NOT NULL default '0',
`inaktiv` decimal( 10, 0 ) NOT NULL default '0',
`inaktiv2` decimal( 10, 0 ) NOT NULL default '0',
`nichtaktiviert` varchar( 10 ) NOT NULL default '',
`startcreditsb` decimal( 10, 0 ) NOT NULL default '0',
`adminname` varchar( 255 ) NOT NULL default '',
`passwort` varchar( 255 ) NOT NULL default '',
`projekturl` varchar( 255 ) NOT NULL default '',
`adminmail` varchar( 255 ) NOT NULL default '',
`projektname` varchar( 255 ) NOT NULL default '',
`punktetransferg` decimal( 10, 0 ) NOT NULL default '0',
`punktetransferk` decimal( 10, 0 ) NOT NULL default '0',
`session` varchar( 255 ) default '',
`refpunkte1` decimal( 10, 2 ) NOT NULL default '0.00',
`refpunkte2` decimal( 10, 2 ) NOT NULL default '0.00',
`refpunkte3` decimal( 10, 2 ) NOT NULL default '0.00',
`refpunkte4` decimal( 10, 2 ) NOT NULL default '0.00',
`refpunkte5` decimal( 10, 2 ) NOT NULL default '0.00',
`refpunkte6` decimal( 10, 2 ) NOT NULL default '0.00',
`refpunkte7` decimal( 10, 2 ) NOT NULL default '0.00',
`refpunkte8` decimal( 10, 2 ) NOT NULL default '0.00',
`refpunkte9` decimal( 10, 2 ) NOT NULL default '0.00',
`refpunkte10` decimal( 10, 2 ) NOT NULL default '0.00',
`kurs` float NOT NULL default '0',
`money` varchar( 255 ) NOT NULL default '',
`auszahlsumme` int( 10 ) NOT NULL default '0' INSERT INTO `mt_settings` ( `startcredits` , `extrapunkte` , `extramin` , `extraverguetung` , `popupverguetung` , `maxpopups` , `maxverschicken` , `refbonus` , `maxmails` , `maxurlaub` , `mailsmin` , `mailsbuchen` , `mailgueltig` , `doppel` , `doppelzeit` , `unbestaetigt` , `bannerbuchen` , `extrareload` , `inaktiv` , `inaktiv2` , `nichtaktiviert` , `startcreditsb` , `adminname` , `passwort` , `projekturl` , `adminmail` , `projektname` , `punktetransferg` , `punktetransferk` , `session` , `refpunkte1` , `refpunkte2` , `refpunkte3` , `refpunkte4` , `refpunkte5` , `refpunkte6` , `refpunkte7` , `refpunkte8` , `refpunkte9` , `refpunkte10` , `kurs` , `money` , `auszahlsumme` )
VALUES ( 500, 2, 25, 1, 0, 5, 100000, 5, 30, 31, 10, 100, 10, 0, 24, 1, 50, 300, 14, 3, '5', 20, 'Admin', '25101989', 'http://www.paidmail-time.de', 'admin@paidmail-time.de', 'Paidmail-Time', 30, 100000, 'e6750d7662fde3bad95219a78e62ca80', 0.05, 0.03, 0.02, 0.01, 0.01, 0.01, 0.01, 0.01, 0.01, 0.01, 0.01, 'Euro', 75 )


Auf Server A ist MySQL - 4.1.11-Debian_4sarge7 installiert und auf Server B MySQL 4.0.27 . Kann das das Problem sein? Bzw. wie knn ich es lösen?

MfG
pRe
pRe
 
Posts: 2
Joined: 10. February 2007 07:53

Postby Wiedmann » 10. February 2007 14:18

Vor INSERT fehlt ein Semikolon.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby pRe » 11. February 2007 11:38

Danke. Dieses Problem wäre dann gelöst. Aber jetzt erhalte ich folgenden Fehler
#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 44
pRe
 
Posts: 2
Joined: 10. February 2007 07:53

Postby Wiedmann » 11. February 2007 16:42

Dieses Problem wäre dann gelöst.

Wie man es nimmt. Woher (von welchem Programm) kommt denn dieser "vermurxte" Dump?

mysqldump unterlaufen IMHO keine solche Fehler...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 1 guest