SQL error :(

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

SQL error :(

Postby HardySim » 27. August 2003 13:07

hey guggt mal.. ich ab heuet auf LAMPP 1.2 en update gemacht und promt bekomm ich in meinem phpbb en fehler:
SQL Error : 1064 You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ' forum_topics = forum_topics + 1 WHERE forum_id = 2' at line

UPDATE phpbb_forums SET forum_posts = forum_posts + 1, forum_last_post_id = , forum_topics = forum_topics + 1 WHERE forum_id = 2

Line : 481
File : /srv/www/htdocs/user/hardysim/phpBB2/includes/functions_post.php


any ideas?
[url=http://www.hardysim.de]
Image[/url]
www.party-safari.net
User avatar
HardySim
 
Posts: 325
Joined: 19. June 2003 10:22
Location: Geisenheim

Postby Oswald » 27. August 2003 15:20

Huhu Hardy!

Welche Version von phpBB benutzt Du? Ich würd's dann auch gleich mal bei mir ausprobieren.

Gruß,
Oswald

EDIT:
Hab's grad mit phpBB 2.0.6 ausprobiert und damit konnte ich bisher den Fehler nicht nachvollziehen. Was hast Du genau gemacht, als der Fehler bei Dir auftrat?
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby pir187 » 27. August 2003 20:28

UPDATE phpbb_forums SET forum_posts = forum_posts + 1, forum_last_post_id = , forum_topics = forum_topics + 1 WHERE forum_id = 2

tachchen,

fehlt da bei dem teil "forum_last_post_id= ," nicht der wert hinter dem "="??? -> das SET-statement ist doch unvollständig, oder ist das nur ein schreibfehler?
pir187
 
Posts: 76
Joined: 13. August 2003 00:15
Location: Struppen / Sachsen

Postby Oswald » 28. August 2003 00:19

Huhu pir!

Klar, da fehlt der Wert. Aber warum? Hardy sagt, dass ihm das nach dem Upgrade passiert ist und das macht mich natürlich ein bisschen nervös.

Es liegt definitiv nicht am MySQL sonder eher am PHP oder vielleicht auch am Apache.

Mal sehen was Hardy sagt, wann genau dieser Fehler auftritt.

Gute Nacht,
Oswald ;)
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby HardySim » 28. August 2003 08:52

jo, lag wohl an mir...


weiß zwar net warum, aber als ich des paket nochma neu installiert hab, gibns wieder wunderbar...

war wohl nur en zufall, also entwarnung :)
[url=http://www.hardysim.de]
Image[/url]
www.party-safari.net
User avatar
HardySim
 
Posts: 325
Joined: 19. June 2003 10:22
Location: Geisenheim

Ähnliches Problem oder was neues mit MiniXAMP 1.2?

Postby Kai Müller » 10. November 2003 20:22

Hallo zusammen,

bin absoluter Newbie was WAMP-Installationen angeht.

Habe gerade das MINIXAMP - Paket in Version 1.2 installiert. Alles hat wunderbar geklappt.

Wollte danach über PHPMYADMIN eine neue Datenbank anlegen, doch leider erscheint folgende Meldung?

* * * * *
SQL-Befehl :

CREATE DATABASE

MySQL meldet:


#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1

[Dokumentation] · [Zurück]

* * * * *

Habt Ihr eine Idee?

Danke für Eure Mühe.

Gruß,
Kai
Kai Müller
 

Ähnliches Problem oder was neues mit MiniXAMP 1.2?

Postby Kai Müller » 10. November 2003 20:24

Sorry.

Hab Win2000, SP 3 ... wobei das vermutlich nicht das Problem sein wird.

Gruß,
Kai
Kai Müller
 


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 1 guest