MySQL-Versionen ?? Kann meine Tabellen nicht portieren

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

MySQL-Versionen ?? Kann meine Tabellen nicht portieren

Postby Bramburi » 20. November 2006 23:41

Hallo

Bin derzeit etwas verunsichert bezügl. verschiedener MySQL-Versionen.
Auf meinen Desktop-Xamp(Version 1.5.4a auf XP-PRO vor ca. 1/2 Jahr installiert) zeigt mir die Startseite des phpMyAdmins(2.9.0.1) folgendes:

"Server Version: 5.0.24a-community" und daneben "MySQL-Client-Version: 3.23.49" die phpinfo zeigt auch "Client API version 3.23.49" an.

Ich habe nicht gewußt das es getrennte Bezeichnungen der Server- u. Clientversionen gibt.
Wäre interessant für darüber mehr zu erfahren wenn es so ist.

Auf meinen Testserver bei einem ISP der praktisch nie seine Installation auf dem aktuellsten Stand hat, zeigt die phpinfo eine "Client API version4.0.24 " Version für MySQL an.
Über eine Serverversion finde ich beim dortigen schon ziemlich angegrauten phpMyAdmin(2.2.4) nichts, auch nicht in der phpinfo.

Ich dachte in Xampp wird immer die jeweils neueste also eine der 5.x MySQL Versionen verwendet.
Aber wie es scheint dürfte (lt. phpinfo) doch eine ältere Version auf meinen Xampp vorhanden sein.

Ich weiß nicht ob das möglicherweise die Ursache meines Problems ist, dass ich derzeit habe.

Ich versuchte(mittels der phpMyAdmins) einige Tabellen von meinen Destop zu meinen Provider zu portieren und bekomme stets Fehlermeldungen ich die Dumps importieren will.

Oder was könnte sonst noch als Ursache in Frage kommen ?

Umgekehrt funktionierts einwandfrei.


Danke euch schon mal für eure Info

Bramburi
Bramburi
 
Posts: 13
Joined: 06. April 2004 01:19
Location: Wien

Postby Wiedmann » 21. November 2006 00:26

und bekomme stets Fehlermeldungen ich die Dumps importieren will.

Sollen wir raten?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby sari42 » 28. November 2006 18:37

für windows hilft eventuell:
"Why should I download the PHP mysql/mysqli extensions from mysql.com and not from php.net?"
http://dev.mysql.com/downloads/connector/php/

auch vagabundieren häufig veraltete libmysql(.dll) in directories, die weit vorn im suchpfad stehen und sich deshalb "vordrängeln".
sari42
 
Posts: 800
Joined: 27. November 2005 18:28


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 4 guests