Probleme mit Datenbank import

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

Probleme mit Datenbank import

Postby Tight18 » 28. September 2006 12:24

Hallo,

habe mir über Xampp eine Homepage mit einer Datenbank erstellt und möchte die Homepage jetzt auf ohost.de oder funpic.de hochladen.
Leider stoße ich hier auf ein Problem, da ich keine Datenbank selber anlegen kann und mir ein Name für die Datenbank vorgegeben wird! Beim Versuch, die Tabellen, welche ich durch ein Backup gesichert habe, einzufühgen, kommt folgende Fehlermeldung:

Code: Select all
     SQL-Befehl:

    -- phpMyAdmin SQL Dump
    -- version 2.8.1
    -- http://www.phpmyadmin.net
    --
    -- Host: localhost
    -- Erstellungszeit: 23. September 2006 um 13:40
    -- Server Version: 5.0.21
    -- PHP-Version: 5.1.4
    --
    -- Datenbank: `wordpress`
    --
    CREATE DATABASE `wordpress` DEFAULT CHARACTER SET latin1 COLLATE latin1_swedish_ci


und darunder steht folgendes in einem roten Kasten:

MySQL meldet: Dokumentation
#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARACTER SET latin1 COLLATE latin1_swedish_ci' at line


Zudem ist meine Datenbank 210 KB groß, was anscheinend wohl zu groß ist, stimmt das und kann mir hier jemand weiter helfen???

Danke schon mal
Tight18
 
Posts: 2
Joined: 28. September 2006 12:14

Postby Wiedmann » 28. September 2006 12:33

da ich keine Datenbank selber anlegen kann und mir ein Name für die Datenbank vorgegeben wird!
Code: Select all
CREATE DATABASE `wordpress`

Du darfst lokal keinen Export der DB "wordpress" machen, sondern du musst alle Tabllen der DB "wordpress" exportieren. Dann wird auch kein "CREATE DATABASE" in den Dump geschrieben.

You have an error in your SQL syntax ... near 'DEFAULT CHARACTER SET latin1 COLLATE latin1_swedish_ci'

Dein Hoster verwendet wohl eine alte MySQL Version. Du musst beim Export also angeben zu welcher Version der Dump kompatibel sein soll.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Tight18 » 28. September 2006 12:42

also, wenn ich die Tabellen exportiere (kann nicht sagen, ob ich es richtig gemacht habe, da ich nirgendwo was finde, wie ich einzelne Tabelen exportiere und importiere) und bei dem Hoster einfühge, kommt folgendes:

Möglicherweise haben Sie einen Bug im SQL-Parser entdeckt. Bitte überprüfen Sie Ihre Abfrage genaustens, insbesondere auf falsch gesetzte oder nicht geschlossene Anführungszeichen. Eine weitere Ursache könnte darin liegen, dass Sie versuchen eine Datei mit binären Daten, welche nicht von Anführungszeichen eingeschlossen sind, hochzuladen. Sie können alternativ versuchen Ihre Abfrage über das MySQL-Kommandozeileninterface zu senden. Die MySQL-Fehlerausgabe, falls vorhanden, kann Ihnen auch bei der Fehleranalyse helfen. Falls Sie weiterhin Probleme haben sollten oder der Parser dort versagt, wo die Kommandozeile erfolgreich ist, so reduzieren Sie bitte Ihre Abfrage auf den Befehl, welcher die Probleme verursacht, und senden Sie uns einen Bugreport mit den Datenausschnitt, den Sie weiter unten auf dieser Seite finden.:
----AUSSCHNITTSANFANG----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----AUSSCHNITTSENDE----
----BEGINN DER AUSGABE----

ERROR: C1 C2 LEN: 2 3 1276
STR: 

CVS: $Id: sqlparser.lib.php,v 2.36 2005/08/08 20:22:11 lem9 Exp $
MySQL: 4.0.23-Max-log
USR OS, AGENT, VER: Linux MOZILLA 5.0
PMA: 2.6.4-pl3
PHP VER,OS: 4.4.2 Linux
LANG: de-iso-8859-1
SQL: PK
Tight18
 
Posts: 2
Joined: 28. September 2006 12:14

Postby sari42 » 01. October 2006 12:15

im ersten post fehlt möglicherweise nur ";" em ende.

>>>
also, wenn ich die Tabellen exportiere (kann nicht sagen, ob ich es richtig gemacht habe, da ich nirgendwo was finde, wie ich einzelne Tabelen exportiere und importiere) und bei dem Hoster einfühge, kommt folgendes:
<<<

wenn man sich nicht mit mysqldump befreunden kann, kann man auch phpmyadmin benutzen.
sari42
 
Posts: 800
Joined: 27. November 2005 18:28


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 1 guest