Performance Probleme mit mysql 5

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

Performance Probleme mit mysql 5

Postby dyingPhoenix » 26. June 2006 09:35

Hallo,
ich hatte einen "alten" Linux Server mit XAMPP 1.4.15. Der war aber ziemlich lahm, deshalb hab ich gestern einen neuen Server mit SuSE 10 und XAMPP 1.5.3a aufgesetzt. Die Datenbank hab ich von dem alten zum neuen "gedumpt". Allerdings nutzt der mysqld Prozess jetzt ständig 40-50% der CPU und der neue Server ist noch weniger performant als der alte. :-(
Hat jemand eine Idee was das sein könnte? Auf dem alten Server hatte ich nie Problem mit der Performance vom mysqld.

Danke für eure Hilfe!
dyingPhoenix
 
Posts: 19
Joined: 21. December 2004 14:43

Postby dyingPhoenix » 26. June 2006 10:36

Hinzu kommt, dass sich mysql nicht mit ./lampp stopmysql
stoppen läßt. Der sagt zwar XAMPP: Stopping MySQL...
aber in der Prozessliste ist mysqld danach immernoch.
dyingPhoenix
 
Posts: 19
Joined: 21. December 2004 14:43

Postby LazyOne » 26. June 2006 11:51

kannst ja mal inhalft der my.cnf posten :)
LazyOne
 
Posts: 141
Joined: 12. May 2005 12:12
Location: München

Postby dyingPhoenix » 26. June 2006 12:18

Jetzt hab ich alles wieder auf meinem alten Server laufen. Da hab ich keine Probleme mit dem mysqld (Prozessorlast bei max 10%)
Auf dem alten Server läuft MySQL - 4.1.13 auf dem neuen MySQL - 5.0.21. Ich vermute, dass das damit was zu tun hat, kann das sein?
Vielleicht sollte ich noch erwähnen, dass der neue Server ein virtueller ist. Aber ich glaub nicht, das dass damit was zu tun haben kann, oder?

So das ist meine my.cnf. Ich hab nur table_cache auf 1024 geändert. Das hatte ich irgendwo gelesen. Ansonsten ist das die Standard my.cnf von XAMPP.

Danke für eure Hilfe!

# Example MySQL config file for medium systems.
#
# This is for a system with little memory (32M - 64M) where MySQL plays
# an important part, or systems up to 128M where MySQL is used together with
# other programs (such as a web server)
#
# You can copy this file to
# /etc/my.cnf to set global options,
# mysql-data-dir/my.cnf to set server-specific options (in this
# installation this directory is /opt/lampp/var/mysql) or
# ~/.my.cnf to set user-specific options.
#
# In this file, you can use all long options that a program supports.
# If you want to know which options a program supports, run the program
# with the "--help" option.

# The following options will be passed to all MySQL clients
[client]
#password = your_password
port = 3306
socket = /opt/lampp/var/mysql/mysql.sock

# Here follows entries for some specific programs

# The MySQL server
[mysqld]
# commented out by lampp security
#port = 3306
port = 0
socket = /opt/lampp/var/mysql/mysql.sock
skip-locking
key_buffer = 16M
max_allowed_packet = 1M
table_cache = 1024

sort_buffer_size = 512K
net_buffer_length = 8K
read_buffer_size = 256K
read_rnd_buffer_size = 512K
myisam_sort_buffer_size = 8M

# Don't listen on a TCP/IP port at all. This can be a security enhancement,
# if all processes that need to connect to mysqld run on the same host.
# All interaction with mysqld must be made via Unix sockets or named pipes.
# Note that using this option without enabling named pipes on Windows
# (via the "enable-named-pipe" option) will render mysqld useless!
#
#skip-networking

# Replication Master Server (default)
# binary logging is required for replication
# log-bin deactivated by default since XAMPP 1.4.11
#log-bin=mysql-bin

# required unique id between 1 and 2^32 - 1
# defaults to 1 if master-host is not set
# but will not function as a master if omitted
server-id = 1

# Replication Slave (comment out master section to use this)
#
# To configure this host as a replication slave, you can choose between
# two methods :
#
# 1) Use the CHANGE MASTER TO command (fully described in our manual) -
# the syntax is:
#
# CHANGE MASTER TO MASTER_HOST=<host>, MASTER_PORT=<port>,
# MASTER_USER=<user>, MASTER_PASSWORD=<password> ;
#
# where you replace <host>, <user>, <password> by quoted strings and
# <port> by the master's port number (3306 by default).
#
# Example:
#
# CHANGE MASTER TO MASTER_HOST='125.564.12.1', MASTER_PORT=3306,
# MASTER_USER='joe', MASTER_PASSWORD='secret';
#
# OR
#
# 2) Set the variables below. However, in case you choose this method, then
# start replication for the first time (even unsuccessfully, for example
# if you mistyped the password in master-password and the slave fails to
# connect), the slave will create a master.info file, and any later
# change in this file to the variables' values below will be ignored and
# overridden by the content of the master.info file, unless you shutdown
# the slave server, delete master.info and restart the slaver server.
# For that reason, you may want to leave the lines below untouched
# (commented) and instead use CHANGE MASTER TO (see above)
#
# required unique id between 2 and 2^32 - 1
# (and different from the master)
# defaults to 2 if master-host is set
# but will not function as a slave if omitted
#server-id = 2
#
# The replication master for this slave - required
#master-host = <hostname>
#
# The username the slave will use for authentication when connecting
# to the master - required
#master-user = <username>
#
# The password the slave will authenticate with when connecting to
# the master - required
#master-password = <password>
#
# The port the master is listening on.
# optional - defaults to 3306
#master-port = <port>
#
# binary logging - not required for slaves, but recommended
#log-bin=mysql-bin


# Point the following paths to different dedicated disks
#tmpdir = /tmp/
#log-update = /path-to-dedicated-directory/hostname

# Uncomment the following if you are using BDB tables
#bdb_cache_size = 4M
#bdb_max_lock = 10000

# Comment the following if you are using InnoDB tables
skip-innodb
innodb_data_home_dir = /opt/lampp/var/mysql/
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = /opt/lampp/var/mysql/
innodb_log_arch_dir = /opt/lampp/var/mysql/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
innodb_buffer_pool_size = 16M
innodb_additional_mem_pool_size = 2M
# Set .._log_file_size to 25 % of buffer pool size
innodb_log_file_size = 5M
innodb_log_buffer_size = 8M
innodb_flush_log_at_trx_commit = 1
innodb_lock_wait_timeout = 50

[mysqldump]
quick
max_allowed_packet = 16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[myisamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[mysqlhotcopy]
interactive-timeout
dyingPhoenix
 
Posts: 19
Joined: 21. December 2004 14:43

Postby dyingPhoenix » 26. June 2006 12:46

So, was mir gerade noch aufgefallen ist: Bei dem alten Server steht, wenn ich top eingebe bei Time vom mysqld mitlerweil ca. 30 Minuten. Bei dem alten Server stehen das höchstens mal 10 Sekunden.
dyingPhoenix
 
Posts: 19
Joined: 21. December 2004 14:43


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 2 guests