Datenbank erstellen geht nicht ( phpmyadmin; wordpress,Suse)

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

Datenbank erstellen geht nicht ( phpmyadmin; wordpress,Suse)

Postby DoctorJay » 13. June 2006 19:47

Hallo,


Datenbanken lerne ich erst im kommenden Semester, aber ich brauche doch eine Datenbank damit ich in mein wordpress Template die Zugangsdaten eingeben kann.

Ich fand ein tut wie man wordpress unter xampp windows anlegt, aber ich habe die Suse 10.1 und da passiert folgendes:


Mein bisheriger Versuch war in phpmyadmin auf meinem xampp zu starten und dann eine anzulegen. Hierfür fehlen mir aber die Berechtigungen.


Wie lege ich diese Datenbank nur an?

Was mache ich jetzt?

Danke vorab
DoctorJay
 
Posts: 17
Joined: 15. January 2006 13:37

Postby deepsurfer » 13. June 2006 21:08

Mein bisheriger Versuch war in phpmyadmin auf meinem xampp zu starten und dann eine anzulegen. Hierfür fehlen mir aber die Berechtigungen.


Wie lege ich diese Datenbank nur an?

Das klingt schonmal etwas merkwürdig.


Bitte erstmal folgendes bestätigen oder abchecken...

a) XAMPP nach Anleitung mittels so genannten ROOT rechten Installiert ?

b) XAMPP nach anleitung mit ROOT rechten gestartet ?

c) Verlief der Startvorgang des XAMPP ohne Fehlermeldung ?

d) Wenn du nun am selben Rechner wo der XAMPP läuft ein InternetBrowser öffnest
(dürfte bei dir der Konqueror sein)
und mittels Eingabe http://localhost im browser, so sollte dann der Willkommenscreen von XAMPP erscheinen.
Oder ein sehr weisse Seite mit dem Hinweis das der APACHE läuft.

Sollte die weisse seite erscheinen so dürfte der XAMPP nicht ohne Fehlermeldung gestartet sein siehe punkt c

e) Funktionieren alle DEMOscripte in dem XAMPP-Willkommenscreen ?

f) Im Willkommenscreen kann man den phpmyadmin aufrufen.
Und wenn die DEMOScripte funktionen (besonders die CD-Sammlung) dann sollte der phpmyadmin dir jetzt den MySQL-Server zeigen. !?!?

So.ooo, bitte zuerst diese Punkte von a bis f abchecken, und wenn dann alles soweit nachvollziehbar ist geht es dann hier weiter

Ausgehend davon das du kein Securtiy Script ausgeführt hast und der phpmyadmin in voller pracht vor dir aufgebaut ist kommen wir in den bereich zum erstellen einer DB für den WordPress.

Hier nun ein kleines Flash-Video-Tutorial, was in seiner art und weise genau zeigt wie man eine DB und einen dazu gehörigen User einrichtet.
Bedenke das dieses Flash-Video mit einer etwas älteren phpmyadmin Version gemacht wurde. (ich mach nicht ständig neue Flash-VideoTuts).
Aber was auschlaggebend ist, ist das die Funktionen die man im Video sieht auch in der Aktuellen phpmyadmin Version wieder findet.
Also bitte etwas Querdenken und nicht gleich sagen "sieht ja anders aus, find ich nicht"......

Das Video hat unten eine Playleiste, damit kannst du auch zurück gehen und mit ruhiger Hand sogar selber Passagen anschauen.
>>> Hier das Flash-Video <<<

Ausgehend von den Daten (also dem was du als Namen und Passwörter benutzt muss das in die WordPress-config datei eingetragen werden.

Ein kurze Anleitung wie das geht liefert das Wordpress auch schon.
http://wordpress.de/installation

Jetzt sollte es dir möglich sein mit Wordpress zu arbeiten.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby DoctorJay » 13. June 2006 23:36

security script habe ich ausgeführt


Abarbeiten der Liste:

a) denke schon , sonst hätte ich doch gar nix installieren können oder
b)ja denke ich auch ich musste immer su werden
c)ja
d)ja zwar im firefox aber der willkommensscreen erschien
e)flash und mysql läuft nicht , er kann die Datenbank nicht erreichen und will wissen ob ein passwort geändert wurde.
f)phpmyadmin kann ich starten. dann will er ein passwort das ich eingebe, dann zeigt er mir eine übersicht mit mysql und php
und da ist auch mein geliebtes rotes Kreuz bei "neue Datenbank erstellen"

Was machen wir jetzt?



Achso und deine Hilfe war sehr ausführlich und informativ- Danke
DoctorJay
 
Posts: 17
Joined: 15. January 2006 13:37

Postby deepsurfer » 14. June 2006 00:27

security script habe ich ausgeführt

ok...


Abarbeiten der Liste:

> a) denke schon , sonst hätte ich doch gar nix installieren können oder
Doch hättest du auch, aber es würden fehler erscheinen.

> b)ja denke ich auch ich musste immer su werden
hhhmmm klingt für mich das du den XAMPP mit einem doppelklick im Konqueror starte willst und nicht wie nach Anleitung in einem so genanntem Terminafenster. (aber erstmal weiter in der liste)

> c)ja
Ok.. belassen wir das mal so ;) Da damit meine vorherige Vermutung abgehakt ist.

> d)ja zwar im firefox aber der willkommensscreen erschien
ok..hauptsache ein InternetBrowser, soweit schon in Ordnung.

> e)flash und mysql läuft nicht , er kann die Datenbank nicht erreichen
> und will wissen ob ein passwort geändert wurde.
Hier treten zwei Dinge auf ..

1)
Der MySQL fehler beruht darauf das du schon das Security Script benutzt hast und Passworter vergeben.
Eben dieses Passwort kennt das DEMOscript jetzt nicht.
Lösung ==> editiere die /opt/lampp/htdocs/xampp/ cds.php
In zeile 4 steht das hier
mysql_connect("localhost","root","");
zwischen den letzten beiden "" muss das MySQL Passwort eingetragen werden. Abspeicher und das DEMOscript funktioniert wieder.

2)
Ok, das FLASH nicht geht hat damit zutun das in deinem SuSE bzw. im Firefox kein Flashplayer Plugin eingebaut ist.
Da in den Flash-DEMOs die Plugin Installation nicht eingebaut ist wäre ein besuch bei http://flash4all.de mit deinem FireFox von mir an dich ratsam.

Dort wird dir der FireFox mitteilen das ein PLUGIN fehlt und bietet dir an diesen Downzuloaden, mach das, danach ist dein FireFox fähig Flashseiten anzuzeigen (so auch dann das Flash-Video-Tutorial)
Erkennst du auch daran das wenn du flash4all wieder besuchts mehrere Animationen laufen und die Plugin Meldung nicht mehr erscheint.
Jetzt laufen die FLASHdemos im Willkommenscreen und mein Video-Tutorial.

> f)phpmyadmin kann ich starten. dann will er ein passwort das ich
> eingebe, dann zeigt er mir eine übersicht mit mysql und php
> und da ist auch mein geliebtes rotes Kreuz bei "neue Datenbank erstellen"
Dazu bitte die config.inc.php im /opt/lampp/phpmyadmin editieren.
Es gibt in dieser Datei einen bereich für den PMA, dort müsstest du das im Security-Script definierte Passwort für den PMA eintragen, speichern und den phpmyadmin nochmal aufrufen.

> Was machen wir jetzt?
Sind doch gut dabei.....

Das problem ist eigentlich nur das in der Anleitung von WordPress nicht erklärt wird wie man eine DB in MySQL vorbereitet.

Wäre ja auch eigentlich die Dokumentation von MySQL und hinzufügend die Doku von phpmyadmin für zuständig.

Also wenn das erstellen der Datenbank und einem Datenbankuser vollzogen ist (video-tutorial), dürfte die WordPress Install Anleitung dir alle restlichen Infos geben.
Ist ja auch nur eine datei zu editieren und den rest macht das WordPress setup automatisch.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby DoctorJay » 14. June 2006 08:15

hm, ich arbeite immer in der Konsole.
Der Grund ist einfach:
Ich krieg es nicht hin mit dem Befehlsfenster root zu werden. Da passiert immer nichts nachdem ich Alt+F2 und dann "su" eingebe.



Ja ich habe die Datei in den htdocs gefunden, geöffnet und umgeschrieben.
Das Speichern schlug fehl- keine Berechtigung.


Was machte ich falsch?
Wie würde das mit der Konsole geben ( ich bin schon mittels cd opt... in dem Ordner gewesen)

danke vorab
DoctorJay
 
Posts: 17
Joined: 15. January 2006 13:37

Postby deepsurfer » 14. June 2006 09:39

AHA


ALT-F2 ==> xterm (zum öffnen eines Terminalfensters), in diesem
xterm dann "su" , jetzt wird nach root PW gefragt.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby DoctorJay » 15. June 2006 00:02

Ich kann die config Datei nicht öffnen und die Änderung in der ersten Datei nicht speichern.

Was ist da falsch?

Wenn ich in der Konsole arbeite kann ich su werden, aber die Datei nicht öffnen.
Wenn ich mit KDE die Datei öffnen, fehlen mir die Rechte, und ich schaffe es nicht su zu werden.

Danke
DoctorJay
 
Posts: 17
Joined: 15. January 2006 13:37

Postby DoctorJay » 15. June 2006 11:06

Ok das Problem mit dem root werden unter kde ist dank irc gelöst.

'kdesu kate' in die befehlszeile und dann startet kate im root modus.

In der Konsole habe ich es aber nicht geschafft die Datei zu öffnen.
Immer Syntaxfehler!
DoctorJay
 
Posts: 17
Joined: 15. January 2006 13:37

Postby DoctorJay » 15. June 2006 11:25

deepsurfer wrote:
1)
Der MySQL fehler beruht darauf das du schon das Security Script benutzt hast und Passworter vergeben.
Eben dieses Passwort kennt das DEMOscript jetzt nicht.
Lösung ==> editiere die /opt/lampp/htdocs/xampp/ cds.php
In zeile 4 steht das hier
mysql_connect("localhost","root","");
zwischen den letzten beiden "" muss das MySQL Passwort eingetragen werden. Abspeicher und das DEMOscript funktioniert wieder.



Das habe ich getan, leider ohne Erfolg.

Fehlermeldung:
Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'root'@'localhost' (using password: NO) in /opt/lampp/htdocs/xampp/cds.php on line 64
Kann die Datenbank nicht erreichen!
Läuft MySQL oder wurde das Passwort geändert?

Vermutung: Irgendwo muss es noch ein Skript geben wo ich das Password nochmals eingeben muss , denn da steht ja dass er keines eingegeben hat.


> f)phpmyadmin kann ich starten. dann will er ein passwort das ich
> eingebe, dann zeigt er mir eine übersicht mit mysql und php
> und da ist auch mein geliebtes rotes Kreuz bei "neue Datenbank erstellen"
Dazu bitte die config.inc.php im /opt/lampp/phpmyadmin editieren.
Es gibt in dieser Datei einen bereich für den PMA, dort müsstest du das im Security-Script definierte Passwort für den PMA eintragen, speichern und den phpmyadmin nochmal aufrufen.



Ja das wollte ich machen, aber die Datei ist sehr lange und ich konnte einen entsprechenden Abschnitt finden, wo ich vermutet habe, da muss das Passwort rein.
Der Abschnitt war aus Sicherheitsgründen auskommentiert und ich habe dies geändert das Passwort eingegeben und abgespeichert.

Leider ohne Erfolg. Ich hatte beim Start des Apaches wieder keine Berechtigung.

Was lief falsch?
DoctorJay
 
Posts: 17
Joined: 15. January 2006 13:37

Postby Stefan » 15. June 2006 14:16

Hi,
Fehlermeldung:
Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'root'@'localhost' (using password: NO) in /opt/lampp/htdocs/xampp/cds.php on line 64
Kann die Datenbank nicht erreichen!
Läuft MySQL oder wurde das Passwort geändert?

Du hast ein Passwort geändert bzw. überhaupt eins vergeben.

im pma komme das dorthin.
Code: Select all
$cfg['Servers'][$i]['auth_type']     = 'http';    // Authentication method (config, http or cookie based)?
$cfg['Servers'][$i]['user']          = 'root';      // MySQL user
$cfg['Servers'][$i]['password']      = 'DEIN_PASSWORT';   // MySQL password (only needed


Ich glaube allerdings, daß Du nochmal von vorne beginnen solltest, denn auch deepie wird Dir nicht mehr weiterhelfen können, wenn die Basis derart verworren und zerschossen ist.

Achtung, xampp wird komplett gelöscht.

shell öffen
root werden. Root passwort Deiner Kiste eintragen

Code: Select all
tester:~#su
Enter Password:



xampp beenden

Code: Select all
tester:~#/opt/lampp/lampp stop


xampp löschen

Code: Select all
tester:~#rm -rf /opt/lampp


xampp downloaden

Code: Select all
tester:~#wget http://puzzle.dl.sourceforge.net/sourceforge/xampp/xampp-linux-1.5.3a.tar.gz



xampp entpacken

Code: Select all
tester:~#tar xvfz xampp-linux-1.5.3a.tar.gz -C /opt


xampp starten

Code: Select all
tester:~# /opt/lampp/lampp start


Dem root user für mysql ein Passwort verpassen

Code: Select all
tester:~#/opt/lampp/bin/mysqladmin --user=root --password= password [PASSWORT]


Wordpress Datenbank erstellen. Passwort benutzen wie eben gewählt

Code: Select all
tester:~#/opt/lampp/bin/mysql -hlocalhost -uroot -p
Enter password:

Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 7 to server version: 5.0.21

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

Code: Select all
mysql> CREATE DATABASE `wordpress`;

Query OK, 1 row affected (0.03 sec)



mysql shell schließen
Code: Select all
mysql> quit;
Bye


ins xampp/htdocs verzeichnis wechseln

Code: Select all
tester:~#cd /opt/lampp/htdocs


wordpress runterladen

Code: Select all
tester:/opt/lampp/htdocs# wget http://files.wordpress.de/uploads/wp_de_20.zip


Worpress entpacken. Danach hast Du wordpress in einem unterverzeichnis "/wordpress"

Code: Select all
tester:/opt/lampp/htdocs# unzip wp_de_20.zip


Wenn Du Wordpress direkt mit http://localhost aufrufen möchstes, benutze folgendes.
Die Dateien liegen dann direkt im htdocs Verzeichnis. Achtung, vorher vielleicht die
Original xampp Dateien sicher /aus dem Verzeichnis entfernen.

Code: Select all
tester:/opt/lampp/htdocs# unzip wp_de_20.zip | cp -R ./wordpress/* ./



Ich gehe jetzt von ersterem aus, also das die Dateien im Verzeichnis /wordpress liegen.
Das gibt Dir auch die Freiheit noch ein Seite vorzuschalten.

Downloadpaket löschen

Code: Select all
tester:/opt/lampp/htdocs/# rm wp_de_20.zip


ins wordpress verzeichnis wechseln

Code: Select all
tester:/opt/lampp/htdocs# cd wordpress


Jetzt mache wir genau das, was unter http://wordpress.de/installation beschrieben ist.

Konfigurationsdatei anpassen.

Code: Select all
tester:/opt/lampp/htdocs/wordpress# nano wp-config-sample.php


Wenn der Editor nano in der Susi nicht dabei ist, benutzt Du halt einen Editor Deiner Wahl
Code: Select all
<?php
// ** MySQL settings ** //
define('DB_NAME', 'wordpress');    // Der Name der Datenbank, die du benutzt.
define('DB_USER', 'root');     // Dein MySQL Datenbank Benutzername.
define('DB_PASSWORD', 'DEIN_ROOT_PASSWORT'); // Dein MySQL Passwort
define('DB_HOST', 'localhost');    // 99% Chance, dass du hier nichts ändern musst.


// Wenn du verschiedene Präfixe benutzt kannst du innerhalb einer Datenbank
// verschiedene WorPress Installationen betreiben
$table_prefix  = 'wp_';   // Nur Zahlen, Buchstaben und Unterstriche bitte!

// Hier kannst du einstellen welche Sprachdatei benutzt werden soll
// Wenn du nichts einträgst wird Englisch genommen.
define ('WPLANG', 'de_DE');


/* Das war`s, ab hier bitte nichts mehr editieren! Happy blogging. */
define('ABSPATH', dirname(__FILE__).'/');
require_once(ABSPATH.'wp-settings.php');
?>


Bei Passwort trägst Du natürlich das MySQL Root Passwort ein, das Du vorhin vergeben hast.

'strg + x ' -> 'y' Speichert die Änderung.

Die Datei nach wp-config.php umbenennen

Code: Select all
tester:/opt/lampp/htdocs/wordpress# mv wp-config-sample.php wp-config.php



Soderle, mal schauen ob das alles richtig war

Browser aufmachen

http://localhost/wordpress/wp-admin/install.php


Hui, "Schritt 1" Wahnsinn.

Abrücken, Name und Mail eintragen -> Weiter.

Im folgenden Passwort merken und wie in der Doku beschriebn nach dem ersten Login unter Profile wieder
ändern.

Zu erreichen logischerweise unter http://localhost/wordpress/
Wenn Du nur wordpress hast, kannst Du die Daten ja alle ins htdocs Verzeichnis verschieben,
oder darin eine index.html/php erstellen, die auf das Wordpressverzeichnis weiterleitet.

cool, jetzt hab ich auch mal wordpress installiert. läuft einwandfrei.


Viel Spass damit.


PS:
Ach ja, hüte Dich vor der Datei "xmlrpc.php". Ich hab zwar keinen blassen Schimmmer warum, aber
ich weiß aus meinen Logfiles, das die häufig ganz gezielt gesucht wird. Vermutlich um Sicherheitslücken
darin auszunutzen. Also mach Dich schlau was es damit aufsich hat.

Deshalb deinstalliere ich den ganzen Quatsch lieber wieder

Code: Select all
tester:~# /opt/lampp/bin/mysql -hlocalhost -uroot -p
Enter password:
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 46 to server version: 5.0.21

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> DROP DATABASE `wordpress`;
Query OK, 10 rows affected (0.05 sec)

mysql> quit;
Bye


Code: Select all
tester:~# rm -rf /opt/lampp/htdocs/wordpress/
User avatar
Stefan
 
Posts: 475
Joined: 26. December 2002 22:36
Location: Mitten in der sonnigen Südpfalz

Postby DoctorJay » 15. June 2006 15:21

Ok , ich habe es geschafft.


Man wird standardmäßig bei phpmyadmin als rechteloser Benutzer pma eingeloggt.
Ich habe mich dann versucht als root einzuloggen und schon konnte ich machen was ich will.


Endlich.


EDIT: Boah, danke für die ausführliche Antwort, die habe ich jetzt erst erkannt.

Edit 2 : Alle Blogs und Datenbanken laufen erfolgreich - Danke !
DoctorJay
 
Posts: 17
Joined: 15. January 2006 13:37


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 2 guests