Error 1064

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

Error 1064

Postby schotenpopo » 27. April 2006 11:42

Hallo Leute! Bin neu hier und ein absoluter Anfänger. Habe mir den Xampp lite installiert und funktioniert auch alles super. Aber immer wenn ich versuche irgendein script zu installieren bekomme ich folgende Fehlermeldung:

> MySQL Error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'condition text NOT NULL,
conditiontype enum('OR','AND') NOT NULL default 'OR'' at line 5
-> MySQL Error Number: 1064

Was mache ich falsch bzw wie kann ich das beheben?

Sorry falls die Frage blöd ist aber bin echt am verzweifeln und kenne mich mit php und sql leider gar nicht aus... :cry:
schotenpopo
 
Posts: 2
Joined: 27. April 2006 11:30

Postby Wiedmann » 27. April 2006 11:54

Dein Burning Board ist nciht kompatibel zur MySQL Version.
a) Versuch eine neuere/korrigierte Version des Scriptes.
b) oder nimm einen älteren MySQL Server.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby schotenpopo » 27. April 2006 12:31

DANKE!! Na wenn das alles ist! dann schau ich mal nach ner älteren Version, die ganzen scripts wird es wohl leider nicht mehr neuer geben.
schotenpopo
 
Posts: 2
Joined: 27. April 2006 11:30

Postby flame » 29. January 2007 19:19

Welche Version sollte man den benutzen?
Hab MY SQL 4.1 und es läuft auch nicht!

mfg
flame
 
Posts: 26
Joined: 28. January 2007 19:56
Location: Österreich/Kärnten

Postby Wiedmann » 29. January 2007 19:25

Welche Version sollte man den benutzen?

Das sollte IMHO in den Requirements deiner Software stehen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby flame » 29. January 2007 19:59

so jetzt hab ich mal version 5.2 installiert, und nun kommt diese Fehlermeldung, wenn auf den phpmyadmin will:

MySQL-Query failed:


ErrorNo = 1146
Error = Table 'test.settings' doesn't exist
Query = SELECT * FROM settings
flame
 
Posts: 26
Joined: 28. January 2007 19:56
Location: Österreich/Kärnten

Postby Wiedmann » 29. January 2007 20:12

so jetzt hab ich mal version 5.2 installiert,

Von?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby flame » 29. January 2007 20:28

von mysql
flame
 
Posts: 26
Joined: 28. January 2007 19:56
Location: Österreich/Kärnten

Postby Wiedmann » 29. January 2007 20:30

Darf man fragen wieso du dir die Versino 5.2 von MySQL installiert hast?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby flame » 29. January 2007 20:34

da ich bei der älteren version immer den fehler:ErrorNo = 1064
hatte
flame
 
Posts: 26
Joined: 28. January 2007 19:56
Location: Österreich/Kärnten

Postby Wiedmann » 29. January 2007 20:41

Interessant.
Du meinst, mit einer Alpha-Version hast du dann mehr Changen, wenn deiner Software schon die aktuelle Version zu neu ist?

(BTW unterstützt der phpMyAdmin schon 5.1, die aktuelle Beta, nicht mehr.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby flame » 29. January 2007 21:01

hatte auch mysql 4.1 installiert und es ging nicht.
nun ist wieder mysql 5.0.27 von xampp 1.5.5 drauf, der fehler bleibt trotzdem.
flame
 
Posts: 26
Joined: 28. January 2007 19:56
Location: Österreich/Kärnten

Postby Wiedmann » 29. January 2007 21:08

hatte auch mysql 4.1 installiert und es ging nicht.

Dann wird diese evtl. auch zu neu sein?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby flame » 29. January 2007 21:14

ok...hab nun schon gesucht und leider keine frühere version gefunden!

zu meine fehler mit sqladmin, wie komm ich da jetzt wiede rein?
flame
 
Posts: 26
Joined: 28. January 2007 19:56
Location: Österreich/Kärnten

Postby Wiedmann » 29. January 2007 21:23

ok...hab nun schon gesucht und leider keine frühere version gefunden!

Ob das daran liegt, dass man keine Software (mehr) benutzt, welchen einen so alten Server voraussetzt?
MySQL wrote:Because version 4.0.* of MySQL Server are in such low demand we have decided to stop hosting binaries of these older versions.

(aber man muss ja nciht unbedingt bei MySQL suchen...)

zu meine fehler mit sqladmin, wie komm ich da jetzt wiede rein?

Du meinst phpMyAdmin?

Ist das Ganze eigentlich eine Eigeninstallation?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Next

Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 2 guests