kann db bei meinem Hoster nicht importieren...

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

kann db bei meinem Hoster nicht importieren...

Postby spielplan » 16. April 2006 07:29

Hallo zusammen,

beim Versuch meine db bei meinem Hoster per TelNet zu importieren bekomme ich folgende Fehlermeldung:

"You have an error in your SQL syntax...near 'collate latin1_general_ci NOT NULL default..."

Offensichtlich hat das was mit dem Zeichensatz zu tun.

Zuerst habe ich mir über TelNet ein dump erstellt, welches ich dann mit MYSQL-Administrator in meine lokale db importiert habe. Hat wunderbar funktioniert. Dann habe ich einige Änderungen an den Daten vorgenommen und jeweils mit MySQL-Administrator und mit phpMyAdmin erneut einen SQL-Dump erzeugt. Diesen habe ich hochgeladen und wollte diesen dann per TelNet wieder importieren. Jetzt erhalte ich aber obige Fehlermeldung:

"You have an error in your SQL syntax...near 'collate latin1_general_ci NOT NULL default..."

Mein lokaler phpMyAdmin gibt mir als Zeichensatz "German (de-utf-8) an. phpMyAdmin bei meinem Hoster gibt als Zeichensatz "German (de-iso-8859-1) an. Ich kann lokal zwar unterschiedliche Sprachen auswählen, aber nicht den Zeichensatz ändern. Aber genau daran wird es wohl liegen, dass es nicht geht.

Daher nun meine Frage:
Wie bitte gekomme ich meine lokale db wieder bei meinem Hoster importiert?

Viele Grüße
spielplan
spielplan
 
Posts: 14
Joined: 07. May 2003 05:22

Postby Wiedmann » 16. April 2006 09:04

In dem du beim Export erst einmal angibst, für welche MySQL-Version du den Dump überhaupt brauchst.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby spielplan » 16. April 2006 09:26

Vielen Dank für Deine Hilfe!

Ok, dieses Feld habe ich bisher erfolgreich ignoriert:
- SQL-Export-Kompatibilität

Das stand bisher auf "none"
Jetzt habe ich es auf "MYSQL40" eingestellt.

Die Ausgabe, welche den Fehler beim Import erzeugt hat, ist nun nicht mehr vorhanden. Aber dennoch werden alle Umlaute wie z.B das "ü" als "ü" dargestellt.

Gibt es dafür auch eine Lösung?

Viele Grüße
spielplan
spielplan
 
Posts: 14
Joined: 07. May 2003 05:22

Postby Wiedmann » 16. April 2006 09:39

Benutz für den Dump die Konsole und "mysqldump". Dort kannst du dann auch den Zeichensatz angeben.

Das geht jedenfalls immer... Mit irgendeiner Einstellung kann man zwar IMHO den phpMyAmdin auch überreden iso-8859-1 anstatt utf8 auszugeben, aber das darfst mich jetzt nicht genau fragen.

(BTW: hast du denn Dump mit Copy 'n Paste aus dem Browser geholt, oder die eine Datei anlegen lassen? Beim Admin solltest auch schauen, dass auf der Startseite das "latin1_general_ci" als Kollation auch ausgewählt ist)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby spielplan » 16. April 2006 09:50

Ok, Konsole...
...habe ich noch nie benutzt. Muß ich mich erst schlau machen.

Den Dump habe ich als Datei anlegen lassen.

Dann werde ich mir jetzt mal die Konsole anguggen..

Viele Grüße!
spielplan
spielplan
 
Posts: 14
Joined: 07. May 2003 05:22

Postby spielplan » 16. April 2006 14:59

war ja klar das es bei mir nicht funktioniert.

Also, in der Shell gebe ich folgendes ein:

mysqldump --add-drop-table -u spielplan -puffduff verein > datei.sql

Fehlermeldung: "Error 1146: Table 'verein' doesn't exist when doing Lock Tables"

Lock'en tu ich doch gar nichts? Außerdem ist es klar, daß keine Tabelle mit dem Namen "verein" vorhanden ist, da dies ja der Name der db ist.

Aber ich bin doch genau nach Anweisung MySQL Referenz vorgegangen.

Hilfe...


Viele Grüße!
spielplan
spielplan
 
Posts: 14
Joined: 07. May 2003 05:22

Postby spielplan » 17. April 2006 07:10

Hallo zusammen,

also leider komme ich noch immer nicht weiter. Ich werd noch verrückt mit diesem export/import Gedönse.

Inzwischen habe ich einen Export meiner localen db mit Hilfe der Konsole hinbekommen. Auch die Umlaute werden jetzt korrekt ausgegeben.

mysqldump --compatible=mysql40 --databases -u root -piuffduff proallrad > datei.sql

Leider funktioniert der Import bei meinem Hoster noch immer nicht.
Dort gehe ich mit TelNet drauf und gebe folgendes ein:

mysql -h rdbms -u Benutzername -pXXX DBYY < datei.sql

Die Meldung welche nach dem Drücken der Return-Taste erscheint:
MySQL dump 6.6
Host: rdbms Database: DBYYYYYY
Server version 4.0.24

Das wars...keine Fehermeldung...

Aber Daten sind leider keine vorhanden in meiner Datenbank.

Auszug dump (über Telnet vom Hoster erzeugt):
Code: Select all
#
# Table structure for table 'forum_useronline'
#
DROP TABLE IF EXISTS forum_useronline;
CREATE TABLE forum_useronline (
  ip char(15) DEFAULT '' NOT NULL,
  time int(14) DEFAULT '0' NOT NULL,
  user_id int(11) DEFAULT '0'
);

#
# Dumping data for table 'forum_useronline'
#

INSERT INTO forum_useronline VALUES ('84.187.250.113',1144785118,0);
INSERT INTO forum_useronline VALUES ('uid_14058',1144784837,14058);


Auszug dump (lokal mit mysqldump erzeugt)
Code: Select all
--
-- Table structure for table `forum_useronline`
--

DROP TABLE IF EXISTS `forum_useronline`;
CREATE TABLE `forum_useronline` (
  `ip` char(15) NOT NULL default '',
  `time` int(14) NOT NULL default '0',
  `user_id` int(11) default '0'
) TYPE=MyISAM;

--
-- Dumping data for table `forum_useronline`
--

/*!vbvbcvc*/;


/*!40000 ALTER TABLE `forum_useronline` DISABLE KEYS */;
LOCK TABLES `forum_useronline` WRITE;
INSERT INTO `forum_useronline` VALUES ('192.168.0.1',1145165012,0);
UNLOCK TABLES;
/*!40000 ALTER TABLE `forum_useronline` ENABLE KEYS */;

/*!40101 SET SQL_MODE=@OLD_SQL_MODE */;
/*!40014 SET FOREIGN_KEY_CHECKS=@OLD_FOREIGN_KEY_CHECKS */;
/*!40014 SET UNIQUE_CHECKS=@OLD_UNIQUE_CHECKS */;
/*!40111 SET SQL_NOTES=@OLD_SQL_NOTES */;


Vielleicht kann mir ja jemand weiterhelfen?


Viele Grüße
spielplan
spielplan
 
Posts: 14
Joined: 07. May 2003 05:22


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 3 guests