Problem mit MySQL Backup (falsche versionen)

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

Problem mit MySQL Backup (falsche versionen)

Postby bar-b-q » 28. March 2006 10:15

Hi,

ich habe mit phpmyadmin (auf nem MySQL 5.x) ein backup gemacht und es dann versucht in nem phpmyadmin (MySQL 4.x) wiederherzustellen. Kamen einige Fehler, nun weiß ich nicht wie ich die daten davon reinbekommen kann da ich auf dem Server wo im moment der 4.xer läuft keine neue MySQL Version isntallieren kann. Gibts da irgend nen trick ? Habs mit diesem kompatibilitätsmodus von phpmyadmin versucht (beim backupen) aber hat leider auch nix gebracht.

bar-b-q-
bar-b-q
 
Posts: 2
Joined: 28. March 2006 10:08

Postby Wiedmann » 28. March 2006 11:35

Was für Fehler kamen denn?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby bar-b-q » 30. March 2006 08:08

ERROR 1064 at line 19: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'collate latin1_general_ci NOT NULL default 'banner',
`name` v
bar-b-q
 
Posts: 2
Joined: 28. March 2006 10:08

Postby Wiedmann » 30. March 2006 12:12

Habs mit diesem kompatibilitätsmodus von phpmyadmin versucht (beim backupen) aber hat leider auch nix gebracht.

Seltsam... Beim Einstellen der mysql4 kombatibilität sollte er eigentlich die Angaben zum Zeichensatz weglassen in der sql-Datei.

Ist dein lokaler phpMyAdmin auch auf die Latin-Kollation eingestellt (direkt auf der Hauptseite)?

Ansonsten kannst du den Dump ja mal in der Konsole machen. --> siehe MySQL-Manual zu "mysqldump".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 2 guests