Fehler Die Erweiterung mysql kann nicht geladen werden

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

Fehler Die Erweiterung mysql kann nicht geladen werden

Postby msmcse » 05. March 2006 11:01

Hallo und schönen Sonntag an die Runde.
Ja ich habe die Suche gefunden und auch benutzt
leider keine brauchbaren Ergebnisse gefunden.

System
OS XP SP2
xampp Installer Version 1.5.1

Folgende Probleme

Nach der Standart Installation erhalte ich beim Aufruf
localhost/phpadmin
phpMyAdmin - Fehler Die Erweiterung mysql kann nicht geladen werden.

Ich habe in der php.ini nachgesehen die extension sind
nicht mit ; versehen, das extension directory ist korrekt angegeben,
im Windows VZ System32 sind die erforderlichen .dll vorhanden.

switche ich auf PHP 4 mit der php-switch.bat
funktioniert der Aufruf localhost/phpadmin
bis auf die seltsame Fehlermeldung ( mbstring )wäre nicht vorhanden
ist sicher vorhanden.?

beim Switch von PHP 4 auf PHP 5
mittels der php-switch.bat erhalte ich beim
Aufruf des PHP Admin wieder die Fehlermeldung
phpMyAdmin - Fehler Die Erweiterung mysql kann nicht geladen werden.

beim ausführen der php-switch.bat erhalte ich keine Fehlermeldung

Über eine deinstallation und eine neuerliche Installation
konnten ich das Problem auch nicht lösen
wo kann das Problem liegen ??

danke schon mal im voraus
schönen Tag noch

msmcse
msmcse
 
Posts: 24
Joined: 08. November 2005 20:18

Re: Fehler Die Erweiterung mysql kann nicht geladen werden

Postby msmcse » 30. March 2006 13:44

msmcse wrote:Hallo und schönen Sonntag an die Runde.
Ja ich habe die Suche gefunden und auch benutzt
leider keine brauchbaren Ergebnisse gefunden.

System
OS XP SP2
xampp Installer Version 1.5.1

Folgende Probleme

Nach der Standart Installation erhalte ich beim Aufruf
localhost/phpadmin
phpMyAdmin - Fehler Die Erweiterung mysql kann nicht geladen werden.

Ich habe in der php.ini nachgesehen die extension sind
nicht mit ; versehen, das extension directory ist korrekt angegeben,
im Windows VZ System32 sind die erforderlichen .dll vorhanden.

switche ich auf PHP 4 mit der php-switch.bat
funktioniert der Aufruf localhost/phpadmin
bis auf die seltsame Fehlermeldung ( mbstring )wäre nicht vorhanden
ist sicher vorhanden.?

beim Switch von PHP 4 auf PHP 5
mittels der php-switch.bat erhalte ich beim
Aufruf des PHP Admin wieder die Fehlermeldung
phpMyAdmin - Fehler Die Erweiterung mysql kann nicht geladen werden.

beim ausführen der php-switch.bat erhalte ich keine Fehlermeldung

Über eine deinstallation und eine neuerliche Installation
konnten ich das Problem auch nicht lösen
wo kann das Problem liegen ??

danke schon mal im voraus
schönen Tag noch

msmcse


[edit]

Da ich nun zur Problemlösung die Suche hier und das www benutzt habe,
mich quer durch APACHE/PHP/MYSQL TuT`s gelesen habe,ich aber nicht wirklich weiterkomme nochmals die obige Frage kennt wer eine Lösung. :?:

Durchgeführt :!:
.dll dateien ins Windows/system32 VZ kopiert
semiklon vor der extension entfernt,
alle Pfade in der php.ini ( apache/bin ) kontrolliert
alle .dll auf ihr vorhandensein kontrolliert.
jeweils mehrere Neustarts,
zwischen den Änderungen Apache und MYSQL neugestartet,

Da ich bei meiner lokalen Testumgebung mit den Applikationen,
die PHP5 Version verwenden möchte wäre echt toll wenn das funktionieren würde.

[/edit]

grüsse
msmcse
msmcse
 
Posts: 24
Joined: 08. November 2005 20:18

Postby Wiedmann » 30. March 2006 13:51

Du bist dir aber sicher, dass du einen XAMPP benutzt?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby msmcse » 30. March 2006 18:11

Wiedmann wrote:Du bist dir aber sicher, dass du einen XAMPP benutzt?


Hallo Wiedmann
:wink: Also soweit reicht meine Kenntnis über die Thematik

Zur Darstellung meiner Sicherheit
wenn ich die php-switch.bat ausführe sehe ich im Dos Command Fenster
als erstes eine Information Apache Friends XAMPP PHP Switch win32.....
.......Authors......Carsten Wiedmann....

ob das in der Linux Variante ebenfalls so ist kann ich nicht beantworten,
da ich im Moment keine Linux Dis installiert habe.

Wie schon geschrieben, bin zwar kein Apache Profi , aber ein wenig Kenntnis über die Materie habe ich mir nicht zuletzt mit Hilfe diese Forum
angeeignet.Für das vorliegende Problem scheinen diese aber nicht auszureichen.
Hoffe das ich mit Hilfe der Apachefriends doch noch meiner PHP5
Testumgebung realisieren kann.

danke schon mal im voraus
msmcse
msmcse
 
Posts: 24
Joined: 08. November 2005 20:18

Postby Wiedmann » 30. March 2006 18:24

Durchgeführt
.dll dateien ins Windows/system32 VZ kopiert
semiklon vor der extension entfernt,

a) man muss beim XAMPP keine Dateien ins Windowsverzeichnis kopieren
b) die MySQL-Extension ist per default schon aktiviert

--> Der XAMPP inkl. PHP und phpMyAdmin ist direkt nach der Installation einsatzbereit ohne etwas an der Konfig ändern zu müssen. Es sei denn, es wären schon bei der Installation ein Fehler aufgetreten?

alle Pfade in der php.ini ( apache/bin ) kontrolliert

Benutzt er denn diese INI? Schau das mal in phpinfo() nach.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby msmcse » 30. March 2006 19:20

Wiedmann wrote:
Durchgeführt
.dll dateien ins Windows/system32 VZ kopiert
semiklon vor der extension entfernt,
a) man muss beim XAMPP keine Dateien ins Windowsverzeichnis kopieren
b) die MySQL-Extension ist per default schon aktiviert


Das habe ich bei meinen Kreuz und quer lesen durch die TuT`s auch
gelesen, aber da ich mit diesen nicht weiterkam habe ich eben einige
"Ratschläge" getestet, leider bisher ohne Erfolg.
Wie du sehen kannst hatte dieses Post 130 Aufrufe ohne einen Vorschlag
bis heute :wink: das kann auch bedeuten , das bisher keiner diese Problem in Verbindung mit dem XAMPP hatte.

Wiedmann wrote:
--> Der XAMPP inkl. PHP und phpMyAdmin ist direkt nach der Installation einsatzbereit ohne etwas an der Konfig ändern zu müssen. Es sei denn, es wären schon bei der Installation ein Fehler aufgetreten?


Dieser Meinung war ich bis dato ebenfalls, ich kann dir nur versichern
das bei der Installation kein Fehler ausgegeben wird.
Der Welcome Screen des XAMPP erscheint nach der Installation, da Standartmässig dem Anschein nach PHP5 läuft kommt beim Aufruf
Phpmyadmin eben die beschriebene Fehlermeldung.
Nach dem Switch auf die PHP4, kann ich mich in den PHPmyadmin einloggen.

Wiedmann wrote:
alle Pfade in der php.ini ( apache/bin ) kontrolliert
Benutzt er denn diese INI? Schau das mal in phpinfo() nach.


Das werde ich mal machen, aber da ich nichts verstellt habe sollte das doch die default Einstellungen sein.

danke dir für deine Unterstützung
grüsse
msmce
msmcse
 
Posts: 24
Joined: 08. November 2005 20:18

Postby thorsin » 01. April 2006 11:00

hast du irgendwelche extensions aktiviert? manchmal spielt seltsamerweise die reihenfolge der extensions eine rolle. teste mal was passiert, wenn du die extension durch einfügen des ; wieder auskommentierst...
User avatar
thorsin
 
Posts: 136
Joined: 05. March 2006 20:39


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 1 guest