Benutzername und Passwort wie bei meinem Online Server

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

Benutzername und Passwort wie bei meinem Online Server

Postby nev-hh » 08. July 2003 11:44

Hallo,

ich habe alles installiert und es funktioniert einwandfrei. Hauptsächlich habe ich es installiert um meine PHP-Scripte komfortabel offline zu erstellen und vor allem zu testen. Nun habe ich online für die MySql Datenbanken natürlich einen anderen Benutzernamen und ein anderes Passwort. Voreingestellt ist bei wampp2 "root" und "" als Passwort. Wie kann ich das ändern?

Ich bin zwar sehr fit in PHP und kann dort eine Menge, habe mich aber noch nie mit der Installation eines Servers beschäftigt. Daher habt bitte nachsicht für die vielleicht blöde Frage.

Schonmal vielen Dank für eure Hilfe

Gruß nev-hh
nev-hh
 

Postby Oswald » 08. July 2003 12:28

Huhu nev!

Siehe Installationsanleitung zu WAMPP: http://www.apachefriends.org/wampp/wamp ... nstall.txt

C:\wampp2\mysql\bin\mysqladmin -u root password secret

Wobei "secret" das neue Passwort ist.

Viel Erfolg,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Pc-dummy » 08. July 2003 17:36

@ Kai

glaub eher er will neue User erstellen!

@ nev-hh

du kannst dir "am einfachsten" mit phpmyadmin ( http://localhost/phpmyadmin/ ) neue user erstellen mit den einstellungen wie du sie hast beim Prov. (z.b.: user: nev-hh passwd: secret).

Wobei der code ich den Code von Kai trotzdem ausführen würde um MySQL zu sichern!

MFG
Pc-Dummy
Gentoo/X86_64, AMD Athlon 64 FX-53, 1,5 GB INFINEON Ram, Audigy 2 ZS Platinum Pro, 300 GB Platten, LG-DVD Brenner
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch

Postby Thhunder » 03. August 2003 23:18

Kai Seidler wrote:Huhu nev!

Siehe Installationsanleitung zu WAMPP: http://www.apachefriends.org/wampp/wamp ... nstall.txt

C:\wampp2\mysql\bin\mysqladmin -u root password secret

Wobei "secret" das neue Passwort ist.

Viel Erfolg,
Oswald


da bekomm ich die fehlermeldung: "root@localhost acces denied <using Password: NO>
Image
Thhunder
 
Posts: 87
Joined: 03. August 2003 22:42

Postby Guest » 04. August 2003 11:44

hi,



dann füge dem Befehl noch den Parameter "-p" hinzu.... zumindest unter Linux ist es so :)


l0rd
Guest
 

Postby AberHallo » 04. August 2003 18:35

hallo :)
habe da auch ein problem wenn ich das mache kommt
msqladmin: connect to server at `localhost` failed
error: Access denied for user: `root@127.0.0.1` <Using passwort: YES>`

???? weis einer weiter ich sag schon mal DANKE
AberHallo
 

das selbe

Postby java » 03. September 2003 15:41

habe genau das selbe problem wie der kollege über mir, alles nach anleitung gemacht und selben fehler :

Warning: mysql_connect(): Access denied for user: 'root@localhost' (Using password: YES)

ihabe im zum installierendem script natürlich auch das pw eingetragen

Warning: mysql_connect(): Access denied for user: 'root@localhost' (Using password: YES)

wenn ich die config noch nicht ändere kann ich mir die db anschauen, sobald ich ich die config ändere, verlangt er pw und benutzername, aber
das pw funktiniert nicht.

os=winxp prof
XAMPP win32 version 0.9

bitte um hilfe, thx java
java
 

Postby Guest » 05. September 2003 13:51

ne, braucht keiner zu antworten, waren ja schon alle fragen erklärt worden....
Guest
 

Postby Guest » 07. September 2003 17:02

lol...
Guest
 


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 2 guests