MySQL startet nicht mehr?

Alles, was MySQL betrifft, kann hier besprochen werden.

Postby M3g4Star » 17. February 2006 14:31

Na hast schon mal dein Passwort gcheckt ?

oder nicht ? oder änder deine Zugangsdaten mal. was sagt dir denn XAMPP wenn du auf PHPMyAdmin klickst ?

bzw. wenn du "http://localhost/phpmyadmin/" aufrufst ?
User avatar
M3g4Star
 
Posts: 145
Joined: 25. January 2006 07:46
Location: München

Postby jo- » 17. February 2006 15:29

M3g4Star wrote:Na hast schon mal dein Passwort gcheckt ?

oder nicht ? oder änder deine Zugangsdaten mal. was sagt dir denn XAMPP wenn du auf PHPMyAdmin klickst ?

Es fragt mich so oft nach den Zugangsdaten, bis ich auf Abbrechen klicke, dann habe ich keinen Zugriff
M3g4Star wrote:bzw. wenn du "http://localhost/phpmyadmin/" aufrufst ?

Rate mal, wie ich versucht habe in phpmyadmin zu kommen? Richtig über diesen Link ...
jo-
 
Posts: 15
Joined: 05. February 2006 16:11

Postby deepsurfer » 17. February 2006 15:57

Er fragt dich also nach Zugangsdaten.... ergo.... wie M3g4Star schon erwähnte dürftest du mal das SecurityScript ausgeführt haben das im Willkommenscreen von XAMPP zu finden ist.

....ergo.... bei diesem Script vergibst du Passwörter, daraus ergibt sich das MySQL abgesperrt ist.

Im jetzigen Fall wenn phpmyadmin aufgerufen wird, wird nach Name und Passwort gefragt, ergo liegt es nahe mal Name: root PW: das von dir im Security Script eingetragene zu nehmen.

testen und melden.

PS: sollte das abermals nicht klappen dann das resetroot.bat im mysql Verzeichnis ausführen.
Bitte alle Hinweise die da erscheinen lesen.....
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
XAMPP Version: 5.6.3
Operating System: Win-XP / Win7 / Linux -Debian

Postby jo- » 17. February 2006 17:17

Hab beides versucht (PW ändern und resetroot.bat), geht leider immer noch nicht :(
Keine Ahnung was ich da kaputt gemacht hab ...
jo-
 
Posts: 15
Joined: 05. February 2006 16:11

Postby M3g4Star » 20. February 2006 08:20

*hm* sehr sehr merkwürdig.

:?

warum installierst du dir XAMPP nicht einfach nochmal neu ?

:P :roll:
User avatar
M3g4Star
 
Posts: 145
Joined: 25. January 2006 07:46
Location: München

Postby jo- » 22. February 2006 23:15

M3g4Star wrote:*hm* sehr sehr merkwürdig.

:?

warum installierst du dir XAMPP nicht einfach nochmal neu ?

:P :roll:

Gute Idee ...
Scheiß MySQL :P
jo-
 
Posts: 15
Joined: 05. February 2006 16:11

Re: MySQL startet nicht mehr?

Postby user2009 » 20. May 2009 15:24

Hallo,

sorry, dass ich das alte Thema nochmal hochhole, aber ich stehe vor dem gleichen Problem: Mein MySQL startet nicht mehr.

Ich bekomme es weder über das Control-Panel von XAMPP gestartet, noch über die beschriebene Methode mit der Eingabeaufforderung.

Dabei erscheint dann immer eine Fehlermeldung:

Image

Weiss jemand, woran das liegt bzw. wie ich das Problem gelöst bekomme?

Der Fehler tritt sowohl bei der Ausführung von MySQL als Service auf, als auch "normal".

Mit einer Neuinstallation von XAMPP bin ich leider nicht weitergekommen.
user2009
 
Posts: 3
Joined: 20. May 2009 15:15

Re: MySQL startet nicht mehr?

Postby Niushad » 20. October 2010 13:05

Hallo leute ich habe ine problem wenn ich mysql starten will steht da nur mysql startet das wars aber da kommt kein running pls helft mir
Niushad
 
Posts: 1
Joined: 20. October 2010 13:02

Re: MySQL startet nicht mehr?

Postby red-polo » 26. May 2011 09:15

Ich hänge mich mal als Newbie hier an... Habe selbiges Problem, dass MySQL nicht mehr startet.

Habe gestern Xampp in der Version 1.7.4 für Windows in der Installer-Version installiert und das Teil lief gleich. Beim herunterfahren gestern hat Windows Updates installiert und heute startet MySQL nicht mehr.
Habe zwischenzeitlich schon hier im Forum herumgesucht, war bisher aber zu doof den richtigen Tipp zu finden.

Was ich schon getan hab: Control Panel 3.0.2 in der Version vom 13.05.2011 installiert, versucht MySQL direkt über die BAT-Datei zu starten und mySQL-Error-Log ausgelesen. Folgende Fehler werden dort ausgeworfen:
Code: Select all
110526 10:06:40 [Note] Plugin 'FEDERATED' is disabled.
InnoDB: The InnoDB memory heap is disabled
InnoDB: Mutexes and rw_locks use Windows interlocked functions
InnoDB: Compressed tables use zlib 1.2.3
110526 10:06:40  InnoDB: Initializing buffer pool, size = 16.0M
110526 10:06:40  InnoDB: Completed initialization of buffer pool
110526 10:06:40  InnoDB: highest supported file format is Barracuda.
InnoDB: The log sequence number in ibdata files does not match
InnoDB: the log sequence number in the ib_logfiles!
110526 10:06:40  InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
110526 10:06:42  InnoDB: 1.1.4 started; log sequence number 3735503
110526 10:06:42 [ERROR] Fatal error: Can't open and lock privilege tables: Can't find file: 'host' (errno: 2)
110526 10:06:59 [Note] Plugin 'FEDERATED' is disabled.
InnoDB: The InnoDB memory heap is disabled
InnoDB: Mutexes and rw_locks use Windows interlocked functions
InnoDB: Compressed tables use zlib 1.2.3
110526 10:06:59  InnoDB: Initializing buffer pool, size = 16.0M
110526 10:06:59  InnoDB: Completed initialization of buffer pool
110526 10:06:59  InnoDB: highest supported file format is Barracuda.
InnoDB: The log sequence number in ibdata files does not match
InnoDB: the log sequence number in the ib_logfiles!
110526 10:06:59  InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
110526 10:06:59  InnoDB: 1.1.4 started; log sequence number 3735503
110526 10:06:59 [ERROR] Fatal error: Can't open and lock privilege tables: Can't find file: 'host' (errno: 2)


Was kann ich daraus jetzt aber herauslesen, und vor allem wo und wie korrigieren? Vielen Dank für eure Hilfe.

Edit: Zur Technik: Windows 7 Prof. 32Bit mit SP1, aktiver Avast Virenscanner
red-polo
 
Posts: 1
Joined: 26. May 2011 08:48

MySQL startet nicht mehr?

Postby 2012Kaspar » 30. August 2013 02:48

Hallo,

es sollte beim installieren von XAMPP peinlichst
darauf geachtet werden, dass die Firewall vom
Betriebssystem deaktiviert ist und später bei den Einstellungen am besten alle
XAMPP-Panal-Dienste bei Firewall erlaubt werden.

Das kann man einstellen, wenn in der System-
Steuerung auf Firewall gegangen wird.
Da bitte auf erweiterte oder sonstige Einstellungen gehen.

Da die Dienste als erlaubt markieren.

Das gilt nach der Installation!!

Vor der Installation bitte über die Systemsteuerung die Firewall ganz deaktivieren.

Nicht vergessen, die dann wieder nach der
XAMPP-Installation zu aktivieren.

Danach reicht das beschriebene Erlauben der
XAMPP-Dienste vollkommen aus.

Noch was:"Während der Installation den Vierenschutz ebenfalls ausschalten."

Wer da unsicher ist, sollte da genau üben, wo
bei jeweiligen Virenschutzprogramm dieses
ausgestellt/deaktiviert wird.

Bei Avira geht dass über das Menu, wer z.B.
das Avast hat, macht das unten rechts über das
Feld und dem Zeichen des Avast, indem man
mit der linken Maustaste Auswahlmöglichkeiten
erscheinen lässt.

Nun die entsprechenden Eigenschaften aufrufen, die das Avast am besten dauerhaft
deaktiviert.

Nicht vergessen, nach der Installation des XAMPP das Avast wieder zu aktivieren, was auf dem gleichen Weg gemacht wird, wie beim deaktivieren; nur hier aktivieren wählen.

Vor diesen Schritten, das XAMPP am besten mit dem Uninstaller vom XAMPP vollständig deinstallieren.

Ob alles für die Installation nun richtig vorbereitet wurde, sieht man an den Meldungen
während des Installer des XAMPP.

Wenn Firewall nicht aus ist, kommt Warnung.

Wenn Virenschutz an ist, kommt auch eine.

Was auch vorkommen kann, ist dass ein Port,
welches von einem Dienst des
XAMPP-Control-Panals benötigt wird, von einem anderen Programm belegt wird.

Das belegende Programm dann stoppen oder
den Port neu zuteilen.

Puhhhh, jetzt sollte Alles funktionieren.

Ich muss jedoch anmerken, dass es wohl besser
wäre, wenn der Rechner nicht durch die
obligatorischen Deaktivierungen ungeschützt
sein würde.

Geht aber nicht anders.

Tschüüüüs.
2012Kaspar
 
Posts: 14
Joined: 29. July 2013 13:57
XAMPP Version: 5.5.19
Operating System: Windows 7

Previous

Return to MySQL

Who is online

Users browsing this forum: No registered users and 2 guests