MySQL-Volltextsuche fein einstellen

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

MySQL-Volltextsuche fein einstellen

Postby Maurizio » 25. June 2003 10:00

Habe soeben LAMPP erfolgreich unter SuSE Linux 8.2 Pro installiert und soweit läuft auch alles wunderbar. Möchte nun noch das Verhalten der Volltextsuche für MySQL definieren. Laut www.mysql.com wird die minimale zu indexierende Wortlänge in der myisam/ftdefs.h-Datei festgelegt.

Wie & Wo finde ich nun diese Datei bei LAMPP (Entwicklungspaket?) bzw. wie kann ich MySQL dann eigenständig kompilieren?

Stehe da momentan echt mehr als auf dem Schlauch :(
Maurizio
 

Postby Oswald » 25. June 2003 11:35

Huhu Maurizio!

Du brauchst zum einen des LAMPP-Entwicklungspaket und die MySQL-Sourcen von www.mysql.com. Dann kannst Du selbst MySQL übersetzen.

Wenn Bedarf besteht, dann kann ich Dir die configure-Optionen, die ich verwendet hab mal geben. Könnte eine Hilfe sein.

Stell Dich aber auf ein paar Stunden Arbeit ein. ;)

Lieben Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Maurizio » 25. June 2003 12:46

Hallo Oswald,

habe mittlerweile die MySQL-Sourcen von www.mysql.com geholt, die entsprechenden Dateien geändert und ein ./configure ausgeführt.
Code: Select all
./configure --prefix=/opt/lampp/ --with-pthreads --enable-thread-safe-client --enable-shared

Lief ohne Fehlermeldung durch und im Moment bin ich beim make. Mal sehen ob alles funktionieren wird; wäre trotzdem nett, wenn Du mir Deine configure-Optionen mal geben kannst. Per Mail oder hier im Forum?
Maurizio
 

Postby Maurizio » 25. June 2003 13:19

So ein Mist :cry:

Nach dem configure, dem make und dem make install bekomme ich nun MySQL nicht mehr ans Laufen.

MySQL meldet:
Code: Select all
Can't connect to local MySQL server through socket '/opt/lampp/var/mysql/mysql.sock' (2)


Oswaaald!!! Hiiilfe!!!
Maurizio
 

Postby Maurizio » 26. June 2003 14:16

Habe zwischenzeitlich ohne Sourcen und zu kompilieren eine Lösung gefunden. Habe in der [mysqld] Sektion der Datei "my.cnf" einfach folgende Variable auf den gewünschten Wert gesetzt:
Code: Select all
set-variable=ft_min_word_len=X

Danach neu gestartet und die Indexe neu aufgebaut - funktioniert nun einwandfrei.

Möchte nun noch die Stopword-Liste bearbeiten; bin für jeden Tipp dankbar :)
Maurizio
 

Postby Maurizio » 30. June 2003 09:07

Kai Seidler wrote:Wenn Bedarf besteht, dann kann ich Dir die configure-Optionen, die ich verwendet hab mal geben. Könnte eine Hilfe sein.


Ähm... Wie sieht es aus mit den configure-Optionen? Könnte ich wirklich gut gebrauchen :wink:
Maurizio
 

Postby Oswald » 02. July 2003 20:37

Hier ist sie:

Code: Select all
env LD_RUN_PATH=/opt/lampp/lib LD_LIBRARY_PATH="/opt/lampp/lib" CFLAGS="-O6 -I/opt/lampp/include -L/opt/lampp/lib -Wl,--rpath -Wl,/opt/lampp/lib" ./configure --prefix=/opt/lampp --enable-assembler --enable-local-infile --with-mysqld-user=nobody --with-unix-socket-path=/opt/lampp/var/mysql/mysql.sock --with-extra-charsets=complex --libexecdir=/opt/lampp/sbin --sysconfdir=/opt/lampp/etc --datadir=/opt/lampp/share --localstatedir=/opt/lampp/var/mysql --infodir=/opt/lampp/info --includedir=/opt/lampp/include --mandir=/opt/lampp/man --with-innodb


Liebe Grüße und viel Erfolg,
Oswald

PS: Wenn Du MySQL selbst übersetzt, dann sucht MySQL seine Konfigurationsdatei in /etc und nicht mehr in /opt/lampp/etc. Daran bitte denken! ;)
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 4 guests