#1064 - You have an error..... Kollations Problem

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

#1064 - You have an error..... Kollations Problem

Postby speedy00 » 12. December 2005 18:48

morgen ;)
Ich dreh noch durch......

Zuerst hatte ich das prob das wenn ich ein dump von meinem Provider bei xampp eingespielt habe das mir dann immer ü und ö usw. nicht richtig angezeigt wurde.
Das habe ich mittlerweile hinbekommen.
Nun ist es so das wenn ich ein dump von meinem lokalen Forum bei meinem Provider einspielen will
SQL-Befehl:

CREATE TABLE IF NOT EXISTS `phpbb_auth_access` (
`group_id` mediumint( 8 ) NOT NULL default '0',
`forum_id` smallint( 5 ) unsigned NOT NULL default '0',
`auth_view` tinyint( 1 ) NOT NULL default '0',
`auth_read` tinyint( 1 ) NOT NULL default '0',
`auth_post` tinyint( 1 ) NOT NULL default '0',
`auth_reply` tinyint( 1 ) NOT NULL default '0',
`auth_edit` tinyint( 1 ) NOT NULL default '0',
`auth_delete` tinyint( 1 ) NOT NULL default '0',
`auth_sticky` tinyint( 1 ) NOT NULL default '0',
`auth_announce` tinyint( 1 ) NOT NULL default '0',
`auth_global_announce` tinyint( 1 ) NOT NULL default '0',
`auth_vote` tinyint( 1 ) NOT NULL default '0',
`auth_pollcreate` tinyint( 1 ) NOT NULL default '0',
`auth_attachments` tinyint( 1 ) NOT NULL default '0',
`auth_mod` tinyint( 1 ) NOT NULL default '0',
KEY `group_id` ( `group_id` ) ,
KEY `forum_id` ( `forum_id` )
) ENGINE = MYISAM DEFAULT CHARSET = utf8

MySQL meldet: Dokumentation
#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=utf8' at line 19

was wie muss ich denn da einstellen damit das utf.....nich in dem dump steht und er einfach nur die Daten einfügt?

Wenn ich SQL-Export-Kompatibilität: mysql 40 wähle wird es zwar online importiert, aber ü und ö usw. stimmen dann wieder nicht (das soll ein ü sein ü) bzw werden mit umgedrehten Fragezeichen und so angezeigt.
speedy00
 
Posts: 2
Joined: 12. December 2005 11:29

Postby Wiedmann » 13. December 2005 12:52

Wenn ich SQL-Export-Kompatibilität: mysql 40 wähle wird es zwar online importiert, aber ü und ö usw. stimmen dann wieder nicht

Du musst beim Export über mysqldump auch angeben welches Charset du gern hättest.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby speedy00 » 13. December 2005 16:26

Das kann ich nicht, diese option is nich. :(
speedy00
 
Posts: 2
Joined: 12. December 2005 11:29

Postby Wiedmann » 13. December 2005 16:28

Das kann ich nicht, diese option is nich.

Wegen?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby lupo » 31. January 2006 10:46

ich habe diesselben probs, und finde überall im netzt den hinweis auf --> SQL-Export-Kompatibilität einstellen.

aber ich finde diese option beim besten willen nicht!

ich benutze xamp 1.4.11
mit phpmyadmin 2.6.0 pl3
und mysql 4.1.8

weiß jemand rat? wäre sehr dringend - danke!
lupo
 
Posts: 1
Joined: 31. January 2006 10:24


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 2 guests