mysql untersützt innodb nicht :-/

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

mysql untersützt innodb nicht :-/

Postby eary » 02. November 2005 11:48

Hallo!

Leider musste ich feststelen, dass mein mysql kein innodb kann. Kann man das auch nachträglich installieren... denn ich brauche es unbedingt, weil ich mit fremdschlüsseln arbeiten muss.

:shock:
eary
 
Posts: 3
Joined: 02. November 2005 09:03

Postby deepsurfer » 02. November 2005 12:51

ansonsten einfach ein eigenes MySQL installieren, und den XAMPP mysql nicht starten lassen, die funktionen sind dann genau gleich (ok..musst nur die Usernamen übertragen)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby eary » 02. November 2005 12:56

Äh ich meinte : Wie kann ich in Xammp innodb nachträglich installieren bitte?

Beziehungsweise: Untersützt Xammp auch innodb im eingebundenen MYSQL?

Vielleicht :oops: hab ich ja was bei dir Installation falsch gemacht.
eary
 
Posts: 3
Joined: 02. November 2005 09:03

Postby Wiedmann » 02. November 2005 13:49

Beziehungsweise: Untersützt Xammp auch innodb im eingebundenen MYSQL?

Ja, wird unterstützt. Einfach in der "my.cnf" aktivieren.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby eary » 02. November 2005 15:03

:P

Freu es geht! Auf das wäre ich nie gekommen danke!
eary
 
Posts: 3
Joined: 02. November 2005 09:03

Postby fhl » 16. November 2005 00:47

Ich habe das gleiche Problem und habe die my.ini (W2k) geändert, aber ich kann Inno_db trotzdem nicht benutzen.

#skip-innodb
# Uncomment the following if you are using InnoDB tables
innodb_data_home_dir = C:/Programme/xampp/mysql/
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = C:/Programme/xampp/mysql/
innodb_log_arch_dir = C:/Programme/xampp/mysql/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
set-variable = innodb_buffer_pool_size=16M
set-variable = innodb_additional_mem_pool_size=2M
# Set .._log_file_size to 25 % of buffer pool size
set-variable = innodb_log_file_size=5M
set-variable = innodb_log_buffer_size=8M
innodb_flush_log_at_trx_commit=1
set-variable = innodb_lock_wait_timeout=50

Was mache ich falsch??
fhl
 
Posts: 2
Joined: 16. November 2005 00:38

Postby Wiedmann » 16. November 2005 10:17

und habe die my.ini (W2k) geändert,

Die Datei nennt sich "my.cnf" (\xampp\mysql\bin).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby fhl » 16. November 2005 11:54

Jetzt funktioniert es. Danke. :)
Aber warum gibt es auch eine my.ini in der das selbe steht ?? :?
fhl
 
Posts: 2
Joined: 16. November 2005 00:38


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 2 guests