Große Datenbank importieren

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

Große Datenbank importieren

Postby Sam Hawkins » 11. October 2005 12:17

Hallo Leute,
ich versuche vergeblich ein Dump (mit 150 MB) einer Datenbank einzulesen. Ich bin überhaupt kein Experte, habe es allerdings, mit Anleitung, an einem Win98-Rechner hinbekommen. Zuhause mit WinXP klappt es nicht. Meine Vorgehensweise: Ich lege den Datenbankdump in den bin-Ordner von mysql, also hier:
    C:\Programme\xampp\mysql\bin\mein_dump.sql
Dann gehe ich über die Eingabeaufforderung dorthin, um einzulesen:
    C:\Programme\xampp\mysql\bin>mysql meine_Datenbank < mein_dump.sql
klappt leider nicht, denn:
    ERROR 1045 <28000>: Access denied for user 'ODBC'@'localhost' <using password NO>

muß ich noch ein Passwort anfügen? Wenn ja, wie? Bin für jeden Tip dankbar.
Gruß
Sam
Sam Hawkins
 
Posts: 5
Joined: 11. October 2005 11:52

Postby deepsurfer » 11. October 2005 12:54

hast du das security script von xampp ausgeführt ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Sam Hawkins » 11. October 2005 13:50

Hallo deepsurfer,
ich habe nur für phpmyadmin ein Passwort vergeben, aber ich habe glaube kein security script ausgeführt, ist schon etwas länger her. Muß ich es ausführen? Wenn ja, wie?
Muß ich nochmal recherchieren.
Sam Hawkins
 
Posts: 5
Joined: 11. October 2005 11:52

Postby deepsurfer » 11. October 2005 14:01

Also..im XAMPP kann man ein Security Script aufrufen, dieses Script enthält zwei bereiche.

1) Passwort für MySQL

2) Passwort für den zugang auf das Willkommenscreen von XAMPP.

Zu 1 sei gesagt das durch dieses Script dem MySQL und in dem dafür bestehenden User "Root" ein Passwort eingetragen wird.
Damit man nun mittels phpmyadmin ohne Passwort abfrage auf MySQL zugreifen kann, soll man das generierte Passwort in die config.inc.php des PhpmyAdmin eintragen.

Nun gehe ich davon aus das du es so gemacht hast, dann muss dein aufruf des Import anders lauten.

mysql.exe -D Datenbankname < dunp.sql -u root -p passwort

Hinweis an die MySQL Gurus:
Habe das jetzt so aus meinem Kopf heraus genommen, falls das soooo falsch sein sollte bitte korrigieren !!!
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Wiedmann » 11. October 2005 14:31

Ich weiss zwar nicht zuwas dieser riessiege Excurs in die Security ;-) Wichtig ist ja nur dass er einen MySQL-Benutzer mit dazugehörigem Passwort kennt, und diesen beim Tool "mysql.exe" mit angibt.
mysql.exe -D Datenbankname < dunp.sql -u root -p passwort

Bei einer Eingabeumleitung "<" hört der eigentliche Befehl auf und man kann danache keine Parameter für diesen Befehl mehr mit angeben.
Code: Select all
mysql.exe  -u root -pPasswort -D Datenbankname < dump.sql


BTW:
Das MySQL Manual hat da einen eigenen Abschnitt dafür.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Sam Hawkins » 11. October 2005 15:02

Hi deepsurfer,
ich habe ein Passwort gesetzt und es auch in die config.inc.php geschrieben. Allerdings gibt es die Möglichkeit an 3 Stellen im Script das "password" zu setzten, ich habs mit der 1. Möglichkeit probiert, ist das richtig?
Dann habe ich in die Eingabeaufforderung folgendes reingeschrieben:
    mysql.exe -D Datenbankname < dump.sql -u root -p meinpasswort

dann kam (habe noch mal hier das Passwort reingeschrieben):
    Enter password: *****(meinpasswort)

aber:
    ERROR 1049 <42000>: Unknown database 'meinpasswort'

Hast Du eine Idee was jetzt falsch ist?

beste grüße
Sam Hawkins
 
Posts: 5
Joined: 11. October 2005 11:52

Postby Sam Hawkins » 11. October 2005 15:14

Hallo Wiedmann,
vielen Dank für Deinen Beitrag, habe Deine Möglichkeit ausprobiert, ist aber genau das gleiche Ergebnis wie ich es oben beschrieben habe.

Sam
Sam Hawkins
 
Posts: 5
Joined: 11. October 2005 11:52

Postby Wiedmann » 11. October 2005 15:38

ist aber genau das gleiche Ergebnis wie ich es oben beschrieben habe.

Du meinst dieses?:
Code: Select all
ERROR 1049 <42000>: Unknown database 'meinpasswort'


Evtl. solltest du dir dann meine Befehlszeile nochmal genau anschauen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Sam Hawkins » 11. October 2005 15:58

Hi Wiedmann,
habe nochmal genau hingesehen und siehe da:
zwischen ...-p und Passwort... darf kein Leerzeichen stehen.
Datenbank ist eingespielt.
Vielen Dank für eure Hilfe

Grüße von
Sam Hawkins
Sam Hawkins
 
Posts: 5
Joined: 11. October 2005 11:52


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 1 guest