Hilfe ;( MySQL funkt nicht mit den Shop?!

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

Hilfe ;( MySQL funkt nicht mit den Shop?!

Postby ThomasTK » 20. May 2003 19:30

Hallo, hab eine Frage zu MySQL und PHP,
hab von wampp2 installiert funktioniert auch wenn ich den test mache nur wenn ich meinen shop installieren möchte (trippshop von tripleU).
Da bekomme ich dann immer die meldungen

Warning: connect_database(inc/var_sql.inc.php) [function.connect-database]: failed to open stream: No such file or directory in C:\wampp2\htdocs\shop\php\inc\functions_general.inc.php on line 18

Warning: connect_database() [function.include]: Failed opening 'inc/var_sql.inc.php' for inclusion (include_path='\wampp2\php\pear\') in C:\wampp2\htdocs\shop\php\inc\functions_general.inc.php on line 18
Verbindung zur Datenbank fehlgeschlagen

bzw:

Warning: create_form() [function.include]: Failed opening 'inc/config.inc.php' for inclusion (include_path='\wampp2\php\pear\') in C:\wampp2\htdocs\shop\php\admin\inc\functions_config.inc.php on line 14


usw...

was mach ich falsch?! könnt ihr mir bitte helfen?! bin da noch ein ziemlicher anfangen, aber wnen ichs online mach funktiniert alles *seufz*


danke
lg
thomas

Oder vielelicht hab ich bei der Installatione einen Fehler gemacht, war/bin mir net sicher wie die pfade jetzt aussehen?! vorallem serverpfad?!

wäre um hilfe wirklich sehr dankbar!!!

die intallationsanleitung für den trippshop:

Schritt für Schritt...

1. Entpacken des Zipfiles
2. Alles was im Zipfile enthalten ist, auf den Server schieben.
3. Rechte auf den Verzeichnissen und Dateien setzen.

Verzeichnisse:
/php/images chmod 777 und group, user nobody
/php/layout chmod 777 und group, user nobody

Dateien:
/php/inc/

config.inc.php chmod 777
var_sql.inc.php chmod 777
order_id.cfg chmod 777
... alle Layouts in dem Layoutfolder auf chmod 777

/php/admin/logs

basket_log.txt chmod 777
order_log.txt chmod 777

Kurze Erläuterung zu der Datein order_id.cfg:

Hier muss eine Nummer eingetragen werden, die später mit dem Präfix und dem Monat/Jahr
die Bestellnummer ergibt. (Bsp: 1000000 --> ergibt die Bestellnummer B/302_1000000)
Der Präfix wird über die Grundkonfiguration im Adminbereich eingestellt.

4. Grundkonfiguration

Hier ist es absolut wichtig, dass die richtigen Pfade eingegeben werden !!!

Serverpfad zum Shop muss so aussehen: /var/www/.../.../ --> bis zum Verzeichnis /php/... des Shops
Onlinepfad zum Shop muss so aussehen: http://your.domain.de/path_to_shop --> ohne / am Ende
SSL Pfad zum Shop muss so aussehen : https://your.domain.de/path_to_shop --> Wenn kein SSL möglich ist, dann http://
ThomasTK
 

Tut mir leid für das Doppelposting, war ein versehen ;( (nt)

Postby ThomasTK » 20. May 2003 19:36

tut mir leid!
ThomasTK
 

Postby DJ DHG » 20. May 2003 19:45

Moin Moin

warum ein doppel post? hast dich im browser verklickt oder wie?

No such file or directory in C:\wampp2
\htdocs\shop\php\inc\functions_general.inc.php on line 18


gibt es den ordner und die datei wirklich?

Warning: create_form() [function.include]: Failed
opening 'inc/config.inc.php' for inclusion (include_path='\wampp2\php\pear\') in
C:\wampp2\htdocs\shop\php\admin\inc\functions_config.inc.php on line 14


hierfür schaust du dir das hier mal an

http://forum.apachefriends.org/viewtopic.php?t=889

config.inc.php chmod 777


alle dürfen alles mit der datei?

mfg DJDHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby Thomas » 21. May 2003 12:23

Hallo DJ DHG,

naja net direkt im Browser verklickt, hab beim ersten mal abgeborchen hat aber anscheindet trotzdem gepostet! :?


gibt es den ordner und die datei wirklich?


Jep das ist alles richtig, möglicherweise liegt es an das ...

...
hierfür schaust du dir das hier mal an

http://community.apachefriends.org/f//viewtopic.php?t=889
...


muß ich noch probieren, bin schon gespannt hoffe es funkt dann :wink:

alle dürfen alles mit der datei?
eh naja naja schaut so aus :? eh aber die chmod 777 kann ich bei wampp2 eh niergens einstellen oderso?!

Danke für deine Hilfe!

mfg
Thomas
Thomas
 

Funktiniert trotzdem nicht ;(

Postby Thomas » 22. May 2003 09:00

Hallo,

hierfür schaust du dir das hier mal an

http://community.apachefriends.org/f//viewtopic.php?t=889


Hab das versucht auszuprobieren, aber mein File war anscheindend schon ein neueres, war korrekt angegeben alles. Es funktiniert aber trotzdem nicht, immer noch überall die gleichen Fehlermeldunge, woran liegt könns den sonst noch liegen?!

mfg
Thomas
Thomas
 

Danke, haut doch hin ;)

Postby Thomas » 23. May 2003 07:42

Hallo, das mit der falschen Pfadangabe in der php.ini hat doch funktioniert! Hab mich beim ersten versuch leider in der Zeile geirrt ;(

Aber eine Fehlermeldung ist geblieben und zwar,

Code: Select all
Warning: setlocale() [function.setlocale]: Passing locale category name as string is deprecated. Use the LC_* -constants instead. in C:\wampp2\htdocs\php\home.php on line 4


in der datei siehst das so aus

Code: Select all
<?
    include("../php/inc/config.inc.php");
         
    setlocale("LC_TIME", "ge");
    $today = strftime("%A, %d %B %Y");
?>



Woran lann den das liegen?!

Danke
mfg
Thomas
Thomas
 


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 3 guests