ID mit Auto_Increment zählt nicht mehr hoch

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

ID mit Auto_Increment zählt nicht mehr hoch

Postby AlexPausB » 14. April 2005 07:20

Moin,

ich hab hier ein für mich ganz merkwürdiges Problem:

Ich habe eine Tabelle mit "sid" als Primärschlüssel mit AUTO_INCREMENT.

Nach und nach habe ich Datensätze - teils manuell, teils Import - eingefügt.
Aktuell habe ich 116 Datensätze in der Datenbank ABER:

- auto_increment steht auf 127
- auto_increment wird nicht mehr erhöht

Das ganze gibt dann folgendes Problem:

Legt man neue Datensätze an, klappt das genau EINMAL, danach meckert phpmyAdmin es gibt schon einen Datensätz mit der sid 127.

Das Problem besteht auch, wenn ich:

- die gewünschte sid mit angebe
- unter Operationen den auto_increment Wert auf 117 zurücksetze

Was zum Henker ist das? Woran kann das liegen?

Danke und Gruß
ein etwas verzweifelter Alex
AlexPausB
 
Posts: 471
Joined: 05. February 2003 11:19
Location: Fdorf

Postby adi99 » 14. April 2005 18:41

Was hast du für einen typ ausgewählt? tinyint? wenn ja, stell das auf integer(int)
User avatar
adi99
 
Posts: 115
Joined: 15. January 2004 16:08
Location: Switzerland

Postby Stefan » 14. April 2005 19:06

Mahlzeit,

zur Erklärung:

Tinyint -> Wertebereich von -127 bis 127 UNSIGNED von 0 - 255

Wie es weitergeht verrät das Manual.


ciao, Stefan
User avatar
Stefan
 
Posts: 475
Joined: 26. December 2002 22:36
Location: Mitten in der sonnigen Südpfalz

Postby AlexPausB » 16. April 2005 12:32

Aaaaaaaah - damned!

Es ist natürlich tinyint... Vielen Dank!

Der Tag ist gerettet :)
AlexPausB
 
Posts: 471
Joined: 05. February 2003 11:19
Location: Fdorf


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 3 guests