Performance von MySQL

Alles, was MySQL betrifft, kann hier besprochen werden.

Performance von MySQL

Postby VBD » 14. May 2003 18:40

Hi,

habe hier mehere Rechner mit Wampp2 (alles W2K und SP3).
Bei den Systemen die den Microsoft SQL-Server verwenden läuft alles ohne Probleme. Bei den Systemen die auf MySQL aufsetzen geht die Performance total in die Knie z.B. PHPNuke 6.5 ohne Mods beim Aufruf der index.php so zwischen 5,5 und 9 Sekunden. Mit der gleichen Konfiguration auf einer Linux-Kiste (SuSE 8.2, Apache 1.3.26, MySQL 3.23.xx) Zeiten zwischen 0,05 und 0,08 Sekunden!
MySQL starte ich mittels Batch --debug wurde entfernt um etwas mehr Performance zu gewinnen. Leider ist die Performance noch immer indiskutabel. Weiss jemand Rat?

Gruss
Volker
VBD
 

Postby Oswald » 14. May 2003 22:50

Huhu Volker!

Hast Du einen Virenscanner oder etwas ähnliches am laufen? Wenn ja, mal abschalten und noch mal probieren.

Liebe Grüße,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby VBD » 15. May 2003 05:54

Hallo Kai,

Virenscanner gerade deaktiviert.... jezt liege ich ca. 1 Sekunde besser als vorher, aber immer noch unbefriedigend.....
Nuke wird zwar nicht genutzt ist aber für Performancetests gar nicht
schlecht...

Gruss
Volker
VBD
 

Postby Guest » 17. May 2003 22:53

hmm, das selbe phänomen habe ich auch ( http://community.apachefriends.org/f//viewtopic.php?t=1146 )

ich habe von

WAMPP 2.0.36

* WindowsApache + MySQL +PHP + Perl

+ Apache 2.0.36
+ MySQL 3.23.49
+ PHP 4.2
+ Perl 5.6.2


auf

WAMPP 2.0 (Server API Version)

* WindowsApache + MySQL +PHP + Perl

+ Apache 2.0.43
+ MySQL 3.23.54
+ PHP 4.3.1
+ Perl 5.8.0
+ mod_php 4.3.1
+ mod_perl 1.99
+ mod_ssl 2.0.44
+ openssl 0.9.6h


gewechselt. die performance von mysql ist dabei ins bodenlose gesackt. statements, die vorher nur weinige millisekunden benötigt haben, brauchen nun ein knappe sekunde. :o

liegt dies vielleicht an den startparametern in der mysql_start.bat?
wenn ich einfach jene aus der alten installation verwende

Code: Select all
mysql\bin\mysqld --console


laufen die abfragen wieder so performant wie gewohnt. :?:
Guest
 


Return to MySQL

Who is online

Users browsing this forum: No registered users and 1 guest