php nuke database kompatibilitätsprobleme, sql datenbank hat

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

php nuke database kompatibilitätsprobleme, sql datenbank hat

Postby Sky » 16. February 2005 14:38

hallo,
gleich zum problem, ich habe eine homepage mit php nuke entworfen. ich habe sie komplett am localem rechner gestalltet und ausgearbeitet. dazu verwendete ich xampp. auf xampp läut sql mit der version 4.1.8 auf dem webspace (strato) aber version 4.0.12
deshalb kann ich die sql datenbank nicht mit php my admin einlesen, da ich immer den fehler

MySQL meldet:

#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'collate ascii_bin NOT NULL default '',
`password` varchar(60)

erhalte.
(um den lösungsansätzen, das es ein pw sein kann das da nicht gesetzt ist entgegenzuwirken, lösche ich den eintrag aus der db, wird der nächste als fehler ausgegeben.)

ich hoffe auf hilfe, danke schonma
Sky
 
Posts: 5
Joined: 16. February 2005 14:27

Postby Wiedmann » 16. February 2005 14:47

Such mal im Forum nach "mysqldump".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Sky » 16. February 2005 14:57

und dann ???
Sky
 
Posts: 5
Joined: 16. February 2005 14:27

Postby deepsurfer » 16. February 2005 15:08

User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Sky » 16. February 2005 15:20

sorry :wink:
jetzt hats geklappt, bzw ich habs bis zu einem andrem fehler geschaft.
danke leute.

jetz hab ich
#1005 - Can't create table './DB117445/book_auth.frm' (errno: 140)

falls jemand grade weiß was das ist, sagts mir bitte, ich google mir hier heute mit dieser blöden datenbank schon nen affen :(
Sky
 
Posts: 5
Joined: 16. February 2005 14:27


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 6 guests