Schon wieder Versionsproblem

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

Schon wieder Versionsproblem

Postby gerd2304 » 13. February 2005 22:23

Hallo Leute,

das Problem mit den Versionen von MySQL wurde hier ja vielfach besprochen. Ich suche jetzt hier schon seit Stunden, werde aber nicht so recht schlau.
Mein Provider hat MySQL 4.0.16 Von dem Server habe ich per PHPMyAdmin ein Backup gezogen.
Auf meinem Rechner habe ich XAMPP mit MySQL 4.1.8
Bekomme, wenn ich mit MySQL-Front oder auch PHPMYAdmin die Datei einspielen möchte diesen 1064 Error.

Die Backupdatei heißt usr_1635_1.sql
Die Datenbank heißt usr_1635_1

Was ist nun mit dem mysqldump.exe --compatible blabla ? Ist der überhaupt in diesem Falle richtig? Oder macht der ein Backup der Datenbank auf Localhost??
Auf meinem Webspace habe ich keinen Shellzugang.

Stehe total auf dem Schlauch. Bitte ganz dringend um Hilfe.

Grüße
Gerd
gerd2304
 
Posts: 11
Joined: 13. February 2005 22:08

Postby Wiedmann » 13. February 2005 23:16

Bekomme, ... diesen 1064 Error.

Geht es auch weniger genauer?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby gerd2304 » 14. February 2005 07:24

Entschuldigung. Hier der SQL-Befehl:

CREATE TABLE bb1_object2board(

boardid int( 11 ) NOT NULL default '0',
objectid int( 11 ) NOT NULL default '0',
mod int( 1 ) NOT NULL default '0',
boardpermission int( 1 ) NOT NULL default '0',
startpermission int( 1 ) NOT NULL default '0',
replypermission int( 1 ) NOT NULL default '0'
) TYPE = MYISAM


und hier die Fehlermeldung:

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'mod int(1) NOT NULL default '0',
boardpermission int(1) NOT NULL default '0',
' at line 4



Die Datenbank ist mit ca 50 MB groß.
gerd2304
 
Posts: 11
Joined: 13. February 2005 22:08

Postby Wiedmann » 14. February 2005 11:55

Von dem Server habe ich per PHPMyAdmin ein Backup gezogen.
#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'mod int(1) NOT NULL default '0',
boardpermission int(1) NOT NULL default '0',
' at line 4


Beim Export aus phpMyadmin musst du folgende Option aktivieren:
[x] Tabellen- und Feldnamen in einfachen Anführungszeichen
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby gerd2304 » 16. February 2005 18:19

Vielen Dank Wiedmann. Hat prima funktioniert.
gerd2304
 
Posts: 11
Joined: 13. February 2005 22:08


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 1 guest