PHP parst meine Dateien nicht

Alles, was PHP betrifft, kann hier besprochen werden.

PHP parst meine Dateien nicht

Postby benjoe » 08. September 2004 11:05

Ich hab XAMPP auf dem NT-Server im LAN installiert.

Die mitgelieferten Scripte (phpMyAdmin etc.) funktionieren wunderbar.
Nur meine Scripte werden nicht geparst, obwohl richtige Endung (.php) und korrekte PHP-Syntax. Datei liegt auch in einem Unterordner "htdocs".

Wo ist der Fehler?
benjoe
 
Posts: 3
Joined: 08. September 2004 10:57
Location: Hattingen

Postby Wiedmann » 08. September 2004 11:11

Wie rufst du die Scripte denn auf?

Evtl. ein Beispiel - Script von dir vorhanden?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby benjoe » 08. September 2004 13:12

Der Aufruf sieht so aus http://192.168.x.x/ordner/script.php und ist imho richtig. Die xampp-eigenen Scripte laufen ja auch.

Code: Select all
...
<? m="s";if(name=="" or email=="" or message==""):m="";
echo"hello"; ?>
...

Der Code ist imho auch richtig. Aber ich bekomme den gesamten Quelltext (incl. PHP) ausgespuckt (Im Browser wird das HTML interpretiert).
benjoe
 
Posts: 3
Joined: 08. September 2004 10:57
Location: Hattingen

Postby Wiedmann » 08. September 2004 15:18

"192.168.x.x" kann eigentlich nicht richtig sein...

<?

Probiere es mal mit:
<?php
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby benjoe » 08. September 2004 15:30

Mit <?php hab ich es auch schon getestet!

Warum sollte 192.168.usw nicht funktionieren (natürlich sind da keine x sondern ebenfalls Nummern). Ist im LAN die IP des Servers!
benjoe
 
Posts: 3
Joined: 08. September 2004 10:57
Location: Hattingen


Return to PHP

Who is online

Users browsing this forum: No registered users and 1 guest