Support for PHP 5.6.x?

Alles, was PHP betrifft, kann hier besprochen werden.

Support for PHP 5.6.x?

Postby Aar » 18. November 2014 18:41

Hello Apache Friends Support,

Can you tell me when there a update planned op XAMPP, where PHP can be updated to 5.6.x?
This is because the support in PHP of htmlspecialchars() in association with ISO-8858-1 what is 'broken' in PHP 5.4 and 5.5.

Can anyone tell me when PHP 5.6. comes out for XAMPP, and hat te upgrade steps are?
Aar
 
Posts: 7
Joined: 18. November 2014 18:36
Operating System: Windows and Linux (non XAMPP)

Re: Support for PHP 5.6.x?

Postby Altrea » 18. November 2014 19:44

Hi Aar,

Aar wrote:Can you tell me when there a update planned op XAMPP, where PHP can be updated to 5.6.x?

Bitnami releases XAMPP versions consistently, so i am sure that (one of) the next XAMPP release will cover PHP 5.6

Aar wrote:This is because the support in PHP of htmlspecialchars() in association with ISO-8858-1 what is 'broken' in PHP 5.4 and 5.5.

It is not broken. You just need to specify the encoding with that functions because the default charset will not get determined by default.

Aar wrote:hat te upgrade steps are?

An upgrade is like a new installation/migration. You need to backup/export everything and restore everything.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Support for PHP 5.6.x?

Postby Aar » 18. November 2014 20:28

Yes, i know it's not 'broken' buts it's not backwardscompatible, and a little bit broken, for ISO 8858 applications ;)
Aar
 
Posts: 7
Joined: 18. November 2014 18:36
Operating System: Windows and Linux (non XAMPP)

Re: Support for PHP 5.6.x?

Postby Nobbie » 19. November 2014 20:39

Aar wrote:Yes, i know it's not 'broken' buts it's not backwardscompatible, and a little bit broken, for ISO 8858 applications ;)


Simply provide the default charset and it is not only working, but also backwardscompatible. This is by far easier, faster and better than waiting for a new release. It is your decision...
Nobbie
 
Posts: 8758
Joined: 09. March 2008 13:04

Re: Support for PHP 5.6.x?

Postby Aar » 19. November 2014 21:46

Nobbie wrote:
Aar wrote:Yes, i know it's not 'broken' buts it's not backwardscompatible, and a little bit broken, for ISO 8858 applications ;)


Simply provide the default charset and it is not only working, but also backwardscompatible. This is by far easier, faster and better than waiting for a new release. It is your decision...

Better the PHP-developers must provide the default_charset option earlier, so i don't have to change 300 functions ;)
Aar
 
Posts: 7
Joined: 18. November 2014 18:36
Operating System: Windows and Linux (non XAMPP)

Re: Support for PHP 5.6.x?

Postby Nobbie » 19. November 2014 23:49

Aar wrote:Better the PHP-developers must provide the default_charset option earlier, so i don't have to change 300 functions ;)


No problem, its on you, so wait for a solution...
Nobbie
 
Posts: 8758
Joined: 09. March 2008 13:04

Re: Support for PHP 5.6.x?

Postby Aar » 20. November 2014 00:19

i know ;)
Aar
 
Posts: 7
Joined: 18. November 2014 18:36
Operating System: Windows and Linux (non XAMPP)


Return to PHP

Who is online

Users browsing this forum: No registered users and 2 guests