problem mit IF-schleife ...

Alles, was PHP betrifft, kann hier besprochen werden.

problem mit IF-schleife ...

Postby HENNER » 21. July 2004 21:13

Hi,

habe hier ein problem mit einem script.

die fehlermeldung lautet:

Parse error: parse error, unexpected T_IF in c:\www\xampp\gal_edit.php on line 73"

die entsprechende stelle:

Code: Select all
$kcdmember = $row->kcd_member;

if ($kcdmember)
  {
  $kcd = "<select name=\"kcd_member\"><option value=\"1\" selected>ja</option><option value=\"2\">nein</option></select>";
  }
 else
  {
  $kcd = "<select name=\"kcd_member\"><option value=\"1\">ja</option><option value=\"2\" selected>nein</option></select>";
  }


jo, sobald ich diese zeilen kommentiere, kommt keine fehlermeldung mehr ... aber was ist daran falsch ??
in der tabelle steht im feld kcd_member entweder 0 oder 1 ...

ich hoffe jemand von euch kann mir helfen !!

HENNER
HENNER
 
Posts: 23
Joined: 07. March 2004 15:06

Postby Wiedmann » 21. July 2004 23:59

Code: Select all
$kcdmember = $row->kcd_member;
                             ^

Bist du sicher das dieses Semikolon auch wirklich in deinem Script steht? Jedenfalls kommt die Fehlermeldung von einem Fehler vor diesem "if".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby emrox » 28. July 2004 13:51

@Wiedmann: in dem falle wuerde eine andere fehlermeldung kommen

@HENNER: versuchs mal mit einer genaueren abfrage .. z.b. if (!empty($kcdmember)) { ...
..,-
emrox
 
Posts: 2
Joined: 28. July 2004 13:38

Postby Wiedmann » 28. July 2004 15:09

In dem Fall würde genau diese kommen...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to PHP

Who is online

Users browsing this forum: No registered users and 1 guest