Upload bricht nach 4 Min ab / max_execution_time=1200

Alles, was PHP betrifft, kann hier besprochen werden.

Upload bricht nach 4 Min ab / max_execution_time=1200

Postby spacewalker » 07. August 2013 15:13

Hallo,

ich versuche eine Datei hochzuladen (per POST)
Der Upload bricht nach ca. 4 Min bzw. ca. 900MB ab.
Als Fehler wird am Server folgendes protokolliert:
PHP Fatal error: Maximum execution time of 1200 seconds exceeded in C:\xampp\htdocs\uploader3.php on line 7


Nun sind 1200 Sekunden ja nicht 4 Minuten - daher scheint diese Meldung nicht korrekt zu sein.
Warum bricht der Upload dann aber ab?

Code: Select all
Uploader3.php:
1:<html>
2:<head>
3:<meta charset='utf-8'>
4:<title>Upload File</title>
5:</head>
6:<body>
7:<?php
8:
9:echo date("H:i:s") . ": start skript " . $_SERVER["PHP_SELF"];
...


Weitere Einstellungen sind:
upload_max_filesize = 4000M
post_max_size = 4000M

Der Server läuft unter Windows2008R2, XAMPP Version: 1.8.2

Danke
spacewalker
 
Posts: 13
Joined: 25. July 2013 09:46
Operating System: Windows 2008R2

Re: Upload bricht nach 4 Min ab / max_execution_time=1200

Postby Nobbie » 08. August 2013 09:29

Setze doch mal auf 0 (= kein Limit), was passiert dann? Außerdem gibt es noch die Variable max_input_time, sollte auch entsprechend hoch gesetzt werden.

Der Code Schnipsel ist übrigens völlig unbrauchbar, was soll das sein?
Nobbie
 
Posts: 8761
Joined: 09. March 2008 13:04


Return to PHP

Who is online

Users browsing this forum: No registered users and 2 guests