PostgreSQL (postgres) & PHP

Alles, was PHP betrifft, kann hier besprochen werden.

PostgreSQL (postgres) & PHP

Postby Chris S. » 20. April 2004 14:43

Hallo,

ich versuche gerade, auf einem Linux-Rechner, auf dem LAMPP 1.4.4 bislang super und absolut zufriedenstellend läuft, per PHP eine PostgreSQL-Datenbank anzusprechen. Weil das PHP aber offensichtlich nicht für den postgres-support kompiliert wurde, bekam ich die Fehlermeldung mit dem Hinweis, PHP erneut mit --with-pgsql zu kompilieren.

So weit, so gut, ich habe das Entwicklerpaket von LAMPP noch runtergeladen, die aktuelle PHP-Version 4.3.6 genommen und configure durchlaufen lassen. Auch das lief dann gut durch (nachdem ich den Oracle und Interbase-Support rausgenommen habe, denn ich brauche den eh nicht).

Problem: make bricht den Kompiliervorgang ab, weil es einige Fehlermeldungen in der PHP-Datei ext/gd/libgd/gd_png.c gibt. Kann mir bitte jemand einen Tipp geben, ich bin nämlich absolut nicht der Linux-Guru, muß aber irgendwie per PHP die PostgreSQL-Datenbank ansprechen. Oder kann ich da irgendwie drumrum kommen???

Vielen Dank schon mal im voraus!!!
Chris
Chris S.
 
Posts: 1
Joined: 20. April 2004 14:01
Location: Rheinland

Return to PHP

Who is online

Users browsing this forum: No registered users and 3 guests