PHP läuft nicht!

Alles, was PHP betrifft, kann hier besprochen werden.

PHP läuft nicht!

Postby Enzian » 11. March 2004 09:32

Hallo

Habe jetzt schon mehrere Installationen versucht, und immer wieder deaktiviert und gelöscht weil es nicht klappt.

Na, Apache läuft, das ist nun soweit gut. doch wenn ich php-Files öffnen will, öffnet sich der Code (über die Aufforderung "speichern" oder "öffnen") Also Der Browser, oder der Server erkennt die Files eben als File und interpretiert sie nicht.

Was habe ich bisher gemacht?
- PHP auf die Ebene C entpackt, den Ordner habe ich nun extra mal nicht umbenannt, so liegt es auf c:/php-4.3.4-Win32
php.ini.dist ist umbenannt in php.ini und liegt im WINNT zudem habe ich bei extension_dir extension_dir = "c:\php-4.3.4-Win32\extensions" eingesetzt
die beiden php4ts.dll und php4ts.lib sind im System32
Bei httpd.conf im Apache habe ich
beim SariptAlias cgi auch noch ScriptAlias /php/ "C:/php-4.3.4-Win32/" eingesetzt und AddType application/x-httpd-php .php aktiviert

Eine Anleitung verlant auch noch das einsetzen von Action application/x-http-php "/php-4.3.4-Win32/php.exe" aber das geht nicht, das gibt eine Fehlermeldung

Was um Himmelswillen mache ich immer falsch, dass die PHP-Files nicht angezeigt werden?

Danke für die Hilfe
Enzian
 
Posts: 26
Joined: 10. March 2004 23:45

Postby boppy » 11. March 2004 15:47

Handelt es sich bei deinem Download um einen XAMPP??? KLingt nämlich, als ob du PHP einzeln herunter geladen hast. Versuch es einfach mal mit XAMPP:

http://www.apachefriends.org/xampp-windows.html

Dann brauchst du nämlich überhaupt gar nix mehr installieren...
...in diesem Sinne
yours boppy

Interpunktion und Orthographie dieses Beitrags sind frei erfunden.
Eine Übereinstimmung mit aktuellen oder ehemaligen Regeln wäre rein zufällig und ist nicht beabsichtigt.
User avatar
boppy
AF Moderator
 
Posts: 501
Joined: 27. December 2002 02:15
Location: W-E-City


Return to PHP

Who is online

Users browsing this forum: No registered users and 4 guests