Skriptfehlermeldung auf neuem Rechner Windows 7

Alles, was PHP betrifft, kann hier besprochen werden.

Skriptfehlermeldung auf neuem Rechner Windows 7

Postby juan_antonio » 27. December 2010 16:55

Hallo,

eine Frage:

Ich habe ein PHP-Projekt auf einem alten Rechner mit Windows XP laufen gehabt, hab das Projekt jetzt auf einen neuen Rechner mit Windows 7 draufgespielt. Als XAMPP-Paket hab ich das selbe genommen wie auf dem alten Rechner, ist also nicht mehr das Neueste. Genaue Version von XAMPP: 2.1 von 2005.
Die Testumgebung läuft aber soweit, d.h. als ich XAMPP installiert hatte kam wie immer die Meldung: Installation erfolgreich und die Startseite mit den weiteren Infos.

Jetzt zu dem eigenen PHP-Skript, eine index.php:

Dort habe ich mittels der "include"-Anweisung, Dateien inkludiert und zwar sah das so aus:

Code: Select all
<?php
include ("config.php");
?>


Und dann weiter unten:

Code: Select all
<?php
include ("$head");
?>


Ich hab also in der Config.php lauter Variablen definiert, die dann als Wert eine Pfadangabe hatten.
z.B.

Code: Select all
$head="http://localhost/xampp/First_Presentation/Songdataformulare_alt/header.php";


Und das hat dann funktioniert auf meinem alten Rechner.

Beim neuen Rechner kommt da eine Fehlermeldung:

Warning: include(http://localhost/xampp/First_Presentati ... reload.php) [function.include]: failed to open stream: Ein Verbindungsversuch ist fehlgeschlagen, da die Gegenstelle nach einer bestimmten Zeitspanne nicht richtig reagiert hat, oder die hergestellte Verbindung war fehlerhaft, da der verbundene Host nicht reagiert hat. in C:\xampp\xampp\htdocs\xampp\First_Presentation\Songdataformulare_alt\Songtextabfrage\songtextbeginn.php on line 11

Warning: include() [function.include]: Failed opening 'http://localhost/xampp/First_Presentation/Songdataformulare_alt/js_preload.php' for inclusion (include_path='.;C:\xampp\xampp\php\pear\') in C:\xampp\xampp\htdocs\xampp\First_Presentation\Songdataformulare_alt\Songtextabfrage\songtextbeginn.php on line 11

Fatal error: Maximum execution time of 60 seconds exceeded in C:\xampp\xampp\htdocs\xampp\First_Presentation\Songdataformulare_alt\Songtextabfrage\songtextbeginn.php on line 18


In dem Beispiel findet er die "js_preload.php" nicht, die hatte ich genauso mit einer Variable in der index.php inkludiert, vom Prinzip dasselbe wie mit der "header.php", die er nicht findet, wenn in der index.php nur include ("$head") drin steht.

Wenn ich jetzt statt der Variablen $head, gleich die richtige Datei angebe, also "header.php" macht er es aber wieder so wie er es soll.

Ich würde aber gern wissen, ob ich es nicht so lassen kann wie bisher und es vielleicht irgendetwas anderes ist, was ich vielleicht einfach noch einstellen muß. Vielleicht gibt es noch was in der PHP.ini-Datei oder ähnlichem zum einstellen????
Denn wenn es auf dem einen Rechner funktioniert, warum nicht auch auf dem anderen.

Gruß

juan_antonio
juan_antonio
 
Posts: 1
Joined: 23. December 2010 14:49

Return to PHP

Who is online

Users browsing this forum: No registered users and 1 guest